Sending mail from xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Sending mail from xampp

Postby paulm » 13. February 2014 01:44

I am having a problem sending mail on a windows 8 - 64 bit machine. At the office I am using windows 7 and everything works fine. I am using the same settings at home but it doesn't work. Are there any known issues with windows 8? I have attached the php.ini and the sendmail.ini.

Code: Select all
[mail function]
; XAMPP: Comment out this if you want to work with an SMTP Server like Mercury
; SMTP = localhost
; smtp_port = 25

; For Win32 only.
;sendmail_from = postmaster@localhost

; XAMPP IMPORTANT NOTE (1): If XAMPP is installed in a base directory with spaces (e.g. c:\program filesC:\xampp) fakemail and mailtodisk do not work correctly.
; XAMPP IMPORTANT NOTE (2): In this case please copy the sendmail or mailtodisk folder in your root folder (e.g. C:\sendmail) and use this for sendmail_path. 
; XAMPP: Comment out this if you want to work with fakemail for forwarding to your mailbox (sendmail.exe in the sendmail folder)
sendmail_path = "\"C:\xampp\sendmail\sendmail.exe\" -t"

; XAMPP: Comment out this if you want to work with mailToDisk, It writes all mails in the C:\xampp\mailoutput folder
; sendmail_path="C:\xampp\mailtodisk\mailtodisk.exe"

Code: Select all

; smtp port (normally 25)


; SMTPS (SSL) support
;   auto = use SSL for port 465, otherwise try to use TLS
;   ssl  = alway use SSL
;   tls  = always use TLS
;   none = never try to use SSL


; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify


; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging


; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging


; if your smtp server requires authentication, modify the following two lines

These settings work fine in windows 7
Posts: 1
Joined: 13. February 2014 01:36
XAMPP Version: 1.8.3-1
Operating System: windows 8 - 64bit

Re: Sending mail from xampp

Postby StokeMike » 11. August 2014 20:50

I am glad that I am not the only one with the same problem. 2 laptops side by side, one running Windows 7 and the other Windows 8.1. The Windows 7 works perfectly whereas the Windows 8.1 just does not deliver the email. .ini scripts identical to yours (except I use aol). Nothing in the error log.
Have you had any success?
Posts: 1
Joined: 11. August 2014 20:44
XAMPP Version: 5.6.3
Operating System: Windows 8.1

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests