Problems with Apache - local host

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems with Apache - local host

Postby emm_lou » 12. February 2014 00:46

Hello,

As there was a conflict I had to change the port used from 80 to 88.

However, it cannot find the XAMPP splash page when I use http://localhost:88.

Although it can find it when I use http://127.0.0.1:88/xampp/.

But I cannot find my htdocs from this to run any of my files.

Can anyone please help me to get localhost:88 to work, or explain how I can use my htdocs from http://127.0.0.1:88/xampp/.


Thank you :)
emm_lou
 
Posts: 5
Joined: 08. February 2014 18:19
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Problems with Apache - local host

Postby JJ_Tagy » 12. February 2014 00:59

If 127.0.0.1 works but not localhost, it is possible your Windows hosts file has that line commented out or no entry. If you want to try, your htdocs folder would be http://127.0.0.1:88/ (not xampp as that takes you to the htdocs/xampp folder).

As a side note, you should consider going back to port 80 and find the offending application using 80 and change it.
JJ_Tagy
 
Posts: 544
Joined: 30. January 2012 13:44
XAMPP Version: 1.8.3
Operating System: Windows 7 x64

Re: Problems with Apache - local host

Postby emm_lou » 12. February 2014 01:03

I did try http://127.0.0.1:88/ but the browser just fills in the xampp after it :S

Do you know how I would find what is using port 80, and how I would stop it?
emm_lou
 
Posts: 5
Joined: 08. February 2014 18:19
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Problems with Apache - local host

Postby JJ_Tagy » 12. February 2014 01:24

emm_lou wrote:I did try http://127.0.0.1:88/ but the browser just fills in the xampp after it :S

That's because index.php automatically forwards to XAMPP landing page.

emm_lou wrote:Do you know how I would find what is using port 80, and how I would stop it?

There is a netstat button on the control panel window. Stopping it depends in what is running.
JJ_Tagy
 
Posts: 544
Joined: 30. January 2012 13:44
XAMPP Version: 1.8.3
Operating System: Windows 7 x64

Re: Problems with Apache - local host

Postby emm_lou » 12. February 2014 01:29

How to I stop it from writing XAMPP after it?

The netstat say: port:80, PID:4, Name:System
emm_lou
 
Posts: 5
Joined: 08. February 2014 18:19
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Problems with Apache - local host

Postby JJ_Tagy » 12. February 2014 01:40

It is probably Microsoft IIS. You can remove the it in Control Panel -> Programs and Features -> Turn Windows features on or off.

Open htdocs/index.php in your favorite editor to address the redirection.
JJ_Tagy
 
Posts: 544
Joined: 30. January 2012 13:44
XAMPP Version: 1.8.3
Operating System: Windows 7 x64

Re: Problems with Apache - local host

Postby emm_lou » 12. February 2014 01:48

<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>
Something is wrong with the XAMPP installation :-(

This is my index.php . how do I change it to redirect it??

-------Thank you for your help by the way :)
emm_lou
 
Posts: 5
Joined: 08. February 2014 18:19
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Problems with Apache - local host

Postby JJ_Tagy » 12. February 2014 02:44

Edit that page to be whatever you want.

Code: Select all
header('Location: '.$uri.'/xampp/');

is the redirection code.
JJ_Tagy
 
Posts: 544
Joined: 30. January 2012 13:44
XAMPP Version: 1.8.3
Operating System: Windows 7 x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests