Problem with Win 8.1 (64) and Xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with Win 8.1 (64) and Xampp

Postby zdenko » 08. February 2014 18:50

I have WIN 8.1 (64) and xampp-win32-1.8.3-2-VC11.
After starting XAMPP Control Panel sent me information for port 443 is used from other application (vmware). Therefore I change port from 443 to 440, and start again. After restarting XAMPP Control Panel constantly standing in the same place and nothing happens. The screen is a situation showed down.
Does anyone have an idea what could be the problem?
Thanks in advance.

18:24:39 [main] Initializing Control Panel
18:24:39 [main] Windows Version: Windows 8 Pro 64-bit
18:24:39 [main] XAMPP Version: 1.8.3
18:24:39 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
18:24:39 [main] You are not running with administrator rights! This will work for
18:24:39 [main] most application stuff but whenever you do something with services
18:24:39 [main] there will be a security dialogue or things will break! So think
18:24:39 [main] about running this application with administrator rights!
18:24:39 [main] XAMPP Installation Directory: "d:\xampp\"
18:24:39 [main] Checking for prerequisites
18:24:39 [main] All prerequisites found
18:24:39 [main] Initializing Modules
18:24:39 [main] Starting Check-Timer
18:24:39 [main] Control Panel Ready
18:24:42 [Apache] Attempting to start Apache app...
Little help from friends is a big help ...
User avatar
zdenko
 
Posts: 4
Joined: 27. November 2005 10:56
XAMPP Version: 5.5.19
Operating System: Win 8.1 (64)

Re: Problem with Win 8.1 (64) and Xampp

Postby gsmith » 08. February 2014 21:29

18:24:39 [main] You are not running with administrator rights! This will work for
18:24:39 [main] most application stuff but whenever you do something with services
18:24:39 [main] there will be a security dialogue or things will break! So think
18:24:39 [main] about running this application with administrator rights!


Apache runs as a service, so try running the control as Administrator. You can right-click on it's icon and down at the bottom of the screen (if at the big ugly start screen) there should be an option to "Run as Administrator." If you're on the desktop when you right-click the icon a menu will pop up and it will be there.
gsmith
 
Posts: 123
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP Version: 5.6.3
Operating System: Win XP to 8.1/VS 6,9-12

Re: Problem with Win 8.1 (64) and Xampp

Postby zdenko » 09. February 2014 08:30

Yes, I try as admin, but situation is same...

8:29:31 [main] Initializing Control Panel
8:29:31 [main] Windows Version: Windows 8 Pro 64-bit
8:29:31 [main] XAMPP Version: 1.8.3
8:29:31 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
8:29:31 [main] Running with Administrator rights - good!
8:29:31 [main] XAMPP Installation Directory: "d:\xampp\"
8:29:31 [main] Checking for prerequisites
8:29:31 [main] All prerequisites found
8:29:31 [main] Initializing Modules
8:29:31 [main] Starting Check-Timer
8:29:31 [main] Control Panel Ready
8:29:36 [Apache] Attempting to start Apache app...
Little help from friends is a big help ...
User avatar
zdenko
 
Posts: 4
Joined: 27. November 2005 10:56
XAMPP Version: 5.5.19
Operating System: Win 8.1 (64)

Re: Problem with Win 8.1 (64) and Xampp

Postby Altrea » 09. February 2014 08:37

We need additional information like the Apache error.log and the response of the apache_start.bat script
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6670
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Problem with Win 8.1 (64) and Xampp

Postby zdenko » 09. February 2014 08:48

I think problem is resolved.
After changing all default port 443 to 440 in file httpd-ssl.conf all works fine. Now situatios is as:

8:50:25 [main] Initializing Control Panel
8:50:25 [main] Windows Version: Windows 8 Pro 64-bit
8:50:25 [main] XAMPP Version: 1.8.3
8:50:25 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
8:50:25 [main] Running with Administrator rights - good!
8:50:25 [main] XAMPP Installation Directory: "d:\xampp\"
8:50:25 [main] Checking for prerequisites
8:50:25 [main] All prerequisites found
8:50:25 [main] Initializing Modules
8:50:25 [main] Starting Check-Timer
8:50:25 [main] Control Panel Ready
8:50:29 [Apache] Attempting to start Apache app...
8:50:29 [Apache] Status change detected: running
8:50:33 [mysql] Attempting to start MySQL app...
8:50:33 [mysql] Status change detected: running


When I changed that port in XAMPP Control Panel it was useless.

Regards.
Little help from friends is a big help ...
User avatar
zdenko
 
Posts: 4
Joined: 27. November 2005 10:56
XAMPP Version: 5.5.19
Operating System: Win 8.1 (64)

Re: Problem with Win 8.1 (64) and Xampp

Postby guntersammet » 08. August 2014 18:49

Maybe a bit late for you but maybe it helps somebody down the road. Sometimes Skype runs on port 80. You would need to change the Skype port in that case.

Gunter
guntersammet
 
Posts: 4
Joined: 14. June 2007 18:43


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 30 guests