frontend white screen

Problems with the Windows version of XAMPP, questions, comments, and anything related.

frontend white screen

Postby tomrinkes » 26. January 2014 14:05

Hello,

I have a problem, if I install a site on Xampp the first day everything works fine.
But the next day when I view the frontend of the site the home page is white and nothing happens, the backend of the site is fine.

What is going wrong?.

Greetings,

Tom Rinkes
tomrinkes
 
Posts: 6
Joined: 26. January 2014 13:57
XAMPP Version: 1.8.3
Operating System: windows 7

Re: frontend white screen

Postby JJ_Tagy » 26. January 2014 15:32

With as little info you've given us, we have no idea what is wrong with "a" or "the" site.
JJ_Tagy
 
Posts: 515
Joined: 30. January 2012 13:44
XAMPP Version: 1.8.3
Operating System: Windows 7 x64

Re: frontend white screen

Postby Altrea » 26. January 2014 16:11

Hi Tom Rinkes,

Often a white screen contains some not printed information in the browsers sourcecode view.
Contents of your \xampp\apache\logs\error.log, \xampp\apache\logs\access.log and \xampp\php\logs\php_error_log can also give some insight.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: frontend white screen

Postby tomrinkes » 27. January 2014 10:31

Thanks for the replay

de error log looks like this

[Sun Jan 26 13:09:34.979329 2014] [ssl:warn] [pid 3496:tid 248] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Sun Jan 26 13:09:36.545419 2014] [mpm_winnt:notice] [pid 3496:tid 248] AH00455: Apache/2.4.7 (Win32) OpenSSL/0.9.8y PHP/5.4.22 configured -- resuming normal operations
[Sun Jan 26 13:09:36.545419 2014] [mpm_winnt:notice] [pid 3496:tid 248] AH00456: Apache Lounge VC10 Server built: Nov 26 2013 16:07:35
[Sun Jan 26 13:09:36.545419 2014] [core:notice] [pid 3496:tid 248] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Jan 26 13:09:36.688427 2014] [mpm_winnt:notice] [pid 3496:tid 248] AH00418: Parent: Created child process 5584
[Sun Jan 26 13:09:37.501473 2014] [ssl:warn] [pid 5584:tid 260] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Sun Jan 26 13:09:37.901496 2014] [ssl:warn] [pid 5584:tid 260] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Sun Jan 26 13:09:38.051505 2014] [mpm_winnt:notice] [pid 5584:tid 260] AH00354: Child: Starting 150 worker threads.
[Mon Jan 27 09:24:48.847028 2014] [ssl:warn] [pid 3396:tid 248] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jan 27 09:24:49.261051 2014] [core:warn] [pid 3396:tid 248] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Jan 27 09:24:49.613071 2014] [ssl:warn] [pid 3396:tid 248] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jan 27 09:24:52.747251 2014] [mpm_winnt:notice] [pid 3396:tid 248] AH00455: Apache/2.4.7 (Win32) OpenSSL/0.9.8y PHP/5.4.22 configured -- resuming normal operations
[Mon Jan 27 09:24:52.747251 2014] [mpm_winnt:notice] [pid 3396:tid 248] AH00456: Apache Lounge VC10 Server built: Nov 26 2013 16:07:35
[Mon Jan 27 09:24:52.747251 2014] [core:notice] [pid 3396:tid 248] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Jan 27 09:24:52.835256 2014] [mpm_winnt:notice] [pid 3396:tid 248] AH00418: Parent: Created child process 1684
[Mon Jan 27 09:24:53.644302 2014] [ssl:warn] [pid 1684:tid 260] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jan 27 09:24:54.019323 2014] [ssl:warn] [pid 1684:tid 260] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Jan 27 09:24:54.152331 2014] [mpm_winnt:notice] [pid 1684:tid 260] AH00354: Child: Starting 150 worker threads.

the acces log like this

::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/components/com_jnews/images/16/about.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:06 +0100] "GET /oud/administrator/components/com_jnews/images/16/jnewsletter_icon.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-plugin.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/components/com_jnews/images/16/statistics.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-install.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-module.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-checkin.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-massmail.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-info.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-themes.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-language.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/j_bottom.png HTTP/1.1" 304 - "http://localhost/oud/administrator/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/j_corner_br.png HTTP/1.1" 304 - "http://localhost/oud/administrator/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/j_corner_bl.png HTTP/1.1" 304 - "http://localhost/oud/administrator/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/components/com_mobilejoomla/images/mj16x16.gif HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/components/com_sh404sef/assets/images/menu-icon-sh404sef.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/menu/icon-16-help.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/lightgrey.jpg HTTP/1.1" 404 1268 "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:07 +0100] "GET /oud/administrator/templates/khepri/images/j_arrow_down.png HTTP/1.1" 304 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"
::1 - - [27/Jan/2014:09:26:08 +0100] "GET /oud/ HTTP/1.1" 500 - "http://localhost/oud/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36"

the php log like this

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Fatal error: Call to undefined method plgVmPaymentStandard::getVarsToPush() in C:\xampp\htdocs\oud\plugins\vmpayment\standard.php on line 37

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JLoader::import() should not be called statically in C:\xampp\htdocs\oud\libraries\loader.php on line 186

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JFile::exists() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\administrator\components\com_sh404sef\classes\filecache.php on line 417

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JPath::clean() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\libraries\joomla\filesystem\file.php on line 373

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JFile::delete() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\administrator\components\com_sh404sef\classes\filecache.php on line 418

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JLoader::import() should not be called statically in C:\xampp\htdocs\oud\libraries\loader.php on line 186

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JLoader::register() should not be called statically in C:\xampp\htdocs\oud\libraries\loader.php on line 71

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JLoader::load() should not be called statically in C:\xampp\htdocs\oud\libraries\loader.php on line 161

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JLoader::register() should not be called statically in C:\xampp\htdocs\oud\libraries\loader.php on line 138

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JClientHelper::getCredentials() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\libraries\joomla\filesystem\file.php on line 137

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JFactory::getConfig() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\libraries\joomla\client\helper.php on line 43

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JPath::clean() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\libraries\joomla\filesystem\file.php on line 155

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JFactory::getDBO() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\libraries\joomla\session\storage\database.php on line 84

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JTable::getInstance() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\libraries\joomla\session\storage\database.php on line 89

[27-Jan-2014 09:26:15 Europe/Berlin] PHP Strict Standards: Non-static method JFactory::getDBO() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\oud\libraries\joomla\database\table.php on line 112
tomrinkes
 
Posts: 6
Joined: 26. January 2014 13:57
XAMPP Version: 1.8.3
Operating System: windows 7

Re: frontend white screen

Postby Nobbie » 27. January 2014 11:54

This is not a Xampp problem, but a Joomla problem.
Nobbie
 
Posts: 6577
Joined: 09. March 2008 13:04

Re: frontend white screen

Postby Altrea » 27. January 2014 12:15

Nobbie is correct.

Have you checked that your Joomla version is compatible with your XAMPP components?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: frontend white screen

Postby tomrinkes » 27. January 2014 12:22

i'm not sure how this is done? my joomla version is 1.5.26 and i'm using 1.8.2 Xampp.
is this conpatible?
tomrinkes
 
Posts: 6
Joined: 26. January 2014 13:57
XAMPP Version: 1.8.3
Operating System: windows 7

Re: frontend white screen

Postby Altrea » 27. January 2014 13:22

No.

Joomla 1.5.X requires PHP 5.2.X. => http://www.joomla.org/technical-requirements.html
XAMPP 1.8.2 is shipped with PHP 5.4.X

The last XAMPP version with PHP 5.2.x was XAMPP 1.7.1
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: frontend white screen

Postby tomrinkes » 27. January 2014 13:38

thank you very much for helping me!

greetings,

Tom
tomrinkes
 
Posts: 6
Joined: 26. January 2014 13:57
XAMPP Version: 1.8.3
Operating System: windows 7

Re: frontend white screen

Postby tomrinkes » 27. January 2014 13:40

I have one more question, the reason i'm doing this is so i can upgrade from 1.5 to 2.5 en VM 2.0.
is this goning to be a problem with the version of PHP when i upgrade?

Tom
tomrinkes
 
Posts: 6
Joined: 26. January 2014 13:57
XAMPP Version: 1.8.3
Operating System: windows 7

Re: frontend white screen

Postby Altrea » 27. January 2014 13:55

Again take a look at the Joomla Requirements: http://www.joomla.org/technical-requirements.html
Joomla 2.5 needs at least PHP 5.2.4.

So if you want to upgrade Joomla from v1.5 to v2.5 you should take an environment with >= PHP 5.2.4 and < PHP 5.3
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: frontend white screen

Postby tomrinkes » 27. January 2014 14:14

oke clear (i think...)

so my plan is too update my 1.1.9 VM to 2.0 within my J1.5.
than migrate to J2.5 within Xampp 1.8.2

this is the best way?
tomrinkes
 
Posts: 6
Joined: 26. January 2014 13:57
XAMPP Version: 1.8.3
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests