error sqlite extension

Problems with the Windows version of XAMPP, questions, comments, and anything related.

error sqlite extension

Postby robofortea » 24. January 2014 20:01

Hello,
installing eyeos i have an error saying SQLite extension is not installed, but looking in phpinfo i find that pdo driver for sqlite3.x is enabled. What do i need to change? (and how?)
thanks
robofortea
 
Posts: 5
Joined: 24. January 2014 19:40
XAMPP Version: 1.8.3
Operating System: w7

Re: error sqlite extension

Postby Nobbie » 25. January 2014 12:54

robofortea wrote:What do i need to change? (and how?)


Ask in an eyeos forum why it does not recognize sqlite3.

Maybe eyeos (what i dont know) needs sqlite or sqlite2 instead of sqlite3 (unfortunately, these are are portable to each other).
Nobbie
 
Posts: 7147
Joined: 09. March 2008 13:04

Re: error sqlite extension

Postby robofortea » 25. January 2014 14:05

Thanks, but I think it's something related with getting SQLite extension installed, which regards to Xampp. Anybody knows how can i get that?
Thanks again
robofortea
 
Posts: 5
Joined: 24. January 2014 19:40
XAMPP Version: 1.8.3
Operating System: w7

Re: error sqlite extension

Postby Altrea » 25. January 2014 14:26

Hi robofortea,

robofortea wrote:but I think it's something related with getting SQLite extension installed, which regards to Xampp.

And we know, that you are wrong. SQLite 3 is included and activated by default. No need to install anything to get SQLite 3 working.

Test it out yourself, you can create a database, database table, database set and output the set again:
Code: Select all
<?php
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE foo (bar STRING)');
$db->exec("INSERT INTO foo (bar) VALUES ('This is a test')");

$result = $db->query('SELECT bar FROM foo');
var_dump($result->fetchArray());
?>


best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: error sqlite extension

Postby robofortea » 25. January 2014 17:09

Thanks Altrea
robofortea
 
Posts: 5
Joined: 24. January 2014 19:40
XAMPP Version: 1.8.3
Operating System: w7

Re: error sqlite extension

Postby thiemksb » 24. July 2015 04:54

Sqlite 3 was enabled. but eyeos 2.5 notice "not installed". Please help me.
thiemksb
 
Posts: 2
Joined: 24. July 2015 04:36
XAMPP Version: 5.6.3
Operating System: win 7

Re: error sqlite extension

Postby Altrea » 24. July 2015 09:24

Ask at an eyeos support channel if eyeos uses sqlite3. Maybe you will need sqlite2 or sqlite.

We cannot provide any support for eyeos
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: error sqlite extension

Postby thiemksb » 24. July 2015 13:39

thank you, i will try,
thiemksb
 
Posts: 2
Joined: 24. July 2015 04:36
XAMPP Version: 5.6.3
Operating System: win 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests