Apache not starting

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache not starting

Postby Roshan » 21. January 2014 07:05

when i start apache from Xampp control panel, it is not starting.
below is the log for the same.

11:21:13 AM [Apache] Attempting to start Apache app...
11:21:13 AM [Apache] Status change detected: running
11:21:14 AM [Apache] Status change detected: stopped
11:21:14 AM [Apache] Error: Apache shutdown unexpectedly.
11:21:14 AM [Apache] This may be due to a blocked port, missing dependencies,
11:21:14 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:21:14 AM [Apache] Press the Logs button to view error logs and check
11:21:14 AM [Apache] the Windows Event Viewer for more clues
11:21:14 AM [Apache] If you need more help, copy and post this
11:21:14 AM [Apache] entire log window on the forums

Please help what to do.
Roshan
 
Posts: 1
Joined: 21. January 2014 07:01
XAMPP Version: 5.5.19
Operating System: Windows 8

Re: Apache not starting

Postby Altrea » 21. January 2014 07:53

same procedure as every day:

11:21:14 AM [Apache] If you need more help, copy and post this
11:21:14 AM [Apache] > > > entire log window < < < on the forums


Apache error.log and response of the apache_start.bat script can give some extra information too.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache not starting

Postby KesKIDit » 23. January 2014 17:56

Installation problem (port 80 used by an unknown program) with XAMPP 1.8.3 on Windows 7. I found 2 different solutions that work together. The problem here is that XAMPP seems to NOT un-block a port at installation like PostgresQL can do (I think that I've noticed that while I was trying to install also PostgresQL).
(A)
1 - Create a Restore point and make a backup of the registry before this.
Launch RegEdit: Type regedit in the lower box in the Start button on the bottom-left.
2 - Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
3 - Add a new DWORD (32-bit) value by right-clicking on HTTP.
4 - Name it ‘NoRun’ not including the quotes
5 - Double click the new property
6 - In the Value data field type ’1′ not including quotes and click OK
7 - Re-boot your computer
Apache will start on port 80 but will crash.
(B)
Now that there is no more problem with the port 80 and maybe all this wasn't necessary :?: (not sure), let's get to the 2nd solution.
Go to your xampp directory --> apache --> conf ("httpd.conf" file).
Open it with NotePad++ or jEdit and go to the line 58 (approx.).
Change the (listen 80) to (listen 82) (changes the port from 80 to 82). Here you choose which port you want and in some forums there are issues as this may not be the best solution but at least everything works fine now.
Now re-boot your PC and re-start XAMPP control panel. There might be again some red lines (horror) but don't panic.
Just click on START button for each service starting with the trouble-maker Apache, things should go better (from Nothing to YELLOW to GREEN) at last!
I've worked on this issue for 3 days because I really wanted XAMPP but was thinking to migrate WAMP or WAPP but since Linux Ubuntu is my 1st choice I really wanted this XAMPP on both Ubuntu and Win 7. Enjoy. :mrgreen:
KesKIDit
 
Posts: 1
Joined: 20. January 2014 00:03
XAMPP Version: 1.8.3
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests