Session Upload Progress is not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Session Upload Progress is not working

Postby thoemi » 19. January 2014 11:06

Hi all,

I'm trying to get php session upload progress working in xampp. Here is what I'm trying to run:

I've freshly installed XAMPP 1.8.3-2 and checked if session.upload.progress is enabled via phpinfo(). The PHP module is run via the Apache 2.0 Handler, which is correct since I read that running PHP via FastCGI will not work. I have successfully run this script on my Virtual Server (Debian, Apache2.0, PHP 5.4)

So here is the problem: When I look at the $_SESSION variable while the file is beeing transferred (via an ajax call like in the example), the session variable never contains any file upload information. Even if I set session.upload.progress.cleanup to Off in the php.ini. I checked if the sessions are correctly initialized by setting some random variable and this seems to work.

Thanks for any Ideas where the problem could be.

Posts: 1
Joined: 19. January 2014 10:51
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Session Upload Progress is not working

Postby Altrea » 19. January 2014 11:58

Hi Thomas,

We can't provide any support for third party scripts, sorry.
Wild guess: The requirements for this Scripts is PHP 5.4, maybe you should try a XAMPP release containing PHP 5.4.

best wishes,
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
AF Moderator
Posts: 7289
Joined: 17. August 2009 13:05
XAMPP Version: 5.6.3
Operating System: Windows 10 Pro x64

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests