Can access Xampp sites from internet but images not loading

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can access Xampp sites from internet but images not loading

Postby sixfootjames » 08. January 2014 13:29

Slowly but surely I am configuring my Xampp setup so that I can access it from outside of my local network and send links to clients so that they can enter their own content but I am having a problem with the images and CSS not loading as it should and I am not sure what might be causing this.

I'm assuming there is a path issue that is incorrect so I need to figure out where I can make that change to resolve the issue please.

Thank you
sixfootjames
 
Posts: 13
Joined: 31. July 2012 09:50
Operating System: Windows 7 Pro

Re: Can access Xampp sites from internet but images not load

Postby JJ_Tagy » 08. January 2014 13:42

This is not an XAMPP issue.

Only you can determine where to make the change based upon your post. You can always check your logs and it will tell you if the client requests an invalid file from the server.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: Can access Xampp sites from internet but images not load

Postby sixfootjames » 08. January 2014 13:59

Thanks JJ...now that you mention it, all my sites in the past have been running on http://localhost:81/ because of a conflict with IIS.
I have for some time now no longer used IIS at all but never switched back the port numbers.
In my efforts to give my clients access to the projects I am working on so that they can add content while I design and develop, I've set up Xampp so that clients can access it from the outside.

I build mostly WP sites now and have changed the ports back to 80 to run on http://localhost/ which got me to thinking about what you said. So I ran Interconnect's script (http://interconnectit.com/products/sear ... databases/) to do a find and replace on all of the instances of http://localhost:81/ and replace with http://localhost/.

I am loading it up from my phone (because I am having another slight issue accessing the sites internally from the no-ip.com domain name) but still the site does not load the images.

Any other thoughts perhaps that I should look at?
sixfootjames
 
Posts: 13
Joined: 31. July 2012 09:50
Operating System: Windows 7 Pro

Re: Can access Xampp sites from internet but images not load

Postby sixfootjames » 08. January 2014 14:06

Just tried setting up a brand new site knowing that everything would be on http://localhost/ but that didn't load the images either.
sixfootjames
 
Posts: 13
Joined: 31. July 2012 09:50
Operating System: Windows 7 Pro


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 67 guests