Accessing Xampp remotely working but not internally

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Accessing Xampp remotely working but not internally

Postby sixfootjames » 07. January 2014 17:08

I've followed the instructions I found here to be able to access my Xampp installation from the outside (http://community.apachefriends.org/f/viewtopic.php?f=16&t=41118&p=232796#p232796) but I am having problems accessing it internally within our own office. Would there be a reason for this happening?

These are my settings inside of the httpd-xampp.conf file.

# Close XAMPP sites here
<LocationMatch "^/(?i:(?:xampp|licenses|phpmyadmin|webalizer|server-status|server-info))">
Order deny,allow
Deny from all
Allow from ::1 127.0.0.0/8
ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var
</LocationMatch>

Thank you.
sixfootjames
 
Posts: 13
Joined: 31. July 2012 09:50
Operating System: Windows 7 Pro

Re: Accessing Xampp remotely working but not internally

Postby Altrea » 07. January 2014 17:21

We can't answer that without knowing anything about your paths, URLs, internal IPs or log file Infos (access.log, error.log). Sorry.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Accessing Xampp remotely working but not internally

Postby sixfootjames » 07. January 2014 18:08

Altrea wrote:We can't answer that without knowing anything about your paths, URLs, internal IPs or log file Infos (access.log, error.log). Sorry.


Thanks Altreas. I'm assuming it is safe enough to delete everything in my log files and then run it for a short bit and send you the data? The Access.log file is about 300Mb at the moment.
sixfootjames
 
Posts: 13
Joined: 31. July 2012 09:50
Operating System: Windows 7 Pro

Re: Accessing Xampp remotely working but not internally

Postby Altrea » 07. January 2014 18:12

Sure. From the access log we just need the relating entries of the specific requests.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Accessing Xampp remotely working but not internally

Postby sixfootjames » 07. January 2014 20:02

Hi Altrea.

Hope this is enough?

From the access log:
41.50.16.52 - - [07/Jan/2014:21:00:39 +0200] "GET /arystanjakam HTTP/1.1" 404 1147 "-" "Mozilla/5.0 (Linux; Android 4.3; GT-I9500 Build/JSS15J) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.59 Mobile Safari/537.36"
41.50.16.52 - - [07/Jan/2014:21:01:21 +0200] "GET /example_website HTTP/1.1" 301 413 "-" "Mozilla/5.0 (Linux; Android 4.3; GT-I9500 Build/JSS15J) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.59 Mobile Safari/537.36"
41.50.16.52 - - [07/Jan/2014:21:01:21 +0200] "GET /example_website/ HTTP/1.1" 404 9315 "-" "Mozilla/5.0 (Linux; Android 4.3; GT-I9500 Build/JSS15J) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.59 Mobile Safari/537.36"

From the error log:
[Tue Jan 07 20:37:49 2014] [warn] pid file G:/Websites/Xampp-1.7.7/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jan 07 20:37:49 2014] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 07 20:37:49 2014] [notice] Digest: done
[Tue Jan 07 20:37:50 2014] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Jan 07 20:37:50 2014] [notice] Server built: Sep 10 2011 11:34:11
[Tue Jan 07 20:37:50 2014] [notice] Parent: Created child process 13196
[Tue Jan 07 20:37:51 2014] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 07 20:37:51 2014] [notice] Digest: done
[Tue Jan 07 20:37:51 2014] [notice] Child 13196: Child process is running
[Tue Jan 07 20:37:51 2014] [notice] Child 13196: Acquired the start mutex.
[Tue Jan 07 20:37:51 2014] [notice] Child 13196: Starting 150 worker threads.
[Tue Jan 07 20:37:51 2014] [notice] Child 13196: Starting thread to listen on port 442.
[Tue Jan 07 20:37:51 2014] [notice] Child 13196: Starting thread to listen on port 442.
[Tue Jan 07 20:37:51 2014] [notice] Child 13196: Starting thread to listen on port 80.
[Tue Jan 07 20:37:51 2014] [notice] Child 13196: Starting thread to listen on port 80.
[Tue Jan 07 20:40:50 2014] [warn] pid file G:/Websites/Xampp-1.7.7/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jan 07 20:40:50 2014] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 07 20:40:50 2014] [notice] Digest: done
[Tue Jan 07 20:40:51 2014] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Jan 07 20:40:51 2014] [notice] Server built: Sep 10 2011 11:34:11
[Tue Jan 07 20:40:51 2014] [notice] Parent: Created child process 2704
[Tue Jan 07 20:40:52 2014] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 07 20:40:52 2014] [notice] Digest: done
[Tue Jan 07 20:40:52 2014] [notice] Child 2704: Child process is running
[Tue Jan 07 20:40:52 2014] [notice] Child 2704: Acquired the start mutex.
[Tue Jan 07 20:40:52 2014] [notice] Child 2704: Starting 150 worker threads.
[Tue Jan 07 20:40:52 2014] [notice] Child 2704: Starting thread to listen on port 442.
[Tue Jan 07 20:40:52 2014] [notice] Child 2704: Starting thread to listen on port 442.
[Tue Jan 07 20:40:52 2014] [notice] Child 2704: Starting thread to listen on port 80.
[Tue Jan 07 20:40:52 2014] [notice] Child 2704: Starting thread to listen on port 80.
[Tue Jan 07 21:00:39 2014] [error] [client 41.50.16.52] File does not exist: G:/Websites/Xampp-1.7.7/htdocs/arystanjakam
sixfootjames
 
Posts: 13
Joined: 31. July 2012 09:50
Operating System: Windows 7 Pro

Re: Accessing Xampp remotely working but not internally

Postby sixfootjames » 08. January 2014 13:52

Any thoughts on this one Altrea? ;)
sixfootjames
 
Posts: 13
Joined: 31. July 2012 09:50
Operating System: Windows 7 Pro

Re: Accessing Xampp remotely working but not internally

Postby Nobbie » 08. January 2014 14:58

You see this error:

> File does not exist: G:/Websites/Xampp-1.7.7/htdocs/arystanjakam

Is there a file arystanjakam in G:/Websites/Xampp-1.7.7/htdocs? And why does it not have any extension?
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Accessing Xampp remotely working but not internally

Postby sixfootjames » 08. January 2014 15:02

Hey Nobbie. That was me typing the project name incorrectly.
To answer your question, all of these projects are WordPress sites with permalinks switched on so the extension won't show.
sixfootjames
 
Posts: 13
Joined: 31. July 2012 09:50
Operating System: Windows 7 Pro

Re: Accessing Xampp remotely working but not internally

Postby Nobbie » 08. January 2014 19:20

sixfootjames wrote:Hey Nobbie. That was me typing the project name incorrectly.
To answer your question, all of these projects are WordPress sites with permalinks switched on so the extension won't show.


Ok - in fact this is a WordPress Problem and not a Xampp Problem. We do not support WordPress here.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Accessing Xampp remotely working but not internally

Postby Altrea » 10. January 2014 15:52

I can't see any relating request entries from your internal clients to identify the problem, so providing help is difficult.
Could be anything between a router problem and webapplication problem.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests