My Apache can't listen on 80

Problems with the Windows version of XAMPP, questions, comments, and anything related.

My Apache can't listen on 80

Postby sigung_q » 05. January 2014 05:44

I can't get my apache to listen on port 80, and as a result, can't host my website to the internet. It can listen on 82, but when I try external access, I only get a blank page. Is there a workaround for this?
sigung_q
 
Posts: 14
Joined: 05. February 2013 05:14
Operating System: Windows 7 V.6.1 Build 7601:SP1

Re: My Apache can't listen on 80

Postby Altrea » 05. January 2014 05:45

XAMPP is only designed and supported as local development/testing environment, not as public accessible live server.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: My Apache can't listen on 80

Postby Nobbie » 05. January 2014 09:46

sigung_q wrote:I only get a blank page. Is there a workaround for this?


If you run Apache on Port 82, you must apply the portnumber in the URL: http://domainname:82

If you omiss the portnumber (which is standard), the URL yields to Port 80 - and Port 80 is already served by another process, which does not respond to the request (therefore the blank page). Anyway, it is a bad idea to change Apache to Port 82 (as you see, it leads to an ugly URL containing the portnumber), instead you should find out, which process already listenes to Port 80 and then change this program to listen to a different port. Usually Skype is known for this kind of problems, you can configure Skype not to use Port 80 in the Options menu and then restart Skype and Apache (and reset Apache to listen to Port 80).

If you are running Apache from Xampp, beware that Xampp is not suited for running online, your server will be hacked soon because Xampp is highly unsafe. Is is meant for development only.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: My Apache can't listen on 80

Postby blayderunner123 » 09. January 2014 00:11

Had the same problem when attempting to run Apache on my windows *.1 machine to run Apache follow these steps:
1. Mouse-over and click on Config under Apache section in the XAMPP Control Panel -->
2. Select Apache (httpd.conf)
3. scroll down untill you reach section entitled "# Listen:"
3.a change "Listen" to port:8080
4. "save" httpd.conf and then exit.
5. click "Start"

Congratulations Apache is now running.

Note: Apache will run even if no one is logged in on the server at the moment) Select only for the Current User, on Port 8080

for more information go to: http://httpd.apache.org/docs/2.2/platform/windows.html
blayderunner123
 
Posts: 1
Joined: 08. January 2014 23:54
Operating System: Windows 8.1 Developer Edition

Re: My Apache can't listen on 80

Postby sigung_q » 13. January 2014 02:04

Thanx guys!! I changed it to port 82. I am using it for development right now, so it's not important for me to host a produced website yet.
Thanx about the zend server as well. I am thinking of self hosting in the future.
sigung_q
 
Posts: 14
Joined: 05. February 2013 05:14
Operating System: Windows 7 V.6.1 Build 7601:SP1


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 23 guests