Vhost configuration leads to "Apache shutdown unexpectedly."

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Vhost configuration leads to "Apache shutdown unexpectedly."

Postby hedgerh » 19. December 2013 06:28

Hey guys, trying to get XAMPP up and running. I managed to start Apache using ports 85 and 1337 for SSL. However, I am receiving the Apache shutdown unexpectedly error when I try to set up virtual hosts in httpd-vhosts.conf. Here is the error:
12:19:36 AM [Apache] Status change detected: running
12:19:37 AM [Apache] Status change detected: stopped
12:19:37 AM [Apache] Error: Apache shutdown unexpectedly.
12:19:37 AM [Apache] This may be due to a blocked port, missing dependencies,
12:19:37 AM [Apache] improper privileges, a crash, or a shutdown by another method.
12:19:37 AM [Apache] Press the Logs button to view error logs and check
12:19:37 AM [Apache] the Windows Event Viewer for more clues
12:19:37 AM [Apache] If you need more help, copy and post this
12:19:37 AM [Apache] entire log window on the forums


Here is what I have added in httpd-vhosts.conf:
NameVirtualHost *:85
<VirtualHost *>
DocumentRoot "G:/xampp/htdocs" # change this line with your htdocs folder
ServerName client.local
<Directory "G:/xampp/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

I've tried adding :85 to the VirtualHost tag and removing it from NameVirtualHost as well.


Here is what I've added to C:/Windows/System32/drivers/hosts:
127.0.0.1 client.local


Any help would be greatly appreciated. I've tried following all of the tutorials that explain how to set up virtual hosts. Thanks!
hedgerh
 
Posts: 2
Joined: 19. December 2013 06:14
Operating System: Windows 7

Re: Vhost configuration leads to "Apache shutdown unexpected

Postby Nobbie » 19. December 2013 13:09

Dont change Apache Port to 85, instead find the Application which blocks Port 80. Usually its Skype or Microsoft IIS.

Same for Port 443.

Anyway, changing the Port in the VirtualHost clause does NOT change the Port which Apache is listening to. This is defined by a LISTEN command. But - see above - dont mess around with the ports, find the blocking application and either stop it or configure it properly not to use Port 80 (Skype).
Nobbie
 
Posts: 8766
Joined: 09. March 2008 13:04

Re: Vhost configuration leads to "Apache shutdown unexpected

Postby hedgerh » 19. December 2013 18:46

Thanks for the reply. Skype was already set to use alternative ports by default. Our Homegroup Provider and Windows Media Sharing seem to be using port 80, so I guess I will look into how to change the ports that they use.
hedgerh
 
Posts: 2
Joined: 19. December 2013 06:14
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: suze5544 and 74 guests