[BUGS] XAMPP 1.8.2-3 & 1.8.3-2 issues

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[BUGS] XAMPP 1.8.2-3 & 1.8.3-2 issues

Postby Altrea » 04. December 2013 19:55

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6821
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: [BUGS] XAMPP 1.8.2-3 & 1.8.3-2 issues

Postby Altrea » 06. January 2014 18:42

Bug Report
mysql_error.log wrote:{YYYY-mm-dd HH:ii:ss} [Note] Plugin 'FEDERATED' is disabled.
{YYYY-mm-dd HH:ii:ss} InnoDB: The InnoDB memory heap is disabled
{YYYY-mm-dd HH:ii:ss} InnoDB: Mutexes and rw_locks use Windows interlocked functions
{YYYY-mm-dd HH:ii:ss} InnoDB: Compressed tables use zlib 1.2.3
{YYYY-mm-dd HH:ii:ss} InnoDB: Initializing buffer pool, size = 16.0M
{YYYY-mm-dd HH:ii:ss} InnoDB: Completed initialization of buffer pool
InnoDB: Error: space header page consists of zero bytes in data file C:\xampp\mysql\data\ibdata1
{YYYY-mm-dd HH:ii:ss} InnoDB: Could not open or create data files.
{YYYY-mm-dd HH:ii:ss} InnoDB: If you tried to add new data files, and it failed here,
{YYYY-mm-dd HH:ii:ss} InnoDB: you should now edit innodb_data_file_path in my.cnf back
{YYYY-mm-dd HH:ii:ss} InnoDB: to what it was, and remove the new ibdata files InnoDB created
{YYYY-mm-dd HH:ii:ss} InnoDB: in this failed attempt. InnoDB only wrote those files full of
{YYYY-mm-dd HH:ii:ss} InnoDB: zeros, but did not yet use them in any way. But be careful: do not
{YYYY-mm-dd HH:ii:ss} InnoDB: remove old data files which contain your precious data!
{YYYY-mm-dd HH:ii:ss} [ERROR] Plugin 'InnoDB' init function returned error.
{YYYY-mm-dd HH:ii:ss} [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
{YYYY-mm-dd HH:ii:ss} [ERROR] Unknown/unsupported storage engine: InnoDB
{YYYY-mm-dd HH:ii:ss} [ERROR] Aborting
{YYYY-mm-dd HH:ii:ss} [Note] C:\xampp\mysql\bin\mysqld.exe: Shutdown complete


Reproducible Testcase
None yet.
Possible issue related parameters: (external) harddiks >2TB, missing write permissions, third party security software or windows security functions

Affected XAMPP versions
All XAMPP versions!?
Issue is reported for XAMPP 1.8.2-X and XAMPP 1.8.3-X full as well as lite portable versions
search.php?keywords=%22space+header+page%22&terms=all&author=&sc=1&sf=all&sr=posts&sk=t&sd=d&st=0&ch=300&t=0&submit=Suche

Solutions / Workarounds (unconfirmed)

Workaround 1: Adding setting innodb_flush_method=normal to my.ini
  • Open with plain text editor \xampp\mysql\bin\my.ini
  • at the end of the innodb_ parameters inside the [mysqld] block in add
    Code: Select all
    innodb_flush_method=normal
  • save the file

Workaround 2: Changing default-storage-engine to MyISAM and disabling InnoDB completely
  • Open with plain text editor \xampp\mysql\bin\my.ini
  • search the following line
    Code: Select all
    [mysqld]
  • after that line add the following line
    Code: Select all
    default-storage-engine=MyISAM
  • search the following line
    Code: Select all
    #skip-innodb
  • change that line to
    Code: Select all
    skip-innodb
  • save the file

References
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6821
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

XAMPP new security concept compat access rules

Postby Altrea » 21. January 2014 22:02

Bug Report
XAMPP Apache new security concept is still using compatibility access rules instead of new syntax

\xampp\apache\conf\extra\httpd-xampp.conf ~lines 120ff
Code: Select all
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
   Order deny,allow
   Deny from all
   Allow from ::1 127.0.0.0/8 \
      fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \
      fe80::/10 169.254.0.0/16

   ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>

Some users are reporting getting access forbidden http status though they are using localhost

Reproducible Testcase
not relevant

Affected XAMPP versions
All XAMPP Versions containing Apache 2.4+

Solutions / Workarounds

Recommendation 1:
local access only (IPv4 + IPv6): 127.0.0.0/8, [::1] and the servers lan addresses
Code: Select all
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
   <RequireAny>
      Require local
   </RequireAny>

   ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>


Recommendation 2:
local access + private network addresses (same range the security concept currently contains)
Code: Select all
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
   <RequireAny>
      Require local
      Require ip 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 169.254.0.0/16 fc00::/7 fe80::/10
   </RequireAny>

   ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>


References
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6821
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Installer Error: Installer payload initialization failed

Postby Altrea » 29. January 2014 07:39

Bug Report
BitRock installer respond with the message
Installer payload initialization failed. This is likely due to an incomplete or corrupt downloaded file.


Reproducible Testcase
Windows 8.1 with fresh XAMPP 1.8.3-2 or XAMPP 1.8.2-3 installer version

Affected XAMPP versions
All XAMPP Installer versions containing Bitrock Installer!?

Solutions / Workarounds
Using the .zip or .7z version

References
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6821
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

php_intl.dll activation errors

Postby Altrea » 05. February 2014 20:33

Bug Report
XAMPP Apache is throwing error messages if trying to activate php_intl.

  • the program can't start because icu****.dll is missing from your computer. Try reinstalling the program to fix the problem
  • the program can't start because msvcp110.dll is missing from your computer. Try reinstalling the program to fix the problem
  • PHP Startup: Unable to load dynamic library 'C:\xampp\php\ext\php_intl.dll'

The reasons for that are
  • XAMPP don't register a PATH variable for the php folder (don't change that, i like that :D ) and Apache will not search for that dlls in the php folder
  • Microsoft Visual C++ Redistributable 2012 library msvcp110.dll cannot be found

Reproducible Testcase
Windows System without any installed Visual C++ Runtimes.
fresh extracted version of xampp-win32-1.8.3-2-VC11.zip
uncommenting the following line in \xampp\php\php.ini
Code: Select all
extension=php_intl.dll

starting Apache

Affected XAMPP versions
All current XAMPP versions

Solutions / Workarounds
Workaround:

Recommendation for the developers of future XAMPP versions:
  • copy all icu*.dll to \xampp\apache\bin\ or find a way that Apache can find them anyway (without any system variables, registry keys, etc - XAMPP philosophy)
  • add the msvcp110.dll file in \xampp\apache\bin\ and \xampp\php\ too (msvcr110.dll is already included)

References
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6821
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: Altrea, Nobbie and 44 guests