"Port" Error On installation

Problems with the Windows version of XAMPP, questions, comments, and anything related.

"Port" Error On installation

Postby OzWaz » 03. December 2013 01:06

I have just installed XAMPP but when I click 'start' on Apache I get this error message

9:56:15 AM [Apache] Attempting to start Apache app...
9:56:15 AM [Apache] Status change detected: running
9:56:16 AM [Apache] Status change detected: stopped
9:56:16 AM [Apache] Error: Apache shutdown unexpectedly.
9:56:16 AM [Apache] This may be due to a blocked port, missing dependencies,
9:56:16 AM [Apache] improper privileges, a crash, or a shutdown by another method.
9:56:16 AM [Apache] Press the Logs button to view error logs and check
9:56:16 AM [Apache] the Windows Event Viewer for more clues
9:56:16 AM [Apache] If you need more help, copy and post this
9:56:16 AM [Apache] entire log window on the forums

What do I do to resolve this issue/

Thanks in advance

OS Windows 7
Skype Not installed

Thanks
User avatar
OzWaz
 
Posts: 12
Joined: 02. December 2013 13:23
Operating System: windows7

Re: "Port" Error On installation

Postby JJ_Tagy » 03. December 2013 01:46

OzWaz wrote:9:56:16 AM [Apache] If you need more help, copy and post this
9:56:16 AM [Apache] entire log window on the forums


I would run the control panel with admin rights and follow these instructions.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: "Port" Error On installation

Postby OzWaz » 03. December 2013 02:49

Thanks for the response

1. How do I run the control panel with admin rights?; and
2. What Instructions do I follow

Thanks
User avatar
OzWaz
 
Posts: 12
Joined: 02. December 2013 13:23
Operating System: windows7

Re: "Port" Error On installation

Postby JJ_Tagy » 03. December 2013 03:51

1. Right click the control panel and select "Run as Administrator".
2. View the Apache logs by clicking on the log button. Also, copy the ENTIRE control panel log window.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: "Port" Error On installation

Postby OzWaz » 03. December 2013 06:42

I have CP v3.2.1 it does not respond to a right click

see image here - http://www.warrenbolton.com/Content/Documents/Xampp.html

Here is the Apache error log

[Tue Dec 03 09:52:47.886629 2013] [ssl:warn] [pid 4196:tid 256] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Tue Dec 03 09:52:48.198630 2013] [ssl:warn] [pid 4196:tid 256] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Tue Dec 03 09:52:48.261030 2013] [mpm_winnt:notice] [pid 4196:tid 256] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.19 configured -- resuming normal operations
[Tue Dec 03 09:52:48.261030 2013] [mpm_winnt:notice] [pid 4196:tid 256] AH00456: Server built: Feb 23 2013 13:07:34
[Tue Dec 03 09:52:48.261030 2013] [core:notice] [pid 4196:tid 256] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Dec 03 09:52:48.261030 2013] [mpm_winnt:notice] [pid 4196:tid 256] AH00418: Parent: Created child process 4072
[Tue Dec 03 09:52:48.853831 2013] [ssl:warn] [pid 4072:tid 268] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Tue Dec 03 09:52:49.134632 2013] [ssl:warn] [pid 4072:tid 268] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Tue Dec 03 09:52:49.181432 2013] [mpm_winnt:notice] [pid 4072:tid 268] AH00354: Child: Starting 150 worker threads.


Thanks for your help

Warren
User avatar
OzWaz
 
Posts: 12
Joined: 02. December 2013 13:23
Operating System: windows7

Re: "Port" Error On installation

Postby Altrea » 03. December 2013 07:00

Don't rightclick the control panel itself but the xampp-control.exe file.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: "Port" Error On installation

Postby OzWaz » 03. December 2013 07:08

Okay that is done

what next?
User avatar
OzWaz
 
Posts: 12
Joined: 02. December 2013 13:23
Operating System: windows7

Re: "Port" Error On installation

Postby OzWaz » 03. December 2013 07:46

All Good XAMPP up and running

Thanks
User avatar
OzWaz
 
Posts: 12
Joined: 02. December 2013 13:23
Operating System: windows7

Re: "Port" Error On installation

Postby JJ_Tagy » 03. December 2013 12:25

Altrea wrote:Don't rightclick the control panel itself but the xampp-control.exe file.

Yeah, I guess I need to be more specific.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: "Port" Error On installation

Postby Altrea » 03. December 2013 13:53

JJ_Tagy wrote:Yeah, I guess I need to be more specific.

:lol:
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests