Apache fails to start (1.8.2-2VC9)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache fails to start (1.8.2-2VC9)

Postby agent154 » 28. November 2013 02:48

I'm using Windows 8.1 Pro x64.

I recently downloaded the 7z archive of version 1.8.2-2 and stored it in the folder "C:\users\sarah\appdata\local\xampp". I then loaded all the config files that were accessible from the control panel and edited the paths from "/xampp/..." to "/users/sarah/appdata/local/xampp/..." for whatever files had such references. All programs except Apache now start and function as expected, but Apache fails to start and doesn't even seem to leave any traces of a log entry. There was a Windows Firewall popup that asked me for permission to allow Apache to accept connections, but even after accepting, it won't work. I also changed my listen port number from 80 to 8008, to no benefit, and also tried listening explicitly on my IP 192.168.2.254:8008. Windows Event Viewer has no entries from Apache, and there is no log text file other than install.log.

What other things can I try to get this working, or at least get some indication as to what's wrong? All I see is

9:58:03 PM [Apache] Error: Apache shutdown unexpectedly.
9:58:03 PM [Apache] This may be due to a blocked port, missing dependencies,
9:58:03 PM [Apache] improper privileges, a crash, or a shutdown by another method.
9:58:03 PM [Apache] Press the Logs button to view error logs and check
9:58:03 PM [Apache] the Windows Event Viewer for more clues
9:58:03 PM [Apache] If you need more help, copy and post this
9:58:03 PM [Apache] entire log window on the forums
agent154
 
Posts: 2
Joined: 28. November 2013 02:33
Operating System: Windows 8.1 Pro

Re: Apache fails to start (1.8.2-2VC9)

Postby agent154 » 28. November 2013 03:21

Found the issue -- Skype was blocking access for some reason, even though I wasn't trying to use the same ports as it. I stopped Skype from using ports 80 and 443 and now Apache is working.
agent154
 
Posts: 2
Joined: 28. November 2013 02:33
Operating System: Windows 8.1 Pro


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 32 guests