Browser Not Parsing PHP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Browser Not Parsing PHP

Postby markmmiller09 » 23. November 2013 14:42

ApacheFriends XAMPP Version 1.8.3
Windows 7 64-bit

I am able to view http://localhost/xampp/index.php so it appears that PHP is installed, however when I try to open a .php file from c:\xampp\htdocs , Chrome opens the file as plain text and does not parse the PHP.

My XAMPP status reads:
MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) DEACTIVATED
Server Side Includes (SSI) ACTIVATED

Is the fact that my common gateway interface is deactivated causing some sort of problem?

Why does the XAMPP index.php page work but any php scripts I put in htdocs do not run in my browser?
markmmiller09
 
Posts: 1
Joined: 23. November 2013 14:32
XAMPP Version: 1.8.3-3
Operating System: Windows 7 64-Bit

Re: Browser Not Parsing PHP

Postby Altrea » 23. November 2013 15:40

markmmiller09 wrote:Is the fact that my common gateway interface is deactivated causing some sort of problem?

No

markmmiller09 wrote:Why does the XAMPP index.php page work but any php scripts I put in htdocs do not run in my browser?

How do you "open" the file in your browser?
What is the sourcecode of that file?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6699
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Browser Not Parsing PHP

Postby rsolly » 13. December 2013 08:03

First, I am an absolute rank beginner.

ApacheFriends XAMPP Version 1.8.2
Windows 7 64-bit

I seem to be having the same problem as Mr. Miller.:
XAMPP seems to be installed and operating on my machine and I have loaded a .php script in the htdocs folder that I want to see. In this case the script is some sort of a calendar program.
I am using localhost/calendar.php and many other variations and all I get is the "Object Not Found" Message. Can you help?

Chuck
rsolly
 
Posts: 3
Joined: 13. December 2013 07:46
XAMPP Version: 1.8.3
Operating System: Win 7 Ultimate

Re: Browser Not Parsing PHP

Postby Altrea » 13. December 2013 09:09

Are you sure the file path is \xampp\htdocs\calendar.php?
Have you maybe activated the "hide known file extensions" option of your Windows explorer?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6699
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Browser Not Parsing PHP

Postby rsolly » 13. December 2013 19:39

Altrea,
Thanks for returning my call for help.
Can you give me an example of what the localhost URL would look like if the calendar.php file was in fact in the htdocs folder?

I have a feeling I am missing a back slash or something...

Chuck
rsolly
 
Posts: 3
Joined: 13. December 2013 07:46
XAMPP Version: 1.8.3
Operating System: Win 7 Ultimate

Re: Browser Not Parsing PHP

Postby Altrea » 13. December 2013 20:27

rsolly wrote:Can you give me an example of what the localhost URL would look like if the calendar.php file was in fact in the htdocs folder?

Sure, it is pretty straight forward:
http://localhost/calendar.php

Maybe the \xampp\apache\logs\access.log can give some inside.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6699
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Browser Not Parsing PHP

Postby rsolly » 14. December 2013 05:11

Altrea,
Thanks. I was putting the entire path into the URL. It works but it is mostly code. Probably because mysql is not activated. I will get back to you!

Chuck
rsolly
 
Posts: 3
Joined: 13. December 2013 07:46
XAMPP Version: 1.8.3
Operating System: Win 7 Ultimate


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests