xampp not starting in Windows 7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp not starting in Windows 7

Postby myDragonCloud » 21. November 2013 19:56

I am having the same problem. Here is the log.

1:21:02 PM [main] Initializing Control Panel
1:21:03 PM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
1:21:03 PM [main] XAMPP Version: 1.8.3
1:21:03 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
1:21:03 PM [main] You are not running with administrator rights! This will work for
1:21:03 PM [main] most application stuff but whenever you do something with services
1:21:03 PM [main] there will be a security dialogue or things will break! So think
1:21:03 PM [main] about running this application with administrator rights!
1:21:03 PM [main] XAMPP Installation Directory: "d:\xampp\"
1:21:03 PM [main] Checking for prerequisites
1:22:18 PM [main] All prerequisites found
1:22:18 PM [main] Initializing Modules
1:22:18 PM [main] Starting Check-Timer
1:22:18 PM [main] Control Panel Ready
1:22:31 PM [Apache] Attempting to start Apache app...
1:22:31 PM [Apache] Status change detected: running
1:22:34 PM [Apache] Status change detected: stopped
1:22:34 PM [Apache] Error: Apache shutdown unexpectedly.
1:22:34 PM [Apache] This may be due to a blocked port, missing dependencies,
1:22:34 PM [Apache] improper privileges, a crash, or a shutdown by another method.
1:22:34 PM [Apache] Press the Logs button to view error logs and check
1:22:34 PM [Apache] the Windows Event Viewer for more clues
1:22:34 PM [Apache] If you need more help, copy and post this
1:22:34 PM [Apache] entire log window on the forums
myDragonCloud
 
Posts: 7
Joined: 21. November 2013 19:35
Operating System: Windows 7 Home Premium

Re: xampp not starting in Windows 7

Postby myDragonCloud » 21. November 2013 19:58

Oh yea, The log says I am running without administrative rights but I am. I checked this already.
myDragonCloud
 
Posts: 7
Joined: 21. November 2013 19:35
Operating System: Windows 7 Home Premium

Re: xampp not starting in Windows 7

Postby Altrea » 21. November 2013 20:08

administrator rights means with elevated administraror rights.
So: rightclick the control-panel exe file and choose "run as administrator".
That is a huge difference for Windows systems with enabled User Account control (UAC)

After changing that the log entries can be difference so we need again the up to date control panel log entries.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp not starting in Windows 7

Postby myDragonCloud » 21. November 2013 20:22

made the change here is the result. Notice that jep6591 posted his complete log. It is very different from my own. Should I create a seperate post? Please let me know what you want me to do?

2:19:14 PM [main] Initializing Control Panel
2:19:14 PM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
2:19:14 PM [main] XAMPP Version: 1.8.3
2:19:14 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
2:19:14 PM [main] Running with Administrator rights - good!
2:19:14 PM [main] XAMPP Installation Directory: "d:\xampp\"
2:19:14 PM [main] Checking for prerequisites
2:19:14 PM [main] All prerequisites found
2:19:14 PM [main] Initializing Modules
2:19:14 PM [main] Starting Check-Timer
2:19:14 PM [main] Control Panel Ready
2:19:19 PM [Apache] Attempting to start Apache app...
2:19:20 PM [Apache] Status change detected: running
2:19:20 PM [Apache] Status change detected: stopped
2:19:20 PM [Apache] Error: Apache shutdown unexpectedly.
2:19:20 PM [Apache] This may be due to a blocked port, missing dependencies,
2:19:20 PM [Apache] improper privileges, a crash, or a shutdown by another method.
2:19:20 PM [Apache] Press the Logs button to view error logs and check
2:19:20 PM [Apache] the Windows Event Viewer for more clues
2:19:20 PM [Apache] If you need more help, copy and post this
2:19:20 PM [Apache] entire log window on the forums
myDragonCloud
 
Posts: 7
Joined: 21. November 2013 19:35
Operating System: Windows 7 Home Premium

Re: xampp not starting in Windows 7

Postby Altrea » 21. November 2013 20:27

What is the response of executing the apache_start.bat file?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp not starting in Windows 7

Postby myDragonCloud » 21. November 2013 20:55

Ran the apache_start.bat. Here is the result

<OS 10013>An attempt was made to access a socket in a way forbidden by its access permissions. : AH00073: make_sock: unable to listen for connections on address [::]80
<OS 10013>An attempt was made to access a socket in a way forbidden by its access permissions. : AH00073: make_sock: unable to listen for connections on address 0.0.0.0:80
AH00451: no listening sockets availalble, shutting down
AH00015: Unable to open logs

thanks,

don
myDragonCloud
 
Posts: 7
Joined: 21. November 2013 19:35
Operating System: Windows 7 Home Premium

apache crashes shortly after starting

Postby myDragonCloud » 22. November 2013 17:03

I have been attempting to run apache with the same results. I have had some questions asked and answered in replies to similar post but it was beginning to get confusing as to whose questions were being asked and answered so I started this post to address the particular situation that I found myself in. The following is the log and some other information that was requested of me.

2:19:14 PM [main] Initializing Control Panel
2:19:14 PM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
2:19:14 PM [main] XAMPP Version: 1.8.3
2:19:14 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
2:19:14 PM [main] Running with Administrator rights - good!
2:19:14 PM [main] XAMPP Installation Directory: "d:\xampp\"
2:19:14 PM [main] Checking for prerequisites
2:19:14 PM [main] All prerequisites found
2:19:14 PM [main] Initializing Modules
2:19:14 PM [main] Starting Check-Timer
2:19:14 PM [main] Control Panel Ready
2:19:19 PM [Apache] Attempting to start Apache app...
2:19:20 PM [Apache] Status change detected: running
2:19:20 PM [Apache] Status change detected: stopped
2:19:20 PM [Apache] Error: Apache shutdown unexpectedly.
2:19:20 PM [Apache] This may be due to a blocked port, missing dependencies,
2:19:20 PM [Apache] improper privileges, a crash, or a shutdown by another method.
2:19:20 PM [Apache] Press the Logs button to view error logs and check
2:19:20 PM [Apache] the Windows Event Viewer for more clues
2:19:20 PM [Apache] If you need more help, copy and post this
2:19:20 PM [Apache] entire log window on the forums

Ran the apache_start.bat. Here is the result

<OS 10013>An attempt was made to access a socket in a way forbidden by its access permissions. : AH00073: make_sock: unable to listen for connections on address [::]80
<OS 10013>An attempt was made to access a socket in a way forbidden by its access permissions. : AH00073: make_sock: unable to listen for connections on address 0.0.0.0:80
AH00451: no listening sockets availalble, shutting down
AH00015: Unable to open logs

I was also asked for the result of the following command

netstat -an | find /i "listening"

Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>netstat -an | find /i "listening"
TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49152 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49153 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49154 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49171 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49186 0.0.0.0:0 LISTENING
TCP 127.0.0.1:5354 0.0.0.0:0 LISTENING
TCP 127.0.0.1:27015 0.0.0.0:0 LISTENING
TCP 127.0.0.1:49157 0.0.0.0:0 LISTENING
TCP 127.0.0.1:49158 0.0.0.0:0 LISTENING
TCP 192.168.1.27:139 0.0.0.0:0 LISTENING
TCP [::]:135 [::]:0 LISTENING
TCP [::]:445 [::]:0 LISTENING
TCP [::]:49152 [::]:0 LISTENING
TCP [::]:49153 [::]:0 LISTENING
TCP [::]:49154 [::]:0 LISTENING
TCP [::]:49171 [::]:0 LISTENING
TCP [::]:49186 [::]:0 LISTENING

C:\Windows\system32>

Been at this a few days please help?
myDragonCloud
 
Posts: 7
Joined: 21. November 2013 19:35
Operating System: Windows 7 Home Premium

Re: xampp not starting in Windows 7

Postby Altrea » 22. November 2013 17:20

I have already splitted your posts and answers from the original topic yesterday, so no need to open a new thread.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp not starting in Windows 7

Postby myDragonCloud » 22. November 2013 17:31

Thanks, any new suggestions.
myDragonCloud
 
Posts: 7
Joined: 21. November 2013 19:35
Operating System: Windows 7 Home Premium

Re: xampp not starting in Windows 7

Postby Altrea » 22. November 2013 17:45

Well, anything is preventing Apache from catching port 80.
That could be another process or service or could be any security program like a firewall, anti-virus, etc.

Check this thread for a short list of programs known for using port 80
viewtopic.php?f=16&t=58765&p=220603#p220603
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp not starting in Windows 7

Postby myDragonCloud » 24. November 2013 18:03

I haven't found anything on port 80 or 443. Further I turned off windows firewall. But that did not help either. Any other suggestions. I am still getting the same error messages.
myDragonCloud
 
Posts: 7
Joined: 21. November 2013 19:35
Operating System: Windows 7 Home Premium


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests