Virtual Hosts not working on Windows 8.1

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Virtual Hosts not working on Windows 8.1

Postby patislesfan » 16. November 2013 14:15

Hi. I have searched far and wide for this answer and I wonder if the easy answer to my issue might be to downgrade back to Windows 7. But that would require rebuilding my machine and I want to see if I can resolve this before I have to resort to that.

My issue is I can't get virtual hosts to work on Windows 8.1. I'm trying to develop multiple wordpress websites at a time. I've tried all different methods but every time I think I have everything set all I get is "Oops! Google Chrome could not find site1" or whichever site I'm trying. Port 80 is working fine and I can get my localhost to work fine. I even put a different directory first by accident and when I typed in localhost it went to that directory. But anytime I add a second or more than one directory I get nothing. I took out the # comment in the httpd.conf file. I've tried many different methods in the httpd-vhosts.conf file. I'm at a loss. I have a separate WinXP machine (I know it's old but it works for me now) and it worked for me there very simple. I just can't seem to get it to work for me on my windows 8.1 machine. And I know XAMPP is only developed up to Windows Vista but any help would be appreciated.

Below I have included what's in my hosts file, my httpd-vhosts.conf and some lines from my httpd.conf file. Let me know if you need anything else to help me resolve this issue. Thanks so much.

hosts file
Code: Select all
# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a ‘#’ symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handle within DNS itself.
#       127.0.0.1       localhost
#       ::1             localhost
127.0.0.1       localhost
127.0.0.1       site1
127.0.0.1       transitioningveterans


httpd-vhosts.conf file
Code: Select all
# Virtual Hosts
#
# Required modules: mod_log_config

# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.4/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
##NameVirtualHost *:80
#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ##ServerName or ##ServerAlias in any <VirtualHost> block.
#
##<VirtualHost *:80>
    ##ServerAdmin webmaster@dummy-host.example.com
    ##DocumentRoot "C:/xampp/htdocs/dummy-host.example.com"
    ##ServerName dummy-host.example.com
    ##ServerAlias www.dummy-host.example.com
    ##ErrorLog "logs/dummy-host.example.com-error.log"
    ##CustomLog "logs/dummy-host.example.com-access.log" common
##</VirtualHost>

##<VirtualHost *:80>
    ##ServerAdmin webmaster@dummy-host2.example.com
    ##DocumentRoot "C:/xampp/htdocs/dummy-host2.example.com"
    ##ServerName dummy-host2.example.com
    ##ErrorLog "logs/dummy-host2.example.com-error.log"
    ##CustomLog "logs/dummy-host2.example.com-access.log" common
##</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:\xampp\htdocs"
    ServerName localhost
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:\websites\site1"
    ServerName site1
    ServerAlias site1
    ErrorLog "logs\site1-error.log"
    CustomLog "logs\site1-access.log" combined
    <Directory "C:\websites\site1">
        Require all granted
        AllowOverride All
        Options Indexes FollowSymLinks
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:\Dropbox\06 Transitioning Veterans"
    ServerName transitioningveterans
    ServerAlias transitioningveterans
    ErrorLog "logs\transitioningveterans-error.log"
    CustomLog "logs\transitioningveterans-access.log" combined
    <Directory "C:\Dropbox\06 Transitioning Veterans">
        Require all granted
        AllowOverride All
        Options Indexes FollowSymLinks
    </Directory>
</VirtualHost>


From httpd.conf file
Code: Select all
#Listen 12.34.56.78:80
#Listen 80
Listen 0.0.0.0:80


# Virtual hosts
Include conf/extra/httpd-vhosts.conf
patislesfan
 
Posts: 4
Joined: 16. November 2013 13:53
Operating System: Windows 8.1

Re: Virtual Hosts not working on Windows 8.1

Postby Altrea » 16. November 2013 14:31

Your HOSTS and xampp-vhosts.conf changes are working great on my Windows 7 Ultimate x64 Testmachine.

The first test i would do on your machine is trying to ping localhost, site1 and transitioningveterans to see if they can resolve successful.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Hosts not working on Windows 8.1

Postby patislesfan » 16. November 2013 14:52

I just pinged localhost and got replies from ::1. When I pinged site1 and transitioningveterans it said "Ping request could not find host."

I'm thinking this is a Windows 8.1 issue.
patislesfan
 
Posts: 4
Joined: 16. November 2013 13:53
Operating System: Windows 8.1

Re: Virtual Hosts not working on Windows 8.1

Postby Altrea » 16. November 2013 14:56

I have found this, maybe this helps: http://serverfault.com/questions/452268 ... oubleshoot
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Hosts not working on Windows 8.1

Postby patislesfan » 16. November 2013 15:32

OK I wanted to report back and thanks so much for helping me finally figure this out. While the link you sent me wasn't the issue I did find out it was something wrong with the hosts file.

I had to completely replace the hosts file. And that's not just creating a new one and just copying over what was there. I had to create a new hosts file, delete the old one and then save a new (looks exactly the same) hosts file into the C:/Windows/System32/drivers/etc folder. That's totally resolved everything and I was able to ping the two sites, site1 and transitioningveterans. This link helped me out: http://www.tweaksforgeeks.com/windows7/2011/02/windows-7-hosts-file-ignored.

Thanks so much Altrea for helping me out. I really appreciate it.
patislesfan
 
Posts: 4
Joined: 16. November 2013 13:53
Operating System: Windows 8.1

Re: Virtual Hosts not working on Windows 8.1

Postby Altrea » 16. November 2013 15:39

You are welcome.
Have fun with XAMPP on Windows 8.1 and report back if you get any other issues. 8)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Hosts not working on Windows 8.1

Postby patislesfan » 16. November 2013 15:42

Will do and thanks again. You have been great. Have a good one.
patislesfan
 
Posts: 4
Joined: 16. November 2013 13:53
Operating System: Windows 8.1

Re: Virtual Hosts not working on Windows 8.1

Postby googirl » 24. March 2014 23:08

I just create an account to reply to you guys !
It has been more than a week that i encountered this ***** problem, i thought that i get a personnalized virus ! It was my last hope then i found this post and recreate the hosts file and it resolves my issue !
Thanks a lot and good coding ! :D
googirl
 
Posts: 1
Joined: 24. March 2014 23:04
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests