Forever port occupied

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Forever port occupied

Postby dinesh978 » 12. November 2013 02:43

Hi All,

Whenever I launch the XAMPP control panel, I get the message that the ports that are configured to be listened by the Apache Server are busy, and the listening app always flagged to be the Apache Server itself!!!! This is very inconvenient and frustrating as I always have to change the port for the Apache Server before I could proceed further with doing anything useful.

The sample error log is given below:

Code: Select all
06:58:42  [main]    Initializing Control Panel
06:58:43  [main]    Windows Version: Windows 7 Home Premium  64-bit
06:58:43  [main]    XAMPP Version: 1.8.3
06:58:43  [main]    Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
06:58:43  [main]    Running with Administrator rights - good!
06:58:43  [main]    XAMPP Installation Directory: "c:\xampp\"
06:58:43  [main]    Checking for prerequisites
06:58:46  [main]    All prerequisites found
06:58:46  [main]    Initializing Modules
06:58:46  [Apache]    Problem detected!
06:58:46  [Apache]    Port 26666 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 1804!
06:58:46  [Apache]    Apache WILL NOT start without the configured ports free!
06:58:46  [Apache]    You need to uninstall/disable/reconfigure the blocking application
06:58:46  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
06:58:46  [Apache]    Problem detected!
06:58:46  [Apache]    Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 1804!
06:58:46  [Apache]    Apache WILL NOT start without the configured ports free!
06:58:46  [Apache]    You need to uninstall/disable/reconfigure the blocking application
06:58:46  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
06:58:46  [main]    Starting Check-Timer
06:58:46  [main]    Control Panel Ready



Could you suggest any remedy to this problem? Or will I have to live forever with this problem?

Thanks.
Dinesh
dinesh978
 
Posts: 4
Joined: 09. August 2013 05:54
Operating System: Windows 7 Home Premium 64-bit

Re: Forever port occupied

Postby Altrea » 12. November 2013 04:51

Hi dinesh978,

The reason is very easy: you have registered a Windows service for XAMPP Apache so it get's started after every boot of your OS.
If you don't want that and instead start Apache manually, you need to stop Apache and unregister this service.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Forever port occupied

Postby dinesh978 » 12. November 2013 07:27

Hello Altrea,

Yes, you said very correctly that a Windows service for Apache is registered in my computer that gets started automatically. I have changed the startup mode of this service from Automatic to Manual, and believe this will fix the issue.

Thanks very much for your helpful response. Much appreciated!!

Regards,
Dinesh
dinesh978
 
Posts: 4
Joined: 09. August 2013 05:54
Operating System: Windows 7 Home Premium 64-bit

Re: Forever port occupied

Postby Altrea » 12. November 2013 11:19

This will not fix this issue if the name is the same as the control panel will expect.
So unregistering the service would be the clean way.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests