i can't start my apache in xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

i can't start my apache in xampp

Postby jeromechan10 » 10. November 2013 06:49

it shows these codes in the bottom page of the control panel v3.2.1:

6:47:29 AM [Apache] Error: Apache shutdown unexpectedly.
6:47:29 AM [Apache] This may be due to a blocked port, missing dependencies,
6:47:29 AM [Apache] improper privileges, a crash, or a shutdown by another method.
6:47:29 AM [Apache] Press the Logs button to view error logs and check
6:47:29 AM [Apache] the Windows Event Viewer for more clues
6:47:29 AM [Apache] If you need more help, copy and post this
6:47:29 AM [Apache] entire log window on the forums


and in error log text, it shows:


[Tue Nov 05 15:30:21.662524 2013] [ssl:warn] [pid 5300:tid 404] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Tue Nov 05 15:30:22.493572 2013] [ssl:warn] [pid 5300:tid 404] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Tue Nov 05 15:30:22.617579 2013] [mpm_winnt:notice] [pid 5300:tid 404] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.19 configured -- resuming normal operations
[Tue Nov 05 15:30:22.652581 2013] [mpm_winnt:notice] [pid 5300:tid 404] AH00456: Server built: Feb 23 2013 13:07:34
[Tue Nov 05 15:30:22.652581 2013] [core:notice] [pid 5300:tid 404] AH00094: Command line: 'd:\\xampp\\apache\\bin\\httpd.exe -d D:/xampp/apache'
[Tue Nov 05 15:30:22.689583 2013] [mpm_winnt:notice] [pid 5300:tid 404] AH00418: Parent: Created child process 5796
[Tue Nov 05 15:30:23.741643 2013] [ssl:warn] [pid 5796:tid 416] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Tue Nov 05 15:30:24.447684 2013] [ssl:warn] [pid 5796:tid 416] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Tue Nov 05 15:30:24.593692 2013] [mpm_winnt:notice] [pid 5796:tid 416] AH00354: Child: Starting 150 worker threads.
[Tue Nov 05 15:31:04.350966 2013] [:error] [pid 5796:tid 1912] [client ::1:50243] script 'D:/xampp/htdocs/login_page.php' not found or unable to stat, referer: http://jeromechan10.webzai.com/jeromechan10/
[Tue Nov 05 15:44:06.354694 2013] [:error] [pid 5796:tid 1912] [client ::1:50408] script 'D:/xampp/htdocs/install.php' not found or unable to stat
[Tue Nov 05 15:44:36.131397 2013] [:error] [pid 5796:tid 1900] [client ::1:50411] script 'D:/xampp/htdocs/index(2).php' not found or unable to stat
[Tue Nov 05 15:44:39.104567 2013] [:error] [pid 5796:tid 1900] [client ::1:50411] script 'D:/xampp/htdocs/index(2).php' not found or unable to stat
[Tue Nov 05 16:47:18.242578 2013] [mpm_winnt:notice] [pid 5300:tid 404] AH00428: Parent: child process 5796 exited with status 1073807364 -- Restarting.
[Fri Nov 08 15:03:33.230530 2013] [ssl:warn] [pid 6300:tid 404] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Fri Nov 08 15:03:33.604551 2013] [core:warn] [pid 6300:tid 404] AH00098: pid file D:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Nov 08 15:03:34.838622 2013] [ssl:warn] [pid 6300:tid 404] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Fri Nov 08 15:03:37.400768 2013] [mpm_winnt:notice] [pid 6300:tid 404] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.19 configured -- resuming normal operations
[Fri Nov 08 15:03:37.441771 2013] [mpm_winnt:notice] [pid 6300:tid 404] AH00456: Server built: Feb 23 2013 13:07:34
[Fri Nov 08 15:03:37.441771 2013] [core:notice] [pid 6300:tid 404] AH00094: Command line: 'd:\\xampp\\apache\\bin\\httpd.exe -d D:/xampp/apache'
[Fri Nov 08 15:03:37.479773 2013] [mpm_winnt:notice] [pid 6300:tid 404] AH00418: Parent: Created child process 7180
[Fri Nov 08 15:03:39.556892 2013] [ssl:warn] [pid 7180:tid 416] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Fri Nov 08 15:03:40.982973 2013] [ssl:warn] [pid 7180:tid 416] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Fri Nov 08 15:03:41.235988 2013] [mpm_winnt:notice] [pid 7180:tid 416] AH00354: Child: Starting 150 worker threads.
[Fri Nov 08 19:09:26.730178 2013] [mpm_winnt:notice] [pid 6300:tid 404] AH00428: Parent: child process 7180 exited with status 1073807364 -- Restarting.
[Sat Nov 09 14:11:10.691739 2013] [ssl:warn] [pid 4784:tid 404] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Sat Nov 09 14:11:10.845747 2013] [core:warn] [pid 4784:tid 404] AH00098: pid file D:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Nov 09 14:11:12.350834 2013] [ssl:warn] [pid 4784:tid 404] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Sat Nov 09 14:11:14.666966 2013] [mpm_winnt:notice] [pid 4784:tid 404] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.19 configured -- resuming normal operations
[Sat Nov 09 14:11:14.730970 2013] [mpm_winnt:notice] [pid 4784:tid 404] AH00456: Server built: Feb 23 2013 13:07:34
[Sat Nov 09 14:11:14.730970 2013] [core:notice] [pid 4784:tid 404] AH00094: Command line: 'd:\\xampp\\apache\\bin\\httpd.exe -d D:/xampp/apache'
[Sat Nov 09 14:11:14.777972 2013] [mpm_winnt:notice] [pid 4784:tid 404] AH00418: Parent: Created child process 6388
[Sat Nov 09 14:11:17.046102 2013] [ssl:warn] [pid 6388:tid 416] AH01909: RSA certificate configured for www.example.com:

how can i solve the problem in order to start my apache?
jeromechan10
 
Posts: 5
Joined: 10. November 2013 06:46
Operating System: Window 7

Re: i can't start my apache in xampp

Postby Nobbie » 10. November 2013 12:04

Your Apache has started.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: i can't start my apache in xampp

Postby jeromechan10 » 10. November 2013 13:36

but it stops automatically and saying:

6:47:29 AM [Apache] Error: Apache shutdown unexpectedly.
6:47:29 AM [Apache] This may be due to a blocked port, missing dependencies,
6:47:29 AM [Apache] improper privileges, a crash, or a shutdown by another method.
6:47:29 AM [Apache] Press the Logs button to view error logs and check
6:47:29 AM [Apache] the Windows Event Viewer for more clues
6:47:29 AM [Apache] If you need more help, copy and post this
6:47:29 AM [Apache] entire log window on the forums
jeromechan10
 
Posts: 5
Joined: 10. November 2013 06:46
Operating System: Window 7

Re: i can't start my apache in xampp

Postby Altrea » 10. November 2013 13:38

what is the response if you execute \xampp\apache_start.bat in your windows command line?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: i can't start my apache in xampp

Postby jeromechan10 » 10. November 2013 13:52

how can i do that?
jeromechan10
 
Posts: 5
Joined: 10. November 2013 06:46
Operating System: Window 7

Re: i can't start my apache in xampp

Postby Altrea » 10. November 2013 14:02

simply double click the \xampp\apache_start.bat file or better open the command line first navigate to that path with help of the "cd" command and start the file by typing in the name of the file
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: i can't start my apache in xampp

Postby jeromechan10 » 10. November 2013 14:07

it just saying 'Apache 2 is starting
jeromechan10
 
Posts: 5
Joined: 10. November 2013 06:46
Operating System: Window 7

Re: i can't start my apache in xampp

Postby Altrea » 10. November 2013 14:18

jeromechan10 wrote:it just saying 'Apache 2 is starting

if this is the very last line of that window, that is a success message which means Apache could be started.
If there would be any issues you would get a message there.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: i can't start my apache in xampp

Postby jeromechan10 » 10. November 2013 14:33

thank you, problem solved
jeromechan10
 
Posts: 5
Joined: 10. November 2013 06:46
Operating System: Window 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests