Few problems, unexpected shutdown. Please help!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Few problems, unexpected shutdown. Please help!

Postby xxbard » 21. October 2013 05:18

Hello, all! I have researched the problem, but can't seem to put my finger on what it is! Can't seem to start Apache from the control panel.

Here's my log. Thank you all in advance for your time and effort!

12:11:52 AM [main] Initializing Control Panel
12:11:52 AM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
12:11:52 AM [main] XAMPP Version: 1.8.3
12:11:52 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
12:11:52 AM [main] Running with Administrator rights - good!
12:11:52 AM [main] XAMPP Installation Directory: "c:\xampp\"
12:11:52 AM [main] Checking for prerequisites
12:12:14 AM [main] All prerequisites found
12:12:14 AM [main] Initializing Modules
12:12:14 AM [Apache] Problem detected!
12:12:14 AM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 1396!
12:12:14 AM [Apache] Apache WILL NOT start without the configured ports free!
12:12:14 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
12:12:14 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:12:14 AM [Apache] Problem detected!
12:12:14 AM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 1396!
12:12:14 AM [Apache] Apache WILL NOT start without the configured ports free!
12:12:14 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
12:12:14 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:12:14 AM [main] Starting Check-Timer
12:12:14 AM [main] Control Panel Ready
12:15:54 AM [mysql] Attempting to start MySQL app...
12:15:54 AM [mysql] Status change detected: running
12:16:04 AM [mysql] Attempting to stop MySQL (PID: 4636)
12:16:04 AM [mysql] Status change detected: stopped
12:16:06 AM [Apache] Problem detected!
12:16:06 AM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 1396!
12:16:06 AM [Apache] Apache WILL NOT start without the configured ports free!
12:16:06 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
12:16:06 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:16:06 AM [Apache] Problem detected!
12:16:06 AM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 1396!
12:16:06 AM [Apache] Apache WILL NOT start without the configured ports free!
12:16:06 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
12:16:06 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:16:06 AM [Apache] Attempting to start Apache app...
12:16:07 AM [Apache] Status change detected: running
12:16:07 AM [Apache] Status change detected: stopped
12:16:07 AM [Apache] Error: Apache shutdown unexpectedly.
12:16:07 AM [Apache] This may be due to a blocked port, missing dependencies,
12:16:07 AM [Apache] improper privileges, a crash, or a shutdown by another method.
12:16:07 AM [Apache] Press the Logs button to view error logs and check
12:16:07 AM [Apache] the Windows Event Viewer for more clues
12:16:07 AM [Apache] If you need more help, copy and post this
12:16:07 AM [Apache] entire log window on the forums
xxbard
 
Posts: 2
Joined: 21. October 2013 04:53
Operating System: Windows 7

Re: Few problems, unexpected shutdown. Please help!

Postby xxbard » 21. October 2013 05:48

I think maybe it's still running as a service from an older install that I though I had removed... I suppose this is no problem?
xxbard
 
Posts: 2
Joined: 21. October 2013 04:53
Operating System: Windows 7

Re: Few problems, unexpected shutdown. Please help!

Postby Altrea » 21. October 2013 15:21

Hi xxbard,

xxbard wrote:I think maybe it's still running as a service from an older install that I though I had removed... I suppose this is no problem?

I would unregister the services and first try if Apache and MySQL are running successful without them.
Don't register services unless you really need them.

Best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests