MySQLi

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQLi

Postby rich1000 » 30. July 2004 19:35

Anyone know how to get this to work with XAMPP under Windows?
rich1000
 
Posts: 6
Joined: 30. July 2004 19:26
Location: SF, CA, USA

Postby Bugman » 31. July 2004 15:14

It should be working automatically when you install Xampp

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Get "Fatal error: Class 'mysqli' not found in ..."

Postby rich1000 » 01. August 2004 01:53

When I issue statement:
"new mysqli (,,,)"


Or when I call "mysqli_connect()" I get call to undefined function.

Is there something extra I need to do to access mysqli or to install it?
rich1000
 
Posts: 6
Joined: 30. July 2004 19:26
Location: SF, CA, USA

Postby Bugman » 01. August 2004 15:19

Hello,

You need to make sure that you have connected to the database before you start any calls to it or querying it.

To check if mysql is running (and its without the i !) start xmapp and then look to make sure mysql is running (xmapp brings up a internet explorere screen and if you go through it, there is somewhere you can check)

If you unsure how to connect to the database, have a look at the many helpful places on the internet which can lead you through it.

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

MySQL is running

Postby rich1000 » 01. August 2004 17:01

The MySQL server is running and the PHP MySQL interface works just fine.

The problem I am having is getting the PHP MySQLi interface working.

thanks
rich1000
 
Posts: 6
Joined: 30. July 2004 19:26
Location: SF, CA, USA

Postby Bugman » 01. August 2004 22:39

Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

MySQLi (that i is not a type)

Postby rich1000 » 01. August 2004 22:49

Please only respond regarding MySQLi

I have no problem with the standard PHP MySQL interface.

Please only respond if you have successfully used MySQLi

thanks
rich1000
 
Posts: 6
Joined: 30. July 2004 19:26
Location: SF, CA, USA

Postby Bugman » 02. August 2004 11:25

Do apologise, never realised they where two seperate products.

Good luck

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby MySchizoBuddy » 16. September 2005 06:36

So no one got mysqli working.
MySchizoBuddy
 
Posts: 12
Joined: 11. June 2005 20:46

Postby Wiedmann » 16. September 2005 08:07

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: Frag and 54 guests