Apache shutdown unexpectedly on xampp 1.8.2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache shutdown unexpectedly on xampp 1.8.2

Postby abc@123 » 16. October 2013 06:17

I am having a problem with XAMPP (running v1.8.2 with control panel v3.2.1) when I try to run Apache. When I try to start Apache, I get the following error:
08:51:17 [main] Initializing Control Panel
08:51:17 [main] Windows Version: Windows 8 Pro 32-bit
08:51:17 [main] XAMPP Version: 1.8.2
08:51:17 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
08:51:17 [main] You are not running with administrator rights! This will work for
08:51:17 [main] most application stuff but whenever you do something with services
08:51:17 [main] there will be a security dialogue or things will break! So think
08:51:17 [main] about running this application with administrator rights!
08:51:17 [main] XAMPP Installation Directory: "c:\xampp\"
08:51:17 [main] Checking for prerequisites
08:51:32 [main] All prerequisites found
08:51:32 [main] Initializing Modules
08:51:32 [Apache] Problem detected!
08:51:32 [Apache] Port 80 in use by "Unable to open process" with PID 4!
08:51:32 [Apache] Apache WILL NOT start without the configured ports free!
08:51:32 [Apache] You need to uninstall/disable/reconfigure the blocking application
08:51:32 [Apache] or reconfigure Apache and the Control Panel to listen on a different port



on running apache_start.bat, i get:
Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.

C:\Users\hp>cd C:\xampp

C:\xampp>apache_start.bat
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : AH00072: make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : AH00072: make_sock: could not bind to address 0.0.0.0:80
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .


seems like there is a problem with port 80, but cant correct it.
Any ideas as to why this isn't working properly? Any help would be appreciated, thanks!
abc@123
 
Posts: 1
Joined: 16. October 2013 05:50
Operating System: Windows 8

Re: Apache shutdown unexpectedly on xampp 1.8.2

Postby Altrea » 21. October 2013 15:53

For PID 4 Port 80 issues, this way please: viewtopic.php?f=16&t=58765&p=220603#p220603
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 83 guests