Apache shutdown unexpectedly in Xampp 1.8.3

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache shutdown unexpectedly in Xampp 1.8.3

Postby amin7x » 15. October 2013 09:18

hi
today i download Xampp 1.8.3.
after install when i click in Start Apache a got error:
Code: Select all
11:46:29 AM  [Apache]    Attempting to start Apache app...
11:46:29 AM  [Apache]    Status change detected: running
11:46:30 AM  [Apache]    Status change detected: stopped
11:46:30 AM  [Apache]    Error: Apache shutdown unexpectedly.
11:46:30 AM  [Apache]    This may be due to a blocked port, missing dependencies,
11:46:30 AM  [Apache]    improper privileges, a crash, or a shutdown by another method.
11:46:30 AM  [Apache]    Press the Logs button to view error logs and check
11:46:30 AM  [Apache]    the Windows Event Viewer for more clues
11:46:30 AM  [Apache]    If you need more help, copy and post this
11:46:30 AM  [Apache]    entire log window on the forums


what i have to do?
sorry for bad english.
thanks.
amin7x
 
Posts: 2
Joined: 15. October 2013 09:01
Operating System: Windows 7

Re: Apache shutdown unexpectedly in Xampp 1.8.3

Postby JJ_Tagy » 15. October 2013 10:51

As the instructions state, we need entire log window - not just the little snippet.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: Apache shutdown unexpectedly in Xampp 1.8.3

Postby amin7x » 15. October 2013 13:08

access.log & error.log is empty.
install.log :
Code: Select all
Installing Apache HTTP Server 2.x with
 DomainName =    example.com
 ServerName =    www.example.com
 ServerAdmin =   admin@example.com
 ServerPort =    80
 ServerSslPort = 443
 ServerRoot =    c:/Apache24
Rewrote docs/conf/extra/httpd-autoindex.conf.in
 to c:/Apache24/conf/original/extra/httpd-autoindex.conf
Rewrote docs/conf/extra/httpd-default.conf.in
 to c:/Apache24/conf/original/extra/httpd-default.conf
Rewrote docs/conf/extra/httpd-ssl.conf.in
 to c:/Apache24/conf/original/extra/httpd-ssl.conf
Rewrote docs/conf/extra/httpd-multilang-errordoc.conf.in
 to c:/Apache24/conf/original/extra/httpd-multilang-errordoc.conf
Rewrote docs/conf/extra/httpd-info.conf.in
 to c:/Apache24/conf/original/extra/httpd-info.conf
Rewrote docs/conf/extra/httpd-userdir.conf.in
 to c:/Apache24/conf/original/extra/httpd-userdir.conf
Rewrote docs/conf/extra/httpd-mpm.conf.in
 to c:/Apache24/conf/original/extra/httpd-mpm.conf
Rewrote docs/conf/httpd.conf.in
 to c:/Apache24/conf/original/httpd.conf
Rewrote docs/conf/extra/proxy-html.conf.in
 to c:/Apache24/conf/original/extra/proxy-html.conf
Rewrote docs/conf/extra/httpd-vhosts.conf.in
 to c:/Apache24/conf/original/extra/httpd-vhosts.conf
Rewrote docs/conf/extra/httpd-dav.conf.in
 to c:/Apache24/conf/original/extra/httpd-dav.conf
Rewrote docs/conf/extra/httpd-languages.conf.in
 to c:/Apache24/conf/original/extra/httpd-languages.conf
Rewrote docs/conf/extra/httpd-manual.conf.in
 to c:/Apache24/conf/original/extra/httpd-manual.conf
Duplicated c:/Apache24/conf/original/extra/httpd-autoindex.conf
 to c:/Apache24/conf/extra/httpd-autoindex.conf
Duplicated c:/Apache24/conf/original/extra/httpd-default.conf
 to c:/Apache24/conf/extra/httpd-default.conf
Duplicated c:/Apache24/conf/original/extra/httpd-ssl.conf
 to c:/Apache24/conf/extra/httpd-ssl.conf
Duplicated c:/Apache24/conf/original/extra/httpd-multilang-errordoc.conf
 to c:/Apache24/conf/extra/httpd-multilang-errordoc.conf
Duplicated c:/Apache24/conf/original/extra/httpd-info.conf
 to c:/Apache24/conf/extra/httpd-info.conf
Duplicated c:/Apache24/conf/original/extra/httpd-userdir.conf
 to c:/Apache24/conf/extra/httpd-userdir.conf
Duplicated c:/Apache24/conf/original/extra/httpd-mpm.conf
 to c:/Apache24/conf/extra/httpd-mpm.conf
Duplicated c:/Apache24/conf/original/httpd.conf
 to c:/Apache24/conf/httpd.conf
Duplicated c:/Apache24/conf/original/magic
 to c:/Apache24/conf/magic
Duplicated c:/Apache24/conf/original/charset.conv
 to c:/Apache24/conf/charset.conv
Duplicated c:/Apache24/conf/original/extra/proxy-html.conf
 to c:/Apache24/conf/extra/proxy-html.conf
Duplicated c:/Apache24/conf/original/extra/httpd-vhosts.conf
 to c:/Apache24/conf/extra/httpd-vhosts.conf
Duplicated c:/Apache24/conf/original/extra/httpd-dav.conf
 to c:/Apache24/conf/extra/httpd-dav.conf
Duplicated c:/Apache24/conf/original/mime.types
 to c:/Apache24/conf/mime.types
Duplicated c:/Apache24/conf/original/extra/httpd-languages.conf
 to c:/Apache24/conf/extra/httpd-languages.conf
Duplicated c:/Apache24/conf/original/extra/httpd-manual.conf
 to c:/Apache24/conf/extra/httpd-manual.conf


when i re-run xampp i got new error:

Code: Select all
3:37:33 PM  [Apache]    Problem detected!
3:37:33 PM  [Apache]    Port 443 in use by ""C:\Program Files\VMware\VMware Workstation\vmware-hostd.exe" -u "C:\ProgramData\VMware\hostd\config.xml"" with PID 2196!
3:37:33 PM  [Apache]    Apache WILL NOT start without the configured ports free!
3:37:33 PM  [Apache]    You need to uninstall/disable/reconfigure the blocking application
3:37:33 PM  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
amin7x
 
Posts: 2
Joined: 15. October 2013 09:01
Operating System: Windows 7

Re: Apache shutdown unexpectedly in Xampp 1.8.3

Postby JJ_Tagy » 15. October 2013 15:26

Recommend searching for VMware in the top. If you aren't using shared VMs, you can disable in VMware settings. Or change the port for shared VMs.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests