IE 10 keeps asking to save a file

Problems with the Windows version of XAMPP, questions, comments, and anything related.

IE 10 keeps asking to save a file

Postby bhushan_d » 05. October 2013 22:48

Hello,

I am new to Apache and a newbie.

I installed Apache 1.8.3 to test SSI. I started Apache serve and it is Green. I checked the status and it says SSI is Activated.
the httpd.conf file contains this:
------------------------------------------------------
DocumentRoot "C:/xampp2/htdocs"
<Directory "C:/xampp2/htdocs">
#
# Possible values for the Options directive are "None", "All",
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important. Please see
# http://httpd.apache.org/docs/2.4/mod/core.html#options
# for more information.
#
Options Indexes FollowSymLinks Includes ExecCGI MultiViews
# Options Indexes FollowSymLinks
AllowOverride All

Require all granted
</Directory>
<IfModule mime_module>
TypesConfig conf/mime.types

#AddType application/x-gzip .tgz
#AddEncoding x-compress .Z
#AddEncoding x-gzip .gz .tgz

AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz

AddHandler cgi-script .cgi .pl .asp

AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
</IfModule>



I then created Simple HTML Files and named them .shtml. FIRST OE WAS
-----------------------------------------------------------------------
<body>
<!--#echo var="DATE_LOCAL" -->

</body>
</html>
------------------------------------------------------------------
I save this under try1.shtml
I got a BLANK PAGE


Then I tried the Next file
________________________________________
<body>
<!--#include virtual="incl1.txt" -->
</body>
</html>
_______________________________________
I save this under try2.shtml
I got a BLANK PAGE in GOOGLE-CHROME
in IE10, a new box opened up and asked me if I wanted to save the Download file try2,shtml. NO IE WINDOWS WAS OPENED


Then opened the httpd.conf file and changed "Includes" to +includes"
Stopped Apache and restarted it and got an ERROR

I then Installed a service and restarted Apache and the start JUST HUNG

Then opened the httpd.conf file and changed "+Includes" back "Includes"
and the service restarted with Apache as GREEN and ports as 80,443

But had the same problems when I opened the two files. BTW BOTH FILES are in "C:/xampp2/htdocs/trial" directory


Another thing when I open Windows explorer the .SHTML files have a icon that looks like a Notepad associated with them NOT the IE symbol. I looked under properties of both files and they are tagged and Internet explorer files.
bhushan_d
 
Posts: 6
Joined: 05. October 2013 22:20
XAMPP Version: 5.5.19
Operating System: Windows 7 64 bit

Re: IE 10 keeps asking to save a file

Postby Altrea » 06. October 2013 16:13

Testcase

  • installed a fresh version of XAMPP 1.8.3-1 without any configuration changes
  • started Apache
  • created a new folder \xampp\htdocs\ssi\
  • created a new file \xampp\htdocs\ssi\index.shtml
    Code: Select all
    <!--#include file="header.shtml"-->
    SSI Test
    <!--#include file="footer.shtml"-->
  • created the files \xampp\htdocs\ssi\header.shtml
    Code: Select all
    <html>
    <head>
    <title>SSI Site</title>
    </head>
    <body>

    and \xampp\htdocs\ssi\footer.shtml
    Code: Select all
    </body>
    </html>
  • request the page by url http://localhost/ssi/index.shtml

working as expected in Google Chrome and IE9
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: IE 10 keeps asking to save a file

Postby bhushan_d » 07. October 2013 17:19

Thank you for your quick reply.

I did what you suggested and it works fine. I then tried to reverse the include file. i.e. I took what was in the header and footer file, put that into the index file and them took the words and put them in a new file. It did not work

Then I did another experiment. I took the original index.shtml and added the following code in between the 2 include statements:
___________________________________

<div>
<table style="text-align: left; width: 441px; height: 32px;"
border="1" cellpadding="2" cellspacing="2">
<tbody>
<tr>
<td style="width: 144px; text-align: center;">Cell 1</td>
<td style="width: 145px; text-align: center;">Cell 2</td>
<td style="width: 145px; text-align: center;">Cell 3</td>
<td style="width: 80px; text-align: center;">Cell 4</td>
</tr>
</tbody>
</table>
</div>
___________________________________________________________________

Worked nicely. I got to see 4 cells

I then reversed the include statements and saved the file as new1.shtml. This file now looks like this:
__________________________________________________________________

<html>
<head>
<title>SSI Site</title>
</head>
<body>
<!--#include file="banner.shtml"-->
</body>
</html>
__________________________________________________________________

The banner.shtml contains the following code:

___________________________________________________

<div>
<table style="text-align: left; width: 441px; height: 32px;"
border="1" cellpadding="2" cellspacing="2">
<tbody>
<tr>
<td style="width: 144px; text-align: center;">Cell 1</td>
<td style="width: 145px; text-align: center;">Cell 2</td>
<td style="width: 145px; text-align: center;">Cell 3</td>
<td style="width: 80px; text-align: center;">Cell 4</td>
</tr>
</tbody>
</table>
</div>
_________________________________________________________________

and the screen is blank.

Please help!!!!!!

Bhushan
bhushan_d
 
Posts: 6
Joined: 05. October 2013 22:20
XAMPP Version: 5.5.19
Operating System: Windows 7 64 bit

Re: IE 10 keeps asking to save a file

Postby Altrea » 07. October 2013 18:46

index2.shtml
Code: Select all
<html>
<head>
<title>SSI Site</title>
</head>
<body>
<!--#include file="banner.shtml"-->
</body>
</html>


banner.shtml
Code: Select all
<div>
<table style="text-align: left; width: 441px; height: 32px;" border="1" cellpadding="2" cellspacing="2">
<tbody>
<tr>
<td style="width: 144px; text-align: center;">Cell 1</td>
<td style="width: 145px; text-align: center;">Cell 2</td>
<td style="width: 145px; text-align: center;">Cell 3</td>
<td style="width: 80px; text-align: center;">Cell 4</td>
</tr>
</tbody>
</table>
</div>


is working as expected in Google Chrome and IE9.

If you get only a blank screen the sourcecode view of your browser could be helpful.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: IE 10 keeps asking to save a file

Postby bhushan_d » 07. October 2013 20:37

I hit F12 in Chrome and the code showed up exactly as
Code: Select all
<html>
  <head>
  <title>SSI Site</title>
  </head>
  <body>
    <!--#include file="banner1.shtml"-->
  </body>
</html>



[img]
src="C:\xampp\XAMPP Error Code.png"
[/img]


That's it. I have a screen shot of this and would like to attach it to this. Not sure how to do that
bhushan_d
 
Posts: 6
Joined: 05. October 2013 22:20
XAMPP Version: 5.5.19
Operating System: Windows 7 64 bit

Re: IE 10 keeps asking to save a file

Postby bhushan_d » 07. October 2013 20:42

BTW Altrea,

When I upload the file to my server and run it, it works fine. This happens only when I am working with my localhost and run XAMPP. I use IE10 AND Chrome to do both views.
bhushan_d
 
Posts: 6
Joined: 05. October 2013 22:20
XAMPP Version: 5.5.19
Operating System: Windows 7 64 bit

Re: IE 10 keeps asking to save a file

Postby bhushan_d » 07. October 2013 20:55

Also, I have Norton Antivirus Software running on the system, Does that interfere with XAMPP?>
bhushan_d
 
Posts: 6
Joined: 05. October 2013 22:20
XAMPP Version: 5.5.19
Operating System: Windows 7 64 bit

Re: IE 10 keeps asking to save a file

Postby Altrea » 08. October 2013 04:38

I would try it out with a complete fresh installation of XAMPP without any configuration changes.

bhushan_d wrote:Also, I have Norton Antivirus Software running on the system, Does that interfere with XAMPP?>

This program is known to influence XAMPP but mainly at starting activities. Don't know if that could be your issue. Maybe you should try it out by temporary deactivating Norton.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: IE 10 keeps asking to save a file

Postby bhushan_d » 11. October 2013 11:35

Tried that. No go
bhushan_d
 
Posts: 6
Joined: 05. October 2013 22:20
XAMPP Version: 5.5.19
Operating System: Windows 7 64 bit

Re: IE 10 keeps asking to save a file

Postby Altrea » 11. October 2013 12:50

Well, why don't you use current script languages like PHP for that task instead of very old barely used techniques like SSI?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests