My XAMPP 1.8.3 will not start; install services

Problems with the Windows version of XAMPP, questions, comments, and anything related.

My XAMPP 1.8.3 will not start; install services

Postby rtcary » 04. October 2013 22:13

I uninstalled a prior version of XAMPP and when I try to run Apache I get this error:

1:51:37 PM [main] Initializing Control Panel
1:51:37 PM [main] Windows Version: Windows 8 Pro 64-bit
1:51:37 PM [main] XAMPP Version: 1.8.3
1:51:37 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
1:51:37 PM [main] You are not running with administrator rights! This will work for
1:51:37 PM [main] most application stuff but whenever you do something with services
1:51:37 PM [main] there will be a security dialogue or things will break! So think
1:51:37 PM [main] about running this application with administrator rights!
1:51:37 PM [main] XAMPP Installation Directory: "c:\xampp\"
1:51:37 PM [main] Checking for prerequisites
1:51:51 PM [main] All prerequisites found
1:51:51 PM [main] Initializing Modules
1:51:51 PM [Apache] Problem detected!
1:51:51 PM [Apache] Port 80 in use by "Unable to open process" with PID 36!
1:51:51 PM [Apache] Apache WILL NOT start without the configured ports free!
1:51:51 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
1:51:51 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
1:51:51 PM [Apache] Problem detected!
1:51:51 PM [Apache] Port 443 in use by "Unable to open process" with PID 36!
1:51:51 PM [Apache] Apache WILL NOT start without the configured ports free!
1:51:51 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
1:51:51 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
1:51:51 PM [main] Starting Check-Timer
1:51:51 PM [main] Control Panel Ready
2:00:41 PM [Apache] Problem detected!
2:00:41 PM [Apache] Port 80 in use by "Unable to open process" with PID 36!
2:00:41 PM [Apache] Apache WILL NOT start without the configured ports free!
2:00:41 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
2:00:41 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
2:00:41 PM [Apache] Problem detected!
2:00:41 PM [Apache] Port 443 in use by "Unable to open process" with PID 36!
2:00:41 PM [Apache] Apache WILL NOT start without the configured ports free!
2:00:41 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
2:00:41 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
2:00:41 PM [Apache] Attempting to start Apache app...
2:00:41 PM [Apache] Status change detected: running
2:00:42 PM [Apache] Status change detected: stopped
2:00:42 PM [Apache] Error: Apache shutdown unexpectedly.
2:00:42 PM [Apache] This may be due to a blocked port, missing dependencies,
2:00:42 PM [Apache] improper privileges, a crash, or a shutdown by another method.
2:00:42 PM [Apache] Press the Logs button to view error logs and check
2:00:42 PM [Apache] the Windows Event Viewer for more clues
2:00:42 PM [Apache] If you need more help, copy and post this
2:00:42 PM [Apache] entire log window on the forums
2:01:49 PM [Apache] Problem detected!
2:01:49 PM [Apache] Port 80 in use by "Unable to open process" with PID 36!
2:01:49 PM [Apache] Apache WILL NOT start without the configured ports free!
2:01:49 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
2:01:49 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
2:01:49 PM [Apache] Problem detected!
2:01:49 PM [Apache] Port 443 in use by "Unable to open process" with PID 36!
2:01:49 PM [Apache] Apache WILL NOT start without the configured ports free!
2:01:49 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
2:01:49 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
2:01:49 PM [Apache] Attempting to start Apache app...
2:01:49 PM [Apache] Status change detected: running
2:01:50 PM [Apache] Status change detected: stopped
2:01:50 PM [Apache] Error: Apache shutdown unexpectedly.
2:01:50 PM [Apache] This may be due to a blocked port, missing dependencies,
2:01:50 PM [Apache] improper privileges, a crash, or a shutdown by another method.
2:01:50 PM [Apache] Press the Logs button to view error logs and check
2:01:50 PM [Apache] the Windows Event Viewer for more clues
2:01:50 PM [Apache] If you need more help, copy and post this
2:01:50 PM [Apache] entire log window on the forums
2:05:49 PM [main] Executing "services.msc"

No doubt I need to clean something up from the prior version.

Suggestions would be appreciated...

Todd
Last edited by rtcary on 04. October 2013 22:34, edited 1 time in total.
rtcary
 
Posts: 4
Joined: 04. October 2013 17:16
XAMPP Version: 1.8.3-3
Operating System: Windows 8.0

Re: My XAMPP 1.8.3 will not start; install services

Postby rtcary » 04. October 2013 22:23

I did get Apache and MySQL running, but they are not running as services on Windows 8.0 (the boxes under Services in the Control panel are blank). Can this be changed?

Todd
rtcary
 
Posts: 4
Joined: 04. October 2013 17:16
XAMPP Version: 1.8.3-3
Operating System: Windows 8.0

Re: My XAMPP 1.8.3 will not start; install services

Postby JJ_Tagy » 04. October 2013 22:40

Without running with admin rights, the boxes will not show anything.
JJ_Tagy
 
Posts: 515
Joined: 30. January 2012 13:44
XAMPP Version: 1.8.3
Operating System: Windows 7 x64

Re: My XAMPP 1.8.3 will not start; install services

Postby rtcary » 04. October 2013 22:56

Thank you...

My experience has been running Apache in Linux; not Windows (especially Win 8). Do I just change the permissions on the XAMPP directory as I would in Linux?

Many thanks...

Todd
rtcary
 
Posts: 4
Joined: 04. October 2013 17:16
XAMPP Version: 1.8.3-3
Operating System: Windows 8.0

Re: My XAMPP 1.8.3 will not start; install services

Postby Altrea » 04. October 2013 23:00

rightclick the control-panel exe and choose "run as Administrator"
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6545
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: My XAMPP 1.8.3 will not start; install services

Postby rtcary » 04. October 2013 23:11

Voila!!

Many thanks...owe you a Bend, Oregon craft beer.
rtcary
 
Posts: 4
Joined: 04. October 2013 17:16
XAMPP Version: 1.8.3-3
Operating System: Windows 8.0


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests