New Install ...MySQL not loading.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New Install ...MySQL not loading.

Postby enemes » 03. October 2013 11:47

Hi Guys

New here, so please be kind!

I have just installed XAMPP 1.8.2

When I start the Control Panel, Apache loads fine, but I seem to have a problem with MySQL path. I get this error message in the Control Console:

11:28:45 [main] Initializing Modules
11:28:45 [mysql] MySQL Service detected with wrong path
11:28:45 [mysql] Change XAMPP MySQL and Control Panel settings or
11:28:45 [mysql] Uninstall/disable the other service manually first
11:28:45 [mysql] Found Path: C:\XAMMP\xampp\mysql\bin\mysqld --defaults-file=C:\XAMMP\xampp\mysql\bin\my.ini mysql
11:28:45 [mysql] Expected Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.ini mysql

11:28:45 [main] Starting Check-Timer

In my first install, (from ZIP) I created a folder XAMMP, and installed everything there. (It is spelled wrong, I know!) MySQL worked fine. Then I did a re-install (from EXE) at root ( C:\xampp ) and now I can't get MySQL to start from the Control Panel, I need to manually start it every time from the batch file, mysql_start.

Any suggestions please.

Thank you

Neil
User avatar
enemes
 
Posts: 3
Joined: 03. October 2013 11:35
Location: Scotland
XAMPP Version: 1.8.3-3
Operating System: Windows XP

Re: New Install ...MySQL not loading.

Postby Altrea » 03. October 2013 11:54

Hi enemes,

uninstall the wrong mysql Service by clicking the green check icon in the control panel.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: New Install ...MySQL not loading.

Postby enemes » 03. October 2013 19:00

Altrea ...
...many thanks! Running great now!
I wasn't sure what those green/red icons were for. I assumed a green check was a good thing :-)
User avatar
enemes
 
Posts: 3
Joined: 03. October 2013 11:35
Location: Scotland
XAMPP Version: 1.8.3-3
Operating System: Windows XP

Re: New Install ...MySQL not loading.

Postby enemes » 03. October 2013 19:03

I am trying to learn PHP, MySQL and XAMPP from scratch ...so I will be around on this forum for a while I think!

Great Work!
User avatar
enemes
 
Posts: 3
Joined: 03. October 2013 11:35
Location: Scotland
XAMPP Version: 1.8.3-3
Operating System: Windows XP

Re: New Install ...MySQL not loading.

Postby Altrea » 03. October 2013 21:41

enemes wrote:I wasn't sure what those green/red icons were for. I assumed a green check was a good thing :-)

green tick means: there is a windows service (autostart) registered for the configurated service name
red cross means: there is no windows service (autostart) registered for the configurated service name

none of them is better then the other. XAMPP can run very well without windows services.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests