Apache running error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache running error

Postby meSaad » 02. October 2013 06:56

Hi,
i installed XAMPP 1.8.3.1 and when i run it show this error in controlpanel:
------------------------------------------------------------------------------------------------
9:08:44 AM [main] Initializing Control Panel
9:08:44 AM [main] Windows Version: Windows 8 Enterprise 64-bit
9:08:44 AM [main] XAMPP Version: 1.8.3
9:08:44 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
9:08:44 AM [main] Running with Administrator rights - good!
9:08:44 AM [main] XAMPP Installation Directory: "d:\xampp\"
9:08:44 AM [main] Checking for prerequisites
9:08:44 AM [main] All prerequisites found
9:08:44 AM [main] Initializing Modules
9:08:44 AM [Apache] Problem detected!
9:08:44 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!
9:08:44 AM [Apache] Apache WILL NOT start without the configured ports free!
9:08:44 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
9:08:44 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
9:08:44 AM [main] Starting Check-Timer
9:08:44 AM [main] Control Panel Ready
------------------------------------------------------------------------------------------------
MySQL starts and no problem, but when i click on Start for apache shows this:
---------------------------------------------------------------------------------
9:22:57 AM [Apache] Attempting to start Apache app...
9:22:58 AM [Apache] Status change detected: running
9:22:58 AM [Apache] Status change detected: stopped
9:22:58 AM [Apache] Error: Apache shutdown unexpectedly.
9:22:58 AM [Apache] This may be due to a blocked port, missing dependencies,
9:22:58 AM [Apache] improper privileges, a crash, or a shutdown by another method.
9:22:58 AM [Apache] Press the Logs button to view error logs and check
9:22:58 AM [Apache] the Windows Event Viewer for more clues
9:22:58 AM [Apache] If you need more help, copy and post this
9:22:58 AM [Apache] entire log window on the forums
--------------------------------------------------------------------------------

What i should do? my anti-virus is Kaspersky Internet Security 2014. but when i pause protection apache still has problem.
meSaad
 
Posts: 1
Joined: 02. October 2013 06:45
XAMPP Version: 5.5.19
Operating System: Win8

Re: Apache running error

Postby Altrea » 03. October 2013 00:45

Hi meSaad,

For PID 4 problems this way please => viewtopic.php?f=16&t=58765&p=220603#p220603

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6699
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests