I have problem with ports after install of xampp.Help me

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I have problem with ports after install of xampp.Help me

Postby rahasadr » 29. September 2013 10:22

I have problem with ports after install of xampp.Help me


12:32:36 PM [main] Initializing Control Panel
12:32:36 PM [main] Windows Version: Windows 7 Ultimate SP1 64-bit
12:32:36 PM [main] XAMPP Version: 1.8.3
12:32:36 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
12:32:36 PM [main] Running with Administrator rights - good!
12:32:36 PM [main] XAMPP Installation Directory: "c:\xampp\"
12:32:36 PM [main] Checking for prerequisites
12:32:37 PM [main] All prerequisites found
12:32:37 PM [main] Initializing Modules
12:32:37 PM [Apache] Problem detected!
12:32:37 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
12:32:37 PM [Apache] Apache WILL NOT start without the configured ports free!
12:32:37 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
12:32:37 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:32:37 PM [main] The FileZilla module is disabled
12:32:37 PM [main] The Mercury module is disabled
12:32:37 PM [main] Starting Check-Timer
12:32:37 PM [main] Control Panel Ready
Be careful to your thoughts because It become your words.
rahasadr
 
Posts: 2
Joined: 29. September 2013 10:12
XAMPP Version: 5.5.19
Operating System: windows7

Re: I have problem with ports after install of xampp.Help me

Postby c3p0 » 01. October 2013 09:04

The exact same error stack occurs on Windows Vista with xampp 1.8.3.
using the windows built-in "adminstrator" account

Changing the number behind the word listen to, eg. 888
Code: Select all
Listen 888
and the
Code: Select all
ServerName localhost:80
line to
Code: Select all
ServerName localhost: <my:IP:Address:here>

in the httpd.conf file from the xampp control panel (v3.2.1) doesn't yield.

some preliminary parts of the solution are suggested here: osprey.unisa.ac.za/phorum/read.php?751,179464
  • I have the UAC switched off with a reboot BEFORE the installation as suggested
    didn't appear to help
  • Also unchecked the IIS option as suggested there with a reboot. Yet, that too didn't appear to help either.
  • Skype is NOT running on this system (checked using the 'Services' button in the xampp control panel).



EDIT:
Code: Select all
Listen 285

and
Code: Select all
ServerName localhost: 285


In the xampp control: clicked on the red X icon to the left of the module name Apache, upon which a pop-up appeared asking whether I want to install Apache, to which I agreed.
A few moments later the icon changed to a green tick to the left of Apache and the error stack disappears.

Click the START button to the right of the Apache module name and the background color of the module name Apache turns red and get this message:
Attempting to start Apache service...

no further message appears thereafter (left it for half an hour).
click the START button again and receive the original error stack.


EDIT 2:
Use the main Config button in the xampp control panel to access the 'Service and Port Settings' . There change the port number to the number you have chosen for your port.
Changed my chosen port number to 2375 as suggested here: http://complete-concrete-concise.com/web-tools/how-to-change-the-apache-port-in-xampp in the 'Why change the port?' section of the article. Changed the port number in both the httpd.conf file as well as in the 'Service and Port Settings' to be 2375.

After that the error stack no longer shows, even after clicking the START button to the right of the Apache module name several times. Only the message "Attempting to start Apache service..." keeps appearing, but nothing seems to actually happen. However, clicking the Services button gives the message 'Executing "services.msc"' and starts that module, showing the process: Apache/2.4.4 (Win32) and the status column is empty on that row. Select that process and attempt to start the process (left hand panel). It fails to start, telling me so in a pop up.
The services tool provides a code though: Event ID 7024 — Service Stop Operations

check this for the event viewer: http://windows.microsoft.com/en-au/windows-vista/open-event-viewer

http://technet.microsoft.com/en-us/library/ca9f4221-56df-46e6-89b8-1465a789c28c.aspx
which says:
  • If event ID 7011 is also logged for this service, then extending the service timeout period to resolve event ID 7011 would also resolve this error.
  • If event ID 7034 is also logged for this service, then restoring the service default settings to resolve event ID 7034 would also resolve this error.

For more information about the sc command, see SC Command Reference Help (http://go.microsoft.com/fwlink/?LinkID=84961).

Futher investigation gets you to the Microsoft management Console, tab Contents, subtree 'services' and 'configure how a service is started'. In this microsoft article on how to use the sc command inside the cmd.exe (console).

The process in question: Apache2.4

Code: Select all
C:\>sc start Apache2.4

SERVICE_NAME: Apache2.4
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 2  START_PENDING
                                (NOT_STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x7d0
        PID                : 2000
        FLAGS              :

C:\>sc query Apache2.4

SERVICE_NAME: Apache2.4
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 1  STOPPED
        WIN32_EXIT_CODE    : 1066  (0x42a)
        SERVICE_EXIT_CODE  : 1  (0x1)
        CHECKPOINT         : 0x0


The thing is, I am still stuck ... no Apache running!
Last edited by c3p0 on 01. October 2013 23:31, edited 1 time in total.
c3p0
 
Posts: 1
Joined: 01. October 2013 08:50
XAMPP Version: 5.5.19
Operating System: Windows Vista

Re: I have problem with ports after install of xampp.Help me

Postby rahasadr » 01. October 2013 20:23

Thanks a lot
Good Luck For Ever
Be careful to your thoughts because It become your words.
rahasadr
 
Posts: 2
Joined: 29. September 2013 10:12
XAMPP Version: 5.5.19
Operating System: windows7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests