Apache refuses to start after creating SSL certificate

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache refuses to start after creating SSL certificate

Postby poila_invictus » 24. September 2013 02:35

I used to be able to run Apache from the XAMPP control panel, after running openssl based on this tutorial (http://robsnotebook.com/xampp-ssl-encrypt-passwords), and after rebooting my Windows 7 64-bit machine, Apache could not run anymore. I'll post the error messages here:

XAMPP Error Log:
XAMPP Version: 1.8.2
9:01:05 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
9:01:05 AM [main] Running with Administrator rights - good!
9:01:05 AM [main] XAMPP Installation Directory: "c:\xampp\"
9:01:05 AM [main] Checking for prerequisites
9:01:06 AM [main] All prerequisites found
9:01:06 AM [main] Initializing Modules
9:01:06 AM [Apache] Problem detected!
9:01:06 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!
9:01:06 AM [Apache] Apache WILL NOT start without the configured ports free!
9:01:06 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
9:01:06 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
9:01:06 AM [main] The FileZilla module is disabled
9:01:06 AM [main] The Mercury module is disabled
9:01:06 AM [main] Starting Check-Timer
9:01:06 AM [main] Control Panel Ready
9:01:14 AM [Apache] Problem detected!
9:01:14 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!
9:01:14 AM [Apache] Apache WILL NOT start without the configured ports free!
9:01:14 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
9:01:14 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
9:01:14 AM [Apache] Attempting to start Apache app...
9:01:14 AM [Apache] Status change detected: running
9:01:15 AM [Apache] Status change detected: stopped
9:01:15 AM [Apache] Error: Apache shutdown unexpectedly.
9:01:15 AM [Apache] This may be due to a blocked port, missing dependencies,
9:01:15 AM [Apache] improper privileges, a crash, or a shutdown by another method.
9:01:15 AM [Apache] Press the Logs button to view error logs and check
9:01:15 AM [Apache] the Windows Event Viewer for more clues
9:01:15 AM [Apache] If you need more help, copy and post this
9:01:15 AM [Apache] entire log window on the forums
9:26:00 AM [Apache] Problem detected!
9:26:00 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!
9:26:00 AM [Apache] Apache WILL NOT start without the configured ports free!
9:26:00 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
9:26:00 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
9:26:00 AM [Apache] Attempting to start Apache app...
9:26:02 AM [Apache] Status change detected: running
9:26:06 AM [Apache] Status change detected: stopped
9:26:06 AM [Apache] Error: Apache shutdown unexpectedly.
9:26:06 AM [Apache] This may be due to a blocked port, missing dependencies,
9:26:06 AM [Apache] improper privileges, a crash, or a shutdown by another method.
9:26:06 AM [Apache] Press the Logs button to view error logs and check
9:26:06 AM [Apache] the Windows Event Viewer for more clues
9:26:06 AM [Apache] If you need more help, copy and post this
9:26:06 AM [Apache] entire log window on the forums

Apache (error.log)
[Mon Sep 23 17:46:54.839631 2013] [mpm_winnt:notice] [pid 1692:tid 268] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.16 configured -- resuming normal operations
[Mon Sep 23 17:46:54.839631 2013] [mpm_winnt:notice] [pid 1692:tid 268] AH00456: Server built: Feb 23 2013 13:07:34
[Mon Sep 23 17:46:54.839631 2013] [core:notice] [pid 1692:tid 268] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Sep 23 17:46:54.841631 2013] [mpm_winnt:notice] [pid 1692:tid 268] AH00418: Parent: Created child process 4516
[Mon Sep 23 17:46:55.927269 2013] [ssl:warn] [pid 4516:tid 284] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Sep 23 17:46:55.928769 2013] [ssl:warn] [pid 4516:tid 284] AH01909: RSA certificate configured for prestashop.localhost:443 does NOT include an ID which matches the server name
[Mon Sep 23 17:46:56.382327 2013] [ssl:warn] [pid 4516:tid 284] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Sep 23 17:46:56.382827 2013] [ssl:warn] [pid 4516:tid 284] AH01909: RSA certificate configured for prestashop.localhost:443 does NOT include an ID which matches the server name
[Mon Sep 23 17:46:56.432833 2013] [mpm_winnt:notice] [pid 4516:tid 284] AH00354: Child: Starting 150 worker threads.
[Mon Sep 23 18:38:27.457344 2013] [mpm_winnt:notice] [pid 1692:tid 268] AH00428: Parent: child process 4516 exited with status 1073807364 -- Restarting.

How do I reset the certificate and XAMPP installation if this problem persists?
poila_invictus
 
Posts: 2
Joined: 24. September 2013 02:25
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Apache refuses to start after creating SSL certificate

Postby Altrea » 24. September 2013 04:35

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6691
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache refuses to start after creating SSL certificate

Postby poila_invictus » 24. September 2013 04:47

Adding more info:
- Skype: I disabled use of ports 80 and 443
- TeamViewer: Not installed.
- IIS: I am aware that IIS uses port 80, so I actually edited the httpd file for Apache to listen to another port, port 1234.
Prior to using mentioned tutorial link for generating cert, Apache listening to port 1234 is possible.

I managed to get Apache service to run again without re-installation of XAMPP. What I did, was to copy the server.crt file from \apache\conf\ssl.crt\ folder from a freshly-extracted folder into the existing folder.
My hunch is that while using that tutorial for generating the SSL certifcate, the cert file was not generated correctly, thus causing my Apache service to not start properly.
poila_invictus
 
Posts: 2
Joined: 24. September 2013 02:25
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Apache refuses to start after creating SSL certificate

Postby Altrea » 24. September 2013 05:21

notices and warnings don't prevent Apache from starting, just errors.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6691
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache refuses to start after creating SSL certificate

Postby hackattack142 » 25. September 2013 03:33

Hello,

If you change the port that Apache listens on, you need to change it in the XAMPP Control Panel configuration as well or it will keep looking at port 80.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests