how can I avoid to show "xampp" in the url?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

how can I avoid to show "xampp" in the url?

Postby towfiqi » 18. September 2013 02:13

Version info: ApacheFriends XAMPP Version 1.8.3(Windows)
My website is hosted like below:
https://ip-address/abc/
Now, If I delete "abc" from url above (which is directory under htdocs and website name) the url become automatically
https://ip-address/xampp
and showing error page.
(please check)
What I want is: when I delete/remove "abc"(website name) it should not show automatically the name "xampp" in the url...it should show the url...
how can I avoid to show "xampp" in the url when I delete wbesite name/directory name? Please reply.
towfiqi
 
Posts: 7
Joined: 18. September 2013 01:56
XAMPP Version: 5.5.19
Operating System: Windows 2008

Re: how can I avoid to show "xampp" in the url?

Postby Altrea » 18. September 2013 04:45

Delete your \xampp\htdocs\index.php
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: how can I avoid to show "xampp" in the url?

Postby towfiqi » 18. September 2013 05:49

Thanks for your quick reply...I have deleted index.php now it is showing index.html which is "IT WORKS".
I have deleted that index.html too now the probelm is directory listing I mean directory folders ate showind inside browser which I do no t like to show...how can I disable to show directory structure in my browser??? Plese reply.
towfiqi
 
Posts: 7
Joined: 18. September 2013 01:56
XAMPP Version: 5.5.19
Operating System: Windows 2008

Re: how can I avoid to show "xampp" in the url?

Postby Altrea » 18. September 2013 06:11

Maybe you should explain more detailed what you want to see and not what you all don't want to see.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: how can I avoid to show "xampp" in the url?

Postby towfiqi » 18. September 2013 06:18

I dont want to see the directory listings
it shoudl show some access denied message
towfiqi
 
Posts: 7
Joined: 18. September 2013 01:56
XAMPP Version: 5.5.19
Operating System: Windows 2008

Re: how can I avoid to show "xampp" in the url?

Postby Altrea » 18. September 2013 06:32

Inside your \xampp\apache\conf\httpd.conf you should fine a line like this
Code: Select all
<Directory "C:/xampp/htdocs">


inside this Directory Block you should have a line beginning with Options.
In this line remove the word Indexes, save the file and restart Apache.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: how can I avoid to show "xampp" in the url?

Postby towfiqi » 18. September 2013 06:54

Thank you very very much. One more question if you dont bother:

Can I change the text what I see now below now:
I mean which file to edit to change the text?
------------------------------------------------------------------------------------
Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.
If you think this is a server error, please contact the webmaster.
--------------------------------------------------------------------------------------------------------------
Thanks again!
towfiqi
 
Posts: 7
Joined: 18. September 2013 01:56
XAMPP Version: 5.5.19
Operating System: Windows 2008

Re: how can I avoid to show "xampp" in the url?

Postby towfiqi » 19. September 2013 02:04

Where can I modify above/below text as well email address?(contact the webmaster)

------------------------------------------------------------------------------------
Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.
If you think this is a server error, please contact the webmaster.
--------------------------------------------------------------------------------------------------------------
towfiqi
 
Posts: 7
Joined: 18. September 2013 01:56
XAMPP Version: 5.5.19
Operating System: Windows 2008

Re: how can I avoid to show "xampp" in the url?

Postby Altrea » 19. September 2013 05:26

repeating your post (pushing threads in general) will NOT result in quicker responses. The opposite is the truth.

towfiqi wrote:Where can I modify above/below text as well email address?(contact the webmaster)

The Apache manual knows the answer: http://httpd.apache.org/docs/2.4/custom-error.html
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests