Mr Confused!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mr Confused!

Postby ChuckS » 17. September 2013 18:07

Yes I am! I am a new programmer. After installing XAMPP the Control Panel (v3.2.1) the log tells me that the ports are blocked (see below) but it seems to be blocked by Apache and Mysql. So why isn't Apache running? What do I have to reset?

12:41:19 AM [main] Initializing Control Panel
12:41:19 AM [main] Windows Version: Windows 7 Ultimate SP1 32-bit
12:41:19 AM [main] XAMPP Version: 1.8.2
12:41:19 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
12:41:19 AM [main] Running with Administrator rights - good!
12:41:19 AM [main] XAMPP Installation Directory: "c:\xampp\"
12:41:19 AM [main] Checking for prerequisites
12:41:20 AM [main] All prerequisites found
12:41:20 AM [main] Initializing Modules
12:41:20 AM [Apache] Problem detected!
12:41:20 AM [Apache] Port 80 in use by ""C:\AppServ\Apache2.2\bin\httpd.exe" -k runservice" with PID 1980!
12:41:20 AM [Apache] Apache WILL NOT start without the configured ports free!
12:41:20 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
12:41:20 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:41:20 AM [mysql] MySQL Service detected with wrong path
12:41:20 AM [mysql] Change XAMPP MySQL and Control Panel settings or
12:41:20 AM [mysql] Uninstall/disable the other service manually first
12:41:20 AM [mysql] Found Path: C:\AppServ\MySQL\bin\mysqld --defaults-file=C:\AppServ\MySQL\my.ini mysql
12:41:20 AM [mysql] Expected Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.ini mysql
12:41:20 AM [mysql] Problem detected!
12:41:20 AM [mysql] Port 3306 in use by "C:\AppServ\MySQL\bin\mysqld --defaults-file=C:\AppServ\MySQL\my.ini mysql"!
12:41:20 AM [mysql] MySQL WILL NOT start without the configured ports free!
12:41:20 AM [mysql] You need to uninstall/disable/reconfigure the blocking application
12:41:20 AM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
12:41:20 AM [main] The FileZilla module is disabled
12:41:20 AM [main] The Mercury module is disabled
12:41:20 AM [main] Enabling autostart for module "Apache"
12:41:20 AM [main] Enabling autostart for module "MySQL"
12:41:20 AM [main] Starting Check-Timer
12:41:20 AM [main] Control Panel Ready
12:41:20 AM [Apache] Autostart active: starting...
12:41:20 AM [Apache] Problem detected!
12:41:20 AM [Apache] Port 80 in use by ""C:\AppServ\Apache2.2\bin\httpd.exe" -k runservice" with PID 1980!
12:41:20 AM [Apache] Apache WILL NOT start without the configured ports free!
12:41:20 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
12:41:20 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:41:20 AM [Apache] Attempting to start Apache service...
12:41:21 AM [mysql] Autostart active: starting...
12:41:21 AM [mysql] Problem detected!
12:41:21 AM [mysql] Port 3306 in use by "C:\AppServ\MySQL\bin\mysqld --defaults-file=C:\AppServ\MySQL\my.ini mysql"!
12:41:21 AM [mysql] MySQL WILL NOT start without the configured ports free!
12:41:21 AM [mysql] You need to uninstall/disable/reconfigure the blocking application
12:41:21 AM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
12:41:21 AM [mysql] Attempting to start MySQL service...
ChuckS
 
Posts: 1
Joined: 17. September 2013 17:11
XAMPP Version: 1.8.3-3
Operating System: Win 7

Re: Mr Confused!

Postby Altrea » 17. September 2013 20:04

ChuckS wrote:the log tells me that the ports are blocked (see below) but it seems to be blocked by Apache and Mysql. So why isn't Apache running?

It is, but not your XAMPP Apache and XAMPP MySQL is running, but other ones.

ChuckS wrote:What do I have to reset?

You could stop and uninstall the other ones in C:\AppServ\ if you don't need them.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6676
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: mark.mcdonald and 43 guests