Testing a new installation. HTTP Error 503

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Testing a new installation. HTTP Error 503

Postby bilboUK » 10. September 2013 18:19

I'm new to web site creation and was advised to set up a local server :) So I've just installed xampp 1.8.2 and had to modify some port settings to get Apache running. Port 80 changed to 8088 and 443 to 4499. When I try to test the server with http://127.0.0.1in Chrome I get the Error 503. I found a post saying it could be a problem with TomCat but I can't start it, please see below, and I don't know what to do next :( Any help greatly appreciated.
18:10:36 [main] Initializing Control Panel
18:10:36 [main] Windows Version: Windows 7 Ultimate SP1 32-bit
18:10:36 [main] XAMPP Version: 1.8.2
18:10:36 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
18:10:36 [main] Running with Administrator rights - good!
18:10:36 [main] XAMPP Installation Directory: "c:\xampp\"
18:10:36 [main] Checking for prerequisites
18:10:36 [main] All prerequisites found
18:10:36 [main] Initializing Modules
18:10:36 [Apache] Problem detected!
18:10:36 [Apache] Port 80 in use by "Unable to open process" with PID 4!
18:10:36 [Apache] Apache WILL NOT start without the configured ports free!
18:10:36 [Apache] You need to uninstall/disable/reconfigure the blocking application
18:10:36 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
18:10:36 [Apache] Problem detected!
18:10:36 [Apache] Port 443 in use by "Unable to open process" with PID 4!
18:10:36 [Apache] Apache WILL NOT start without the configured ports free!
18:10:36 [Apache] You need to uninstall/disable/reconfigure the blocking application
18:10:36 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
18:10:36 [filezilla] XAMPP FileZilla is already running on port 21
18:10:36 [filezilla] XAMPP FileZilla is already running on port 14147
18:10:36 [mercury] XAMPP Mercury is already running on port 25
18:10:36 [mercury] XAMPP Mercury is already running on port 79
18:10:36 [mercury] XAMPP Mercury is already running on port 105
18:10:36 [mercury] XAMPP Mercury is already running on port 106
18:10:36 [mercury] XAMPP Mercury is already running on port 110
18:10:36 [mercury] XAMPP Mercury is already running on port 143
18:10:36 [mercury] XAMPP Mercury is already running on port 2224
18:10:36 [Tomcat] Java is already running on port 8005!
18:10:36 [Tomcat] Is Tomcat already running?
18:10:36 [Tomcat] Java is already running on port 8009!
18:10:36 [Tomcat] Is Tomcat already running?
18:10:36 [main] Starting Check-Timer
18:10:36 [main] Control Panel Ready
18:10:46 [Apache] Problem detected!
18:10:46 [Apache] Port 80 in use by "Unable to open process" with PID 4!
18:10:46 [Apache] Apache WILL NOT start without the configured ports free!
18:10:46 [Apache] You need to uninstall/disable/reconfigure the blocking application
18:10:46 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
18:10:46 [Apache] Problem detected!
18:10:46 [Apache] Port 443 in use by "Unable to open process" with PID 4!
18:10:46 [Apache] Apache WILL NOT start without the configured ports free!
18:10:46 [Apache] You need to uninstall/disable/reconfigure the blocking application
18:10:46 [Apache] or reconfigure Apache and the Control Panel to listen on a different port

18:10:46 [Apache] Attempting to start Apache app...
18:10:46 [Apache] Status change detected: running
18:10:52 [mysql] Attempting to start MySQL app...
18:10:52 [mysql] Status change detected: running
18:10:57 [Tomcat] Java is already running on port 8005!
18:10:57 [Tomcat] Is Tomcat already running?
18:10:57 [Tomcat] Java is already running on port 8009!
18:10:57 [Tomcat] Is Tomcat already running?
18:10:57 [Tomcat] Attempting to start Tomcat app...
18:10:58 [Tomcat] Status change detected: running
18:10:59 [Tomcat] Status change detected: stopped
18:10:59 [Tomcat] Error: Tomcat shutdown unexpectedly.
18:10:59 [Tomcat] This may be due to a blocked port, missing dependencies,
18:10:59 [Tomcat] improper privileges, a crash, or a shutdown by another method.
18:10:59 [Tomcat] Press the Logs button to view error logs and check
18:10:59 [Tomcat] the Windows Event Viewer for more clues
18:10:59 [Tomcat] If you need more help, copy and post this
18:10:59 [Tomcat] entire log window on the forums
bilboUK
 
Posts: 1
Joined: 10. September 2013 17:58
Operating System: WIndows 7

Re: Testing a new installation. HTTP Error 503

Postby Altrea » 10. September 2013 18:24

If you change the default ports in Apache, you need to change the ports in the XAMPP control panel settings too.
And you have to add the port to every URL, e.g. http://127.0.0.1:8088/ instead of http://127.0.0.1/
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests