Please Help ! XAMPP with mod_security not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Please Help ! XAMPP with mod_security not working

Postby wezmaster » 10. September 2013 14:47

Hi,

I am facing a unique problem.

I am trying to install mod_security on xampp (windows).

I followed these steps :

1. Download and extracted http://www.apachefriends.org/download.php?xampp-portable-win32-1.8.3-1-VC11-installer.exe
2. Tested the apache (works fine)
3. Downloaded http://www.apachelounge.com/download/VC11/modules/modules-2.4-win32-VC11.zip
4. copied mod_security2.so to apache/modules/mod_security2/
5. Edited HTTPD.conf to make these changes
LoadModule security2_module modules/mod_security2/mod_security2.so
LoadModule unique_id_module modules/mod_unique_id.so
6. started apache .. (it works and error log shows mod_security loaded)
7. copied modsecurity.conf to apache/conf/
8. Edited httpd.conf to add this line
Include conf/modsecurity.conf
9. started apache .. (It simply wont start. shows error and tells to check error.log. but nothing registered in error.log)
10. commented Include conf/modsecurity.conf in httpd.conf and started apache (it works)

I am going crazy doing this again and again.. cant figure out what and where it is going wrong. Please help.

Thanks and Regards,

Asim
wezmaster
 
Posts: 2
Joined: 10. September 2013 14:33
Operating System: Windows 7 64 bit

Re: Please Help ! XAMPP with mod_security not working

Postby Altrea » 10. September 2013 15:56

Hi wezmaster,

very common you have not set the paths in your modsecurity.conf related to your environment.
Read the comments in your modsecurity.conf file for further information.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Please Help ! XAMPP with mod_security not working

Postby wezmaster » 11. September 2013 20:21

Thanks a lot Altrea for pointing me in right direction..
wezmaster
 
Posts: 2
Joined: 10. September 2013 14:33
Operating System: Windows 7 64 bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests