MySQL won't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL won't start

Postby natcolley » 03. September 2013 18:37

I looked at this post http://community.apachefriends.org/f/viewtopic.php?f=16&t=61387&p=220523&hilit=mysql+stopped#p220523 but I don't have any ibd files in data/mysql.

Here are my logs:

mysql error log:

130903 11:58:59 [Note] Plugin 'FEDERATED' is disabled.
130903 11:59:00 InnoDB: The InnoDB memory heap is disabled
130903 11:59:00 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130903 11:59:00 InnoDB: Compressed tables use zlib 1.2.3
130903 11:59:00 InnoDB: Initializing buffer pool, size = 16.0M
130903 11:59:00 InnoDB: Completed initialization of buffer pool
InnoDB: The first specified data file C:\xampp\mysql\data\ibdata1 did not exist:
InnoDB: a new database to be created!
130903 11:59:00 InnoDB: Setting file C:\xampp\mysql\data\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
130903 11:59:00 InnoDB: Log file C:\xampp\mysql\data\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file C:\xampp\mysql\data\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
130903 11:59:00 InnoDB: Log file C:\xampp\mysql\data\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file C:\xampp\mysql\data\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: 127 rollback segment(s) active.
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
130903 11:59:02 InnoDB: Waiting for the background threads to start
130903 11:59:03 InnoDB: 5.5.32 started; log sequence number 0
130903 11:59:03 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
130903 11:59:03 [Note] - '0.0.0.0' resolves to '0.0.0.0';
130903 11:59:03 [Note] Server socket created on IP: '0.0.0.0'.
130903 12:01:10 [Note] Plugin 'FEDERATED' is disabled.
130903 12:01:10 InnoDB: The InnoDB memory heap is disabled
130903 12:01:10 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130903 12:01:10 InnoDB: Compressed tables use zlib 1.2.3
130903 12:01:10 InnoDB: Initializing buffer pool, size = 16.0M
130903 12:01:10 InnoDB: Completed initialization of buffer pool
130903 12:01:10 InnoDB: highest supported file format is Barracuda.
130903 12:01:11 InnoDB: Waiting for the background threads to start
130903 12:01:12 InnoDB: 5.5.32 started; log sequence number 1595675
130903 12:01:12 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
130903 12:01:12 [Note] - '0.0.0.0' resolves to '0.0.0.0';
130903 12:01:12 [Note] Server socket created on IP: '0.0.0.0'.
130903 12:19:04 [Note] Plugin 'FEDERATED' is disabled.
130903 12:19:04 InnoDB: The InnoDB memory heap is disabled
130903 12:19:04 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130903 12:19:04 InnoDB: Compressed tables use zlib 1.2.3
130903 12:19:04 InnoDB: Initializing buffer pool, size = 16.0M
130903 12:19:04 InnoDB: Completed initialization of buffer pool
130903 12:19:04 InnoDB: highest supported file format is Barracuda.
130903 12:19:05 InnoDB: Waiting for the background threads to start
130903 12:19:06 InnoDB: 5.5.32 started; log sequence number 1595675
130903 12:19:06 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
130903 12:19:06 [Note] - '0.0.0.0' resolves to '0.0.0.0';
130903 12:19:06 [Note] Server socket created on IP: '0.0.0.0'.

xampp control panel notice:
12:18:38 PM [main] Initializing Control Panel
12:18:38 PM [main] Windows Version: Windows 8 Pro 32-bit
12:18:38 PM [main] XAMPP Version: 1.8.2
12:18:38 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
12:18:38 PM [main] You are not running with administrator rights! This will work for
12:18:38 PM [main] most application stuff but whenever you do something with services
12:18:38 PM [main] there will be a security dialogue or things will break! So think
12:18:38 PM [main] about running this application with administrator rights!
12:18:38 PM [main] XAMPP Installation Directory: "c:\xampp\"
12:18:38 PM [main] Checking for prerequisites
12:18:41 PM [main] All prerequisites found
12:18:41 PM [main] Initializing Modules
12:18:41 PM [main] Starting Check-Timer
12:18:41 PM [main] Control Panel Ready
12:18:55 PM [Apache] Attempting to start Apache app...
12:18:57 PM [Apache] Status change detected: running
12:19:04 PM [mysql] Attempting to start MySQL app...
12:19:05 PM [mysql] Status change detected: running
12:19:06 PM [mysql] Status change detected: stopped
12:19:06 PM [mysql] Error: MySQL shutdown unexpectedly.
12:19:06 PM [mysql] This may be due to a blocked port, missing dependencies,
12:19:06 PM [mysql] improper privileges, a crash, or a shutdown by another method.
12:19:06 PM [mysql] Press the Logs button to view error logs and check
12:19:06 PM [mysql] the Windows Event Viewer for more clues
12:19:06 PM [mysql] If you need more help, copy and post this
12:19:06 PM [mysql] entire log window on the forums
12:28:41 PM [main] Executing "c:\xampp\"

Event Viewer:
The description for Event ID 100 from source MySQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Aborting
-
The description for Event ID 100 from source MySQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Event Scheduler: Error while loading from disk.
-
The description for Event ID 100 from source MySQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Event Scheduler: Failed to open table mysql.event
- -
Your assistance is greatly appreciated.

-
edit
I just looked at phpmyadmin and saw this additional error message:
MySQL said: Documentation

#2002 - No connection could be made because the target machine actively refused it.

The server is not responding (or the local server's socket is not correctly configured).
Connection for controluser as defined in your configuration failed.
-
For what it is worth, this is my second installation in the last 36 hours. I had originally put it in MyDocuments but uninstalled and put it in the default c:/xampp folder because of the 'spaces in the url' issue. I did not see any problems with mysql the first time.
natcolley
 
Posts: 11
Joined: 07. January 2008 23:51

Re: MySQL won't start

Postby JJ_Tagy » 04. September 2013 09:04

Your previous installation probably still has service running. Start control panel with admin privileges and check again.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: MySQL won't start

Postby natcolley » 10. September 2013 09:47

I do not detect another service, but once I signed in as admin, everything worked. Thx.
natcolley
 
Posts: 11
Joined: 07. January 2008 23:51

Re: MySQL won't start

Postby natcolley » 10. September 2013 11:08

Well, maybe I spoke too soon. Now I can't access localhost or 127.0.0.1. I tried the certificate wizard, that did nothing. I tried changing 'www.example.com:443' in the ssl.conf file to localhost, but that did nothing either. I tried opening the config.inc file in phpmyadmin, but all that does is download, and of course when I click on open, it just downloads again. How do I get localhost to work again so I can access all the rest of my XAMPP stack? Thank you.
natcolley
 
Posts: 11
Joined: 07. January 2008 23:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests