Apache stops just after start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache stops just after start

Postby Pharoah » 08. August 2013 18:30

I know there are many threads like this one but I couldn't solve it with other's people solutions.

Image

Error Log:
Code: Select all
[Thu Aug 08 16:42:39.843750 2013] [mpm_winnt:notice] [pid 3324:tid 188] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Thu Aug 08 16:42:39.843750 2013] [mpm_winnt:notice] [pid 3324:tid 188] AH00456: Server built: Aug 18 2012 12:41:37
[Thu Aug 08 16:42:39.843750 2013] [core:notice] [pid 3324:tid 188] AH00094: Command line: 'd:\\xampp\\apache\\bin\\httpd.exe -d D:/xampp/apache'
[Thu Aug 08 16:42:39.859375 2013] [mpm_winnt:notice] [pid 3324:tid 188] AH00418: Parent: Created child process 3472
[Thu Aug 08 16:42:41.140625 2013] [mpm_winnt:crit] [pid 3472:tid 1884] (OS 10022)An invalid argument was supplied.  : AH00405: Child: WSASocket failed to open the inherited socket
[Thu Aug 08 16:42:41.140625 2013] [mpm_winnt:crit] [pid 3324:tid 188] AH00427: Parent: child process exited with status 3 -- Aborting.


I changed ports and it didn't help, re-installed XAMPP and it didn't help too. I've also checked if some process is using port 80 or 443 but no one uses. I can't start it on ANY port. Everything worked before(maybe one month ago) but suddenly stopped working. I've also stopped some services like:

    WebClient
    Web Deployment Agent Service
    Microsoft .NET Framework NGEN.

but I don't think this is the problem, because everything worked perfectly before. I checked skype too and it's not using port 80 and 443.
User avatar
Pharoah
 
Posts: 1
Joined: 08. August 2013 18:22
XAMPP Version: 5.6.3
Operating System: WinXP Pro SP3

Re: Apache stops just after start

Postby Altrea » 09. August 2013 06:33

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: eriku and 39 guests