XAMPP Stopping

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Stopping

Postby PaulL » 04. August 2013 23:10

Just installed XAMPP Version 1.8.2
Got the following messages on starting up Apache:

3:35:34 PM [main] Initializing Control Panel
3:35:35 PM [main] Windows Version: Windows 7 Professional SP1 32-bit
3:35:35 PM [main] XAMPP Version: 1.8.2
3:35:35 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
3:35:35 PM [main] You are not running with administrator rights! This will work for
3:35:35 PM [main] most application stuff but whenever you do something with services
3:35:35 PM [main] there will be a security dialogue or things will break! So think
3:35:35 PM [main] about running this application with administrator rights!
3:35:35 PM [main] XAMPP Installation Directory: "c:\xampp\"
3:35:35 PM [main] Checking for prerequisites
3:35:37 PM [main] All prerequisites found
3:35:37 PM [main] Initializing Modules
3:35:37 PM [Apache] Problem detected!
3:35:37 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
3:35:37 PM [Apache] Apache WILL NOT start without the configured ports free!
3:35:37 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
3:35:37 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
3:35:37 PM [Apache] Problem detected!
3:35:37 PM [Apache] Port 443 in use by "Unable to open process" with PID 4!
3:35:37 PM [Apache] Apache WILL NOT start without the configured ports free!
3:35:37 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
3:35:37 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port

So I attempted to change port 80 to 81 and 443 to 444 in the config files. It started to run but as soon as I launched a Joomla page against it, I got
4:51:12 PM [Apache] Attempting to start Apache app...
4:51:13 PM [Apache] Status change detected: running
4:51:13 PM [Apache] Status change detected: stopped
4:51:13 PM [Apache] Error: Apache shutdown unexpectedly.
4:51:13 PM [Apache] This may be due to a blocked port, missing dependencies,
4:51:13 PM [Apache] improper privileges, a crash, or a shutdown by another method.
4:51:13 PM [Apache] Press the Logs button to view error logs and check
4:51:13 PM [Apache] the Windows Event Viewer for more clues
4:51:13 PM [Apache] If you need more help, copy and post this
4:51:13 PM [Apache] entire log window on the forums

I don't really know what to do or if what I did was valid.

Thanks for the assistance.
PaulL
 
Posts: 2
Joined: 04. August 2013 23:00
XAMPP Version: 5.6.3
Operating System: Windows 7 SP1

Re: XAMPP Stopping

Postby Altrea » 05. August 2013 05:03

please execute the \xampp\apache_start.bat file in your windows command line and post the response here.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6544
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP Stopping

Postby hackattack142 » 05. August 2013 22:24

Hello,

Also, if it crashed while running, there should be some error in your Apache error log (/xampp/apache/logs/error.log).
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 702
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests