Can't run Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't run Apache

Postby renatorf » 03. August 2013 19:53

Can anyone please help?

15:46:53 [main] Initializing Control Panel
15:46:53 [main] Windows Version: Windows 7 Home Basic SP1 64-bit
15:46:53 [main] XAMPP Version: 1.8.3
15:46:53 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
15:46:53 [main] Running with Administrator rights - good!
15:46:53 [main] XAMPP Installation Directory: "g:\portableapps\xampp\app\xampp\"
15:46:53 [main] Checking for prerequisites
15:46:53 [main] All prerequisites found
15:46:53 [main] Initializing Modules
15:46:53 [main] Starting Check-Timer
15:46:53 [main] Control Panel Ready
15:46:56 [Apache] Attempting to start Apache app...
15:46:57 [Apache] Status change detected: running
15:46:58 [Apache] Status change detected: stopped
15:46:58 [Apache] Error: Apache shutdown unexpectedly.
15:46:58 [Apache] This may be due to a blocked port, missing dependencies,
15:46:58 [Apache] improper privileges, a crash, or a shutdown by another method.
15:46:58 [Apache] Press the Logs button to view error logs and check
15:46:58 [Apache] the Windows Event Viewer for more clues
15:46:58 [Apache] If you need more help, copy and post this
15:46:58 [Apache] entire log window on the forums
renatorf
 
Posts: 3
Joined: 03. August 2013 19:50
Operating System: Windows 7 Home Basic SP1 64-bi

Re: Can't run Apache

Postby Altrea » 03. August 2013 19:54

Please execute \xampp\apache_start.bat in your Windows command line and report its output.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't run Apache

Postby renatorf » 04. August 2013 20:32

Here it is:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
AH00112: Warning: DocumentRoot [G:/xampp/htdocs] does not exist
(OS 3)O sistema nÒo pode encontrar o caminho especificado. : AH02291: Cannot ac
cess directory 'G:/xampp/apache/logs/' for error log of vhost defined at G:/Port
ableApps/XAMPP/App/xampp/apache/conf/extra/httpd-ssl.conf:83
AH00014: Configuration check failed

Apache konnte nicht gestartet werden
Apache could not be started
Pressione qualquer tecla para continuar. . .
renatorf
 
Posts: 3
Joined: 03. August 2013 19:50
Operating System: Windows 7 Home Basic SP1 64-bi

Re: Can't run Apache

Postby renatorf » 04. August 2013 21:13

Just figured it out. Because I'm running it with PortableApps I had to change all conf files to point to a different directory. Thanks!
renatorf
 
Posts: 3
Joined: 03. August 2013 19:50
Operating System: Windows 7 Home Basic SP1 64-bi


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests