General installation

Problems with the Windows version of XAMPP, questions, comments, and anything related.

General installation

Postby BBone1 » 31. July 2013 20:59

I am new to all this and being so I have been looking into it. I have a couple of questions and the first being when registering it ask what version do you have with a drop down list up to 1.8.2. Not including 1.8.3 and that does not make a lot of sense to me. I selected 1.8.2 and don't have any installed just yet but intend to install 1.8.3 lite.
Also with the 1.8.3 version it says Important:
PHP in this package needs Microsoft Visual C++2008 etc with a link to Microsoft. Can you use Visual C++2012 studio. This is 2013 and that just seems out of date.
Thanks for any advice
BBBBB
BBone1
 
Posts: 3
Joined: 31. July 2013 20:04
XAMPP Version: 5.5.19
Operating System: windows 8

Re: General installation

Postby Altrea » 01. August 2013 06:08

BBone1 wrote:when registering it ask what version do you have with a drop down list up to 1.8.2. Not including 1.8.3 and that does not make a lot of sense to me.

Yeah, that needs to be updated by one of the board Administrators.

BBone1 wrote:Can you use Visual C++2012 studio. This is 2013 and that just seems out of date.

You don't need the complete IDE/compiler installed, just the runtime.
To answer your question: no the runtime needs the exact one the binaries are compiled against.
So if VC9 x86 (Visual C++ 2008 Runtime 32bit) is required you need exactly this one, even independent if you are using a 64bit os. Current PHP 5.5 binaries on php.net are already build with VC11 (Visual C++ 2012).

Best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests