xampp config

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp config

Postby 12strings » 23. July 2013 00:45

Hi guys,I just installed xampp 1.8.2 on win7 64 bit. apache, mysql
& filezilla
are running but phpmyadmin isn't available (503 error)
There is a green & yellow orb icon on top of my xampp control panel icon. I don't
remember that before? This was my cleanest xampp installation. I'm confident someone can tell me how to
proceed. I've tried to post proper, significant info.
==============================================================
reconfigs - apache.conf - curent:
#Listen 12.34.56.78:80
Listen 8080
ServerName localhost:8080
#Include conf/extra/httpd-ssl.conf - current

=========================================================
reconfigs - apache http-ssl.conf - current:
# socache_shmcb_module (for default value of SSLSessionCache)
#SSLSessionCache "shmcb:C:/xampp/apache/logs/ssl_scache(512000)"xx
SSLSessionCache "shmcb:C:/xampp/apache/logs/ssl_scache(512000)"
SSLSessionCacheTimeout 300

==============================================================
reconfigs - php ini:
==================================================================
config.inc.php - current:
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';
/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = '127.0.0.1';


==================================================
apache access log: is empty
=======================================================
php error log: is empty
========================================================
mysql error log:

130721 19:41:34 [Note] Plugin 'FEDERATED' is disabled.
130721 19:41:35 InnoDB: The InnoDB memory heap is disabled
130721 19:41:35 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130721 19:41:35 InnoDB: Compressed tables use zlib 1.2.3
130721 19:41:35 InnoDB: Initializing buffer pool, size = 16.0M
130721 19:41:35 InnoDB: Completed initialization of buffer pool
InnoDB: The first specified data file C:\xampp\mysql\data\ibdata1 did not exist:
InnoDB: a new database to be created!
130721 19:41:35 InnoDB: Setting file C:\xampp\mysql\data\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
130721 19:41:35 InnoDB: Log file C:\xampp\mysql\data\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file C:\xampp\mysql\data\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
130721 19:41:35 InnoDB: Log file C:\xampp\mysql\data\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file C:\xampp\mysql\data\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: 127 rollback segment(s) active.
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
130721 19:41:36 InnoDB: Waiting for the background threads to start
130721 19:41:37 InnoDB: 5.5.32 started; log sequence number 0
130721 19:41:37 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130721 19:41:37 [Note] - '127.0.0.1' resolves to '127.0.0.1';
130721 19:41:37 [Note] Server socket created on IP: '127.0.0.1'.
130721 19:41:37 [Note] Event Scheduler: Loaded 0 events
130721 19:41:37 [Note] mysql\bin\mysqld: ready for connections.
Version: '5.5.32' socket: '' port: 3306 MySQL Community Server (GPL)
130721 19:55:06 [Note] Plugin 'FEDERATED' is disabled.
130721 19:55:06 InnoDB: The InnoDB memory heap is disabled
130721 19:55:06 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130721 19:55:06 InnoDB: Compressed tables use zlib 1.2.3
130721 19:55:06 InnoDB: Initializing buffer pool, size = 16.0M
130721 19:55:06 InnoDB: Completed initialization of buffer pool
130721 19:55:06 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
130721 19:55:06 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
130721 19:55:07 InnoDB: Waiting for the background threads to start
130721 19:55:08 InnoDB: 5.5.32 started; log sequence number 1595675
130721 19:55:08 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130721 19:55:08 [Note] - '127.0.0.1' resolves to '127.0.0.1';
130721 19:55:08 [Note] Server socket created on IP: '127.0.0.1'.
130721 19:55:08 [Note] Event Scheduler: Loaded 0 events
130721 19:55:08 [Note] c:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.32' socket: '' port: 3306 MySQL Community Server (GPL)
130721 20:43:00 [Note] Plugin 'FEDERATED' is disabled.
130721 20:43:00 InnoDB: The InnoDB memory heap is disabled
130721 20:43:00 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130721 20:43:00 InnoDB: Compressed tables use zlib 1.2.3
130721 20:43:00 InnoDB: Initializing buffer pool, size = 16.0M
130721 20:43:00 InnoDB: Completed initialization of buffer pool
130721 20:43:00 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
130721 20:43:00 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
130721 20:43:01 InnoDB: Waiting for the background threads to start
130721 20:43:02 InnoDB: 5.5.32 started; log sequence number 1595675
130721 20:43:02 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130721 20:43:02 [Note] - '127.0.0.1' resolves to '127.0.0.1';
130721 20:43:02 [Note] Server socket created on IP: '127.0.0.1'.
130721 20:43:02 [Note] Event Scheduler: Loaded 0 events
130721 20:43:02 [Note] c:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.32' socket: '' port: 3306 MySQL Community Server (GPL)
130722 13:21:48 [Note] Plugin 'FEDERATED' is disabled.
130722 13:21:48 InnoDB: The InnoDB memory heap is disabled
130722 13:21:48 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130722 13:21:48 InnoDB: Compressed tables use zlib 1.2.3
130722 13:21:49 InnoDB: Initializing buffer pool, size = 16.0M
130722 13:21:49 InnoDB: Completed initialization of buffer pool
130722 13:21:49 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
130722 13:21:49 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
130722 13:21:49 InnoDB: Waiting for the background threads to start
130722 13:21:50 InnoDB: 5.5.32 started; log sequence number 1595675
130722 13:21:50 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130722 13:21:50 [Note] - '127.0.0.1' resolves to '127.0.0.1';
130722 13:21:50 [Note] Server socket created on IP: '127.0.0.1'.
130722 13:21:50 [Note] Event Scheduler: Loaded 0 events
130722 13:21:50 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.32' socket: '' port: 3306 MySQL Community Server (GPL)

=======================================================================
apache error log:
Sun Jul 21 20:42:51.544260 2013] [ssl:warn] [pid 2252:tid 376] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name
[Sun Jul 21 20:42:53.104263 2013] [ssl:warn] [pid 2252:tid 376] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name
[Sun Jul 21 20:42:53.416264 2013] [mpm_winnt:notice] [pid 2252:tid 376] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/[5.4.16 configured -- resuming normal operations
[Sun Jul 21 20:42:53.416264 2013] [mpm_winnt:notice] [pid 2252:tid 376] AH00456: Server built: Feb 23 2013 13:07:34
[Sun Jul 21 20:42:53.416264 2013] [core:notice] [pid 2252:tid 376] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Jul 21 20:42:53.431864 2013] [mpm_winnt:notice] [pid 2252:tid 376] AH00418: Parent: Created child process 6020
[Sun Jul 21 20:42:56.817070 2013] [ssl:warn] [pid 6020:tid 388] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name
[Sun Jul 21 20:42:58.548673 2013] [ssl:warn] [pid 6020:tid 388] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name
[Sun Jul 21 20:42:58.845073 2013] [mpm_winnt:notice] [pid 6020:tid 388] AH00354: Child: Starting 150 worker threads.
[Mon Jul 22 13:21:52.284939 2013] [core:warn] [pid 5972:tid 356] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Jul 22 13:21:53.423741 2013] [ssl:warn] [pid 5972:tid 356] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Jul 22 13:21:53.751341 2013] [mpm_winnt:notice] [pid 5972:tid 356] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.16 configured -- resuming normal operations
[Mon Jul 22 13:21:53.751341 2013] [mpm_winnt:notice] [pid 5972:tid 356] AH00456: Server built: Feb 23 2013 13:07:34
[Mon Jul 22 13:21:53.751341 2013] [core:notice] [pid 5972:tid 356] AH00094: Command line: 'apache\\bin\\httpd.exe -d C:/xampp/apache -f conf\\httpd.conf'
[Mon Jul 22 13:21:53.766941 2013] [mpm_winnt:notice] [pid 5972:tid 356] AH00418: Parent: Created child process 4288
Apache server shutdown initiated...
sl:warn] [pid 4288:tid 368] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Jul 22 13:21:59.195751 2013] [mpm_winnt:notice] [pid 4288:tid 368] AH00354: Child: Starting 150 worker threads.
[Mon Jul 22 13:32:12.260438 2013] [mpm_winnt:notice] [pid 5972:tid 356] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Mon Jul 22 13:32:14.288441 2013] [mpm_winnt:notice] [pid 4288:tid 368] AH00364: Child: All worker threads have exited.
[Mon Jul 22 13:32:14.647242 2013] [mpm_winnt:notice] [pid 5972:tid 356] AH00430: Parent: Child process 4288 exited successfully.
[Mon Jul 22 13:37:03.632950 2013] [ssl:warn] [pid 1072:tid 356] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Jul 22 13:37:03.960550 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.16 configured -- resuming normal operations
[Mon Jul 22 13:37:03.960550 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00456: Server built: Feb 23 2013 13:07:34
[Mon Jul 22 13:37:03.960550 2013] [core:notice] [pid 1072:tid 356] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Jul 22 13:37:03.976150 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00418: Parent: Created child process 5080
[Mon Jul 22 13:37:09.061759 2013] [ssl:warn] [pid 5080:tid 368] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Jul 22 13:37:09.358160 2013] [mpm_winnt:notice] [pid 5080:tid 368] AH00354: Child: Starting 150 worker threads.
[/quote]
============================================================
Last edited by 12strings on 24. July 2013 18:35, edited 1 time in total.
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

Re: xampp config

Postby Altrea » 23. July 2013 13:16

Hi,

maybe the contents of your \xampp\apache\logs\access.log can be helpful.

Which URL do you use to request phpmyadmin?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: xampp config

Postby 12strings » 24. July 2013 17:54

Hi Altrea,
127.0.0.1, http://localhost/phpmyadmin, localhost, http://localhost/
I just installed xampp 1.8.2 on win7 64 bit. apache, mysql
& filezilla
are running but
phpmyadmin isn't
Below is the result of my last effort:
available (503 error).
There is a green & yellow orb icon on top of my xampp controle panel icon. I don't
remember that before? Apache, mysql & filezilla start when I log in.
I'm confident someone there can tell me how to proceed. I've tried to post proper, significant info.
==============================================================
reconfigs - apache.conf - curent:
#Listen 12.34.56.78:80
Listen 8080
ServerName localhost:8080
#Include conf/extra/httpd-ssl.conf - current

=========================================================
reconfigs - apache http-ssl.conf - current:
# socache_shmcb_module (for default value of SSLSessionCache)
#SSLSessionCache "shmcb:C:/xampp/apache/logs/ssl_scache(512000)"xx
SSLSessionCache "shmcb:C:/xampp/apache/logs/ssl_scache(512000)"
SSLSessionCacheTimeout 300

==============================================================
reconfigs - php ini:
==================================================================
config.inc.php -current:
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';
/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = '127.0.0.1';


==================================================
apache access log: is empty
=======================================================
php error log: is empty
========================================================
mysql error log:
3306
130722 13:21:50 [Note] - '127.0.0.1' resolves to '127.0.0.1';
130722 13:21:50 [Note] Server socket created on IP: '127.0.0.1'.
130722 13:21:50 [Note] Event Scheduler: Loaded 0 events
130722 13:21:50 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.32' socket: '' port: 3306 MySQL Community Server (GPL)

=====================================================================
apache error log:
[Mon Jul 22 13:37:03.960550 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.16 configured -- resuming normal operations
[Mon Jul 22 13:37:03.960550 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00456: Server built: Feb 23 2013 13:07:34
[Mon Jul 22 13:37:03.960550 2013] [core:notice] [pid 1072:tid 356] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Jul 22 13:37:03.976150 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00418: Parent: Created child process 5080
[Mon Jul 22 13:37:09.061759 2013] [ssl:warn] [pid 5080:tid 368] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Jul 22 13:37:09.358160 2013] [mpm_winnt:notice] [pid 5080:tid 368] AH00354: Child: Starting 150 worker threads.
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

somethings wrong with php config?

Postby 12strings » 26. July 2013 23:02

Hi guys,I just installed xampp 1.8.2 on win7 64 bit. apache, mysql
& filezilla
are running but phpmyadmin isn't available (503 error).
There is a green & yellow orb icon on top of my xampp icon. I don't
remember that before? I don't have autostart checked in the console.
Apache, mysql & filezilla start when I log in.
I'm confident someone can tell me how to proceed. I've tried to post proper, significant info.
==============================================================
reconfigs - apache.conf - current:

#Listen 12.34.56.78:80
Listen 8080

ServerName localhost:8080

# nclude conf/extra/httpd-ssl.conf - current
=========================================================
reconfigs - apache http-ssl.conf - current:

# socache_shmcb_module (for default value of SSLSessionCache)

#SSLSessionCache "shmcb:C:/xampp/apache/logs/ssl_scache(512000)"xx
SSLSessionCache "shmcb:C:/xampp/apache/logs/ssl_scache(512000)"
SSLSessionCacheTimeout 300
==============================================================
reconfigs - php ini:
==================================================================
config.inc.php - current:

$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';
/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = '127.0.0.1';

==================================================
apache access log: is empty
=======================================================
php error log: is empty
========================================================
mysql error log:

3306
130722 13:21:50 [Note] - '127.0.0.1' resolves to '127.0.0.1';
130722 13:21:50 [Note] Server socket created on IP: '127.0.0.1'.
130722 13:21:50 [Note] Event Scheduler: Loaded 0 events
130722 13:21:50 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.32' socket: '' port: 3306 MySQL Community Server (GPL)[/QUO wphpithTE]
=====================================================================
apache error log:

[Mon Jul 22 13:37:03.960550 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.16 configured -- resuming normal operations
[Mon Jul 22 13:37:03.960550 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00456: Server built: Feb 23 2013 13:07:34
[Mon Jul 22 13:37:03.960550 2013] [core:notice] [pid 1072:tid 356] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Jul 22 13:37:03.976150 2013] [mpm_winnt:notice] [pid 1072:tid 356] AH00418: Parent: Created child process 5080
[Mon Jul 22 13:37:09.061759 2013] [ssl:warn] [pid 5080:tid 368] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Jul 22 13:37:09.358160 2013] [mpm_winnt:notice] [pid 5080:tid 368] AH00354: Child: Starting 150 worker threads.[/QUOTE]
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

Re: xampp config

Postby hackattack142 » 27. July 2013 20:28

Hello,

You changed your Apache port to 8080 which means you need to add that port to your URL (http://localhost:8080/phpmyadmin).

You should also update the port in the XAMPP Control Panel configuration if you have not already.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: xampp config

Postby 12strings » 03. August 2013 22:21

Hello again, someone please lead me past this issue.I really need to get my server
up & running. I'm getting close I think ? Thanks.
php error log:
[28-Jul-2013 04:04:23 Europe/Berlin] PHP Warning: file_get_contents(lang.tmp):

failed the to open stream: No such file or directory in C:\xampp\htdocs\xampp\index.php
on line 2[/quote]
this is file at C:\xampp\htdocs\xampp\index.php:
Code: Select all
<?php
   if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
      $uri = 'https://';
   } else {
      $uri = 'http://';
   }
   $uri .= $_SERVER['HTTP_HOST'];
   header('Location: '.$uri.'/xampp/');
   exit;
?>
Something is wrong with the XAMPP installation :-(


C:\xampp\htdocs\xampp\lang is a folder containing of abbeviated languages

lang.php is a php file in the same folder as above
Code: Select all
<?php
   include("lang/languages.php");
   while (list($key, $value) = each($languages))
   {
      if ($_SERVER['QUERY_STRING'] == $key)
      {
         $fp=fopen("lang.tmp","w");
         fwrite($fp,basename($key));
         fclose($fp);
         header("Location: index.php");
      }
   }
?>

lang.tmp is yet another file in the above folder which contains 2 bytes, "en".
Isn't there a way to make it less vulnerable ?
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

Re: xampp config

Postby Altrea » 03. August 2013 22:56

Hi,

12strings wrote:
php error log:
[28-Jul-2013 04:04:23 Europe/Berlin] PHP Warning: file_get_contents(lang.tmp):
failed the to open stream: No such file or directory in C:\xampp\htdocs\xampp\index.php
on line 2

Thats normal. This file doesn't exist and gets created the first time requesting the XAMPP administration page.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: xampp config

Postby 12strings » 04. August 2013 01:46

thanks altrea.
I really thank you . Everything seems to work but my original problem , php not functioning.

phpmyadmin status shows:
MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) DEACTIVATED
Common Gateway Interface (CGI) DEACTIVATED
Server Side Includes (SSI) ACTIVATED
FTP Service DEACTIVATED

The suggestion, from forum was the same as my current code:
#LoadModule socache_memcache_module modules/mod_socache_memcache.so
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so

#LoadModule socache_memcache_module modules/mod_socache_memcache.so
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so

The suggested line 70 is really line 76

70.SSLPassPhraseDialog builtin
71.
72.# Inter-Process Session Cache:
73.# Configure the SSL Session Cache: First the mechanism
74.# to use and second the expiring timeout (in seconds).
75.#SSLSessionCache "shmcb:C:/xampp/apache/logs/ssl_scache(512000)"
76.SSLSessionCache "shmcb:C:/xampp/apache/logs/ssl_scache(512000)"
77.SSLSessionCacheTimeout 300

I feel that "Common Gateway Interface(CGI)DEACTIVATED" might
be the problem ?
What info do you suggest I submit to to resolve this?
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

Re: PHP Not Working

Postby 12strings » 19. August 2013 03:45

hi guys, I greatly appreciate your efforts. I still haven't
solved the problem(no functioning PHP). I'm running xampp
1.8.2 on win7 32 bit. Apache and Mysql show that they are
running(green) and I'm creating and editing databases. I
cannot start the services? The below is Phpmyadmin status:
----------------------------------------------------
Component
Status
Hint
MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) DEACTIVATED
Server Side Includes (SSI) ACTIVATED
FTP Service ACTIVATED

Some changes to the configuration may sometimes cause false
negatives. All reports viewed with SSL (https://localhost)
do not function!
------------------------------------------------
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

Re: xampp config

Postby Altrea » 19. August 2013 04:58

If you can access the orange XAMPP administration page and you can create and edit databases with phpmyadmin your core components Apache, php and mysql are running.
I don't see what problem you think you have...
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: xampp config

Postby 12strings » 20. August 2013 03:47

Hey fellows,
the suggestion that if one gets to the phpmyadmin page all is well is not exactly true. I'm hopeful
that this post will result in resolution. The below is the copy & paste from Phpmyadmin status:
--------------------------------------------------
You have successfully installed XAMPP on this system!

Component
Status
Hint
MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) [b]DEACTIVATED

Server Side Includes (SSI) ACTIVATED
FTP Service ACTIVATED
----------------------------------------------------- [/b]
Apache, Mysql & Filezilla are running (green) but
I can't start any services. Clicking "maint" neither
Apache nor "Mysql" are present. The fact that Php wouldn't
work is still the case. I will gladly send whatever
documentation suggested. I should add that I've done
an Os reinstallment and downloaded new Microsoft Visual
C++ 2008 Redistributable package & of Xampp 1.8.2.
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

Re: xampp config

Postby Altrea » 20. August 2013 04:40

12strings wrote:the suggestion that if one gets to the phpmyadmin page all is well is not exactly true.

phpmyadmin and the orange XAMPP administration page are both written in PHP, so if they work PHP is working. That is a fact.
If your own php code is not working, it has to be something with your code.

12strings wrote:that this post will result in resolution. The below is the copy & paste from Phpmyadmin status:

That status window is irrelevant for me because it can contain false negatives, but i don't see any problem with result of your statusses itself.

12strings wrote:I can't start any services.

How do you try to register/start services?

12strings wrote:Clicking "maint" neither
Apache nor "Mysql" are present.

What does that mean?

12strings wrote:The fact that Php wouldn't
work is still the case.

And i say PHP IS working. Please give is some insight why YOU think php is not working and what php script.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

still trying to get php to function

Postby 12strings » 11. September 2013 04:25

Hi all, everything seems to work (except php) - I've supplied what I believe to be pertinent info:

phpmyadmin Status display:(keying 127.0.0.1 or admin from control panel)
Component
Status
Hint
MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) DEACTIVATED
Server Side Includes (SSI) ACTIVATED
SMTP Service DEACTIVATED
FTP Service ACTIVATED
Tomcat Service DEACTIVATED
============================================================================
control panel display:
9:00:13 PM [main] Initializing Control Panel
9:00:13 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
9:00:13 PM [main] XAMPP Version: 1.8.2
9:00:13 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
9:00:13 PM [main] Running with Administrator rights - good!
9:00:13 PM [main] XAMPP Installation Directory: "c:\xampp\"
9:00:13 PM [main] Checking for prerequisites
9:00:13 PM [main] All prerequisites found
9:00:13 PM [main] Initializing Modules
9:00:13 PM [Apache] XAMPP Apache Service is already running on port 80
9:00:13 PM [Apache] XAMPP Apache Service is already running on port 443
9:00:13 PM [mysql] XAMPP MySQL Service is already running on port 3306
9:00:13 PM [filezilla] XAMPP FileZilla Service is already running on port 21
9:00:13 PM [filezilla] XAMPP FileZilla Service is already running on port 14147
9:00:13 PM [main] Starting Check-Timer
9:00:13 PM [main] Control Panel ReadyVersion: '5.5.32' socket: '' port: 3306 MySQL Community Server (GPL)
===================================================================================================
mysql error log:
130910 17:35:54 [Note] C:\xampp\mysql\bin\mysqld.exe: Normal shutdown

130910 17:35:54 [Note] Event Scheduler: Purging the queue. 0 events
130910 17:35:54 InnoDB: Starting shutdown...
130910 17:35:56 InnoDB: Shutdown completed; log sequence number 1606765
130910 17:35:56 [Note] C:\xampp\mysql\bin\mysqld.exe: Shutdown complete

130910 17:36:44 [Note] Plugin 'FEDERATED' is disabled.
130910 17:36:44 InnoDB: The InnoDB memory heap is disabled
130910 17:36:44 InnoDB: Mutexes and rw_locks use Windows interlocked functions
130910 17:36:44 InnoDB: Compressed tables use zlib 1.2.3
130910 17:36:44 InnoDB: Initializing buffer pool, size = 16.0M
130910 17:36:44 InnoDB: Completed initialization of buffer pool
130910 17:36:44 InnoDB: highest supported file format is Barracuda.
130910 17:36:44 InnoDB: Waiting for the background threads to start
130910 17:36:45 InnoDB: 5.5.32 started; log sequence number 1606765
130910 17:36:45 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130910 17:36:45 [Note] - '127.0.0.1' resolves to '127.0.0.1';
130910 17:36:45 [Note] Server socket created on IP: '127.0.0.1'.
130910 17:36:45 [Note] Event Scheduler: Loaded 0 events
130910 17:36:45 [Note] C:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.32' socket: '' port: 3306 MySQL Community Server (GPL)
=============================================================================================================
php error log:
[22-Aug-2013 21:37:36 Europe/Berlin] PHP Warning: file_get_contents(lang.tmp): failed to open stream: No such file or directory in C:\xampp\htdocs\xampp\index.php on line 2

====================================================================================================
apache error log:
mpm_winnt:notice] [pid 1484:tid 336] AH00430: Parent: Child process 1968 exited successfully.
[Tue Sep 10 17:36:44.473277 2013] [ssl:warn] [pid 1468:tid 336] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name
[Tue Sep 10 17:36:45.257280 2013] [ssl:warn] [pid 1468:tid 336] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name
[Tue Sep 10 17:36:45.387280 2013] [mpm_winnt:notice] [pid 1468:tid 336] AH00455: Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.16 configured -- resuming normal operations
[Tue Sep 10 17:36:45.387280 2013] [mpm_winnt:notice] [pid 1468:tid 336] AH00456: Server built: Feb 23 2013 13:07:34
[Tue Sep 10 17:36:45.387280 2013] [core:notice] [pid 1468:tid 336] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Sep 10 17:36:45.387280 2013] [mpm_winnt:notice] [pid 1468:tid 336] AH00418: Parent: Created child process 1960
[Tue Sep 10 17:36:46.403286 2013] [ssl:warn] [pid 1960:tid 236] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name
[Tue Sep 10 17:36:46.975288 2013] [ssl:warn] [pid 1960:tid 236] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name
[Tue Sep 10 17:36:47.035288 2013] [mpm_winnt:notice] [pid 1960:tid 236] AH00354: Child: Starting 150 worker threads.
=============================================================================================================
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

Re: xampp config

Postby Altrea » 11. September 2013 06:01

You are just kidding, aren't you?

Stop creating new threads for the same issue (that was the second and last time I merged your threads).
You still haven't told us why you think your php is not working.
Read my last post here and react to it. No information no help.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6697
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests