Apache won't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start

Postby ForbiddenChunk » 20. July 2013 10:56

I have v3.2.1 and it was working fine until one day I came to access it and got the following;

10:54:42 [Apache] Error: Apache shutdown unexpectedly.
10:54:42 [Apache] This may be due to a blocked port, missing dependencies,
10:54:42 [Apache] improper privileges, a crash, or a shutdown by another method.
10:54:42 [Apache] Press the Logs button to view error logs and check
10:54:42 [Apache] the Windows Event Viewer for more clues
10:54:42 [Apache] If you need more help, copy and post this
10:54:42 [Apache] entire log window on the forums

I can't see any obvious reason why?... :?
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache won't start

Postby hackattack142 » 23. July 2013 01:41

Hello,

Could you post the entire XAMPP Control Panel log window and not just the snippet.

Also, are there any errors in your Apache error log and do you get any errors if you run 'apache_start.bat' in the main XAMPP directory
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache won't start

Postby ForbiddenChunk » 05. August 2013 20:05

20:04:32 [main] Initializing Control Panel
20:04:32 [main] Windows Version: Windows 7 Professional SP1 64-bit
20:04:32 [main] XAMPP Version: 1.8.1
20:04:32 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
20:04:32 [main] You are not running with administrator rights! This will work for
20:04:32 [main] most application stuff but whenever you do something with services
20:04:32 [main] there will be a security dialogue or things will break! So think
20:04:32 [main] about running this application with administrator rights!
20:04:32 [main] XAMPP Installation Directory: "c:\xampp\"
20:04:32 [main] Checking for prerequisites
20:04:33 [main] All prerequisites found
20:04:33 [main] Initializing Modules
20:04:33 [Apache] Problem detected!
20:04:33 [Apache] Port 80 in use by "Unable to open process" with PID 4!
20:04:33 [Apache] Apache WILL NOT start without the configured ports free!
20:04:33 [Apache] You need to uninstall/disable/reconfigure the blocking application
20:04:33 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
20:04:33 [mysql] XAMPP MySQL Service is already running on port 3306
20:04:33 [main] Enabling autostart for module "Apache"
20:04:33 [main] Starting Check-Timer
20:04:33 [main] Control Panel Ready
20:04:33 [Apache] Autostart active: starting...
20:04:33 [Apache] Problem detected!
20:04:33 [Apache] Port 80 in use by "Unable to open process" with PID 4!
20:04:33 [Apache] Apache WILL NOT start without the configured ports free!
20:04:33 [Apache] You need to uninstall/disable/reconfigure the blocking application
20:04:33 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
20:04:33 [Apache] Attempting to start Apache app...
20:04:34 [Apache] Status change detected: running
20:04:36 [Apache] Status change detected: stopped
20:04:36 [Apache] Error: Apache shutdown unexpectedly.
20:04:36 [Apache] This may be due to a blocked port, missing dependencies,
20:04:36 [Apache] improper privileges, a crash, or a shutdown by another method.
20:04:36 [Apache] Press the Logs button to view error logs and check
20:04:36 [Apache] the Windows Event Viewer for more clues
20:04:36 [Apache] If you need more help, copy and post this
20:04:36 [Apache] entire log window on the forums


Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : AH00072: make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : AH00072: make_sock: could not bind to address 0.0.0.0:80
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache won't start

Postby Altrea » 05. August 2013 20:12

Known programs / services using port 80 / 443 (as SYSTEM)
  • Internet Information Service (IIS) / World Wide Web Publishing Service (W3SVC)
  • WebMatrix / Web Deployment Agent Service (MsDepSvc)
  • SQL Server Reporting Services (MSSQLSERVER)

Some packages can contain one multiple of these programs, like IDEs as Visual Studio

other programs also using port 80 / 443
  • Skype
  • file sharing programs (torrent etc)
  • remote software (TeamViewer etc)

are you using any of this while starting Apache?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache won't start

Postby ForbiddenChunk » 05. August 2013 20:24

Yeah I use MSSQLSERVER, Visual Studio, Skype, TeamViewer....

Didn't know it conflicted with so many programs :-s
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache won't start

Postby Altrea » 05. August 2013 20:47

Well, Apache needs two ports, one for HTTP communication (Default port 80) and one for HTTPS/SSL (Default port 443).
Surely you can configurate Apache to use different ports, but this can have other side effects with your web applications.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache won't start

Postby ForbiddenChunk » 05. August 2013 21:28

Thanks for getting back to me

What would you suggest I do then? Because I can configure Apache ports but if that cause side effects for my web apps that might not be so good
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache won't start

Postby Altrea » 05. August 2013 22:06

First of all you should identify which service is running and blocking the ports. This will be very common the SQL Server Reporting Services of MSSQLSERVER.
Then you have to decide if you really need this service or maybe you can stop the service for the time you are working with XAMPP.

I would not change Apaches default ports unless it is really needed.
Skype and TeamViewer for example can be configured not to use ports 80 and 443 without any influences for its functionality and most of the users.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache won't start

Postby ForbiddenChunk » 06. August 2013 20:02

Ok I'll give that a try, thanks for your help
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache won't start

Postby ForbiddenChunk » 06. August 2013 21:06

Ok I stopped SQL server reporting services, team viewer and Skype and it still didn't respond

Are you aware of any way round this that will allow these all to run at intermittent times?
ForbiddenChunk
 
Posts: 14
Joined: 29. April 2013 21:24
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache won't start

Postby Altrea » 06. August 2013 21:18

After every change (stopping these programs) check if there is now something different in your log files and log windows.
Maybe you got two issues.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache won't start

Postby kudataz » 07. December 2013 13:47

Altrea wrote:Known programs / services using port 80 / 443 (as SYSTEM)
  • Internet Information Service (IIS) / World Wide Web Publishing Service (W3SVC)
  • WebMatrix / Web Deployment Agent Service (MsDepSvc)
  • SQL Server Reporting Services (MSSQLSERVER)

Some packages can contain one multiple of these programs, like IDEs as Visual Studio

other programs also using port 80 / 443
  • Skype
  • file sharing programs (torrent etc)
  • remote software (TeamViewer etc)

are you using any of this while starting Apache?


how o disable this list sir..? :shock:
  • Internet Information Service (IIS) / World Wide Web Publishing Service (W3SVC)
  • WebMatrix / Web Deployment Agent Service (MsDepSvc)
  • SQL Server Reporting Services (MSSQLSERVER)
kudataz
 
Posts: 8
Joined: 01. December 2013 21:35
XAMPP Version: 5.5.19
Operating System: windows 8.1

Re: Apache won't start

Postby MordaUth » 09. December 2013 04:29

Thank You for posting this list of programs that block Apache Server from running. I was able fix the issue I had and get back up an working again. It was Odd because things were working fine before and then this next time I tried getting in I got the Port issue warning. Still don't know why it worked once then just quit but heh. Windows go figure. LOL
User avatar
MordaUth
 
Posts: 1
Joined: 09. December 2013 04:22
XAMPP Version: 5.5.19
Operating System: Win7 Ult


Return to XAMPP for Windows

Who is online

Users browsing this forum: rherbelin and 31 guests