Custom local IP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Custom local IP

Postby trojansdestroy » 17. July 2013 05:37

I'm running IIS on the same machine as XAMPP 1.8.2 (what my profile says is wrong because the latest option is 1.8.1), with Windows 7. As my primary work is currently through IIS, I need to leave 127.0.0.1 assigned to a site through IIS, and so I'd like to set up a server with IP 127.0.0.6. I also want it in a custom directory, which I believe I've handled, by changing DocumentRoot and the Directory tag to the correct location. I've also changed every instance of "localhost" to the correct IP (127.0.0.6).

I don't know if anything I've done works or not, because I can't get Apache to start. Here's the output through Control Panel 3.2.1:

Code: Select all
9:30:08 PM  [main] Initializing Control Panel
9:30:08 PM  [main] Windows Version: Windows 7 Home Premium SP1 64-bit
9:30:08 PM  [main] XAMPP Version: 1.8.2
9:30:08 PM  [main] Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
9:30:08 PM  [main] You are not running with administrator rights! This will work for
9:30:08 PM  [main] most application stuff but whenever you do something with services
9:30:08 PM  [main] there will be a security dialogue or things will break! So think
9:30:08 PM  [main] about running this application with administrator rights!
9:30:08 PM  [main] XAMPP Installation Directory: "c:\xampp\"
9:30:08 PM  [main] Checking for prerequisites
9:30:08 PM  [main] All prerequisites found
9:30:08 PM  [main] Initializing Modules
9:30:08 PM  [main] Enabling autostart for module "Apache"
9:30:08 PM  [main] Starting Check-Timer
9:30:08 PM  [main] Control Panel Ready
9:30:09 PM  [Apache] Autostart active: starting...
9:30:09 PM  [Apache] Attempting to start Apache app...      ....... Nothing happened here, so I clicked start (I have Apache set to autostart w/Control Panel)
9:30:18 PM  [Apache] Attempting to start Apache app...
9:30:18 PM  [Apache] Status change detected: running
9:30:19 PM  [Apache] Status change detected: stopped
9:30:19 PM  [Apache] Error: Apache shutdown unexpectedly.
9:30:19 PM  [Apache] This may be due to a blocked port, missing dependencies,
9:30:19 PM  [Apache] improper privileges, a crash, or a shutdown by another method.
9:30:19 PM  [Apache] Press the Logs button to view error logs and check
9:30:19 PM  [Apache] the Windows Event Viewer for more clues
9:30:19 PM  [Apache] If you need more help, copy and post this
9:30:19 PM  [Apache] entire log window on the forums


No logs been created yet. The problem persists when running Control Panel as administrator.
trojansdestroy
 
Posts: 2
Joined: 17. July 2013 05:13
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Custom local IP

Postby hackattack142 » 17. July 2013 21:54

Hello,

It sounds like there is probably a syntax issue with your config changes. Try running 'apache_start.bat' in the main XAMPP directory and post any errors it is displaying here (you might have to run it from an already opened command prompt if it closes automatically).
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 702
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Custom local IP

Postby trojansdestroy » 18. July 2013 02:21

apache_start.bat said it could not load modules in httpd.conf, starting at line 72, because the modules could not be found. This line included the path "modules/mod_module_name_here" for each of them. I changed these relative paths to the correct paths ("..\modules\mod_...") and the batch file progressed. It presents the error once again, however, at line 103 (even after changing the path; the file is definitely there).
trojansdestroy
 
Posts: 2
Joined: 17. July 2013 05:13
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Custom local IP

Postby hackattack142 » 18. July 2013 04:00

2 questions:

1. Did you install over a previous installation? (this can cause issues)
2. Did you install with the installer or did you get the zip version? (if you did the zip version, you should run 'setup_xampp.bat' to correct all paths)
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 702
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests