Apache not starting while using a folder outside XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache not starting while using a folder outside XAMPP

Postby Jobin » 06. July 2013 16:48

I have Installed XAMPP and it is working fine in my machine. There was an issue with the port so I changed the port to 81 so my local host is working fine with this url http://localhost:81/wordpress/ (the wordpress folder located inside xampp/htdocs folder).

I am facing another issue , now Iam trying to configure another website that is outside the XAMPP folder. So I modified the httpd-xampp.conf file as follows

Alias /testproject "D:/Work/testproject/"
<Directory "D:/Work/testproject/">
Options Indexes +FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>

I have restored the project database named "testproject" in phpmyadmin

I am using XAMPP 1.8.1

So the issue is I can't start the apache service , Showing an error like,

Error: Apache shutdown unexpectedly.
6:53:37 PM [Apache] This may be due to a blocked port, missing dependencies,
6:53:37 PM [Apache] improper privileges, a crash, or a shutdown by another method.
6:53:37 PM [Apache] Check the "/xampp/apache/logs/error.log" file
6:53:37 PM [Apache] and the Windows Event Viewer for more clues

If i removed the above code from httpd-xampp.conf file, the apache will works fine..

Is that possible to suggest any solutions? Or is there any other settings or files need to change?. I tried my level best to fix this issue, nothing works.
Help really appreciable..
Jobin
 
Posts: 1
Joined: 06. July 2013 16:31
Operating System: Windows 7

Re: Apache not starting while using a folder outside XAMPP

Postby hackattack142 » 07. July 2013 19:50

Hello,

It looks like you are using old Apache 2.2 syntax which does not work in Apache 2.4.

Try replacing
Order allow,deny
Allow from all
with
Require all granted

You can also look at the other alias entries in /xampp/apache/conf/extra/httpd-xampp.conf
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache not starting while using a folder outside XAMPP

Postby Altrea » 07. July 2013 23:07

Hi Jobin,

The old access syntax is not the issue your Apache crashes but the rules could be ignored if mixing old syntax with the new one (which uses XAMPP base configuration).

Your issue is the following (error message i get on my test environment from apache_start.bat):
Either all Options must start with + or -, or no Option may.


so you have to correct this line:
Code: Select all
Options Indexes +FollowSymLinks Includes ExecCGI


best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 95 guests