Problems Installing XAMPP 1.8.2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems Installing XAMPP 1.8.2

Postby gramost » 05. July 2013 19:22

I get this message after installing XAMPP1.8.2 and do not know what to do. Could you help me please??

12:55:06 p.m. [main] Starting Check-Timer
12:55:06 p.m. [main] Control Panel Ready
12:57:51 p.m. [Apache] Problem detected!
12:57:51 p.m. [Apache] Port 80 in use by "Unable to open process" with PID 4!
12:57:51 p.m. [Apache] Apache WILL NOT start without the configured ports free!
12:57:51 p.m. [Apache] You need to uninstall/disable/reconfigure the blocking application
12:57:51 p.m. [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:57:51 p.m. [Apache] Attempting to start Apache app...
12:57:51 p.m. [Apache] Status change detected: running
12:57:53 p.m. [Apache] Status change detected: stopped
12:57:53 p.m. [Apache] Error: Apache shutdown unexpectedly.
12:57:53 p.m. [Apache] This may be due to a blocked port, missing dependencies,
12:57:53 p.m. [Apache] improper privileges, a crash, or a shutdown by another method.
12:57:53 p.m. [Apache] Press the Logs button to view error logs and check
12:57:53 p.m. [Apache] the Windows Event Viewer for more clues
12:57:53 p.m. [Apache] If you need more help, copy and post this
12:57:53 p.m. [Apache] entire log window on the forums
Posts: 1
Joined: 05. July 2013 19:08
Operating System: Windows 7

Re: Problems Installing XAMPP 1.8.2

Postby Altrea » 05. July 2013 21:47

Hi gramost,

This way please: viewtopic.php?f=16&t=55579&p=209427#p209427

Best wishes,
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
AF Moderator
Posts: 8243
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problems Installing XAMPP 1.8.2

Postby robothos » 09. July 2013 13:25

Hi gramost,

This means you'll have to change the port in the configuration file. You just need to:
- start the XAMPP "Control Panel"
- press the button "Config" for Apache
- in the menu that opens choose "Apache (httpd.conf)" and click on it
- in the text that opens find "Listen 80" and change it to "Listen 81"
- now in the same text find "ServerName localhost:80" and change it to "ServerName localhost:81"
- close the text
- in "XAMPP Control Panel" click on Start"

It should work now.

Posts: 3
Joined: 09. July 2013 10:54
Operating System: Windows 8, XAMPP 1.8.2

Re: Problems Installing XAMPP 1.8.2

Postby elpida » 15. November 2013 11:46

Hi there!

I tried to change the port to 81 but even like that didnt work.

turned off my firewall and antivirus but nothing changed.
Posts: 1
Joined: 15. November 2013 11:42
Operating System: windows 7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests