issue opening image from website

Problems with the Windows version of XAMPP, questions, comments, and anything related.

issue opening image from website

Postby Jaykappy » 05. July 2013 04:17

I can upload the image to my website folders
I can see the image in the mysql table
I can open the image via explorer

But when I try and open it via chrome i get this error below....

THe url adn folder and image name are correct in the url...
looks like there is no access to the image via xampp...

http://localhost/VisualUpload/uploads/30/42.jpg

Any thoughts?

Thanks



Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500

localhost
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7
Jaykappy
 
Posts: 14
Joined: 28. May 2013 19:50
Operating System: Win 8

Re: issue opening image from website

Postby Jaykappy » 05. July 2013 04:20

Maybe because I locked the xampp folders?
is there a way to take the password off for testing?


Subject
Status

These XAMPP pages are no longer accessible by network for everyone SECURE
The MySQL admin user root has no longer no password SECURE
PhpMyAdmin password login is enabled. SECURE
A FTP server is not running or is blocked by a firewall! UNKNOWN
Last edited by Jaykappy on 05. July 2013 04:26, edited 1 time in total.
Jaykappy
 
Posts: 14
Joined: 28. May 2013 19:50
Operating System: Win 8

Re: issue opening image from website

Postby Jaykappy » 05. July 2013 04:25

i dug into the htaccess file on and see this....I assume this is where I might be blocking the viewing of the image?

C:\xampp\security\htdocs

AuthName "xampp user"
AuthType Basic
AuthUserFile "C:\xampp\security\xampp.users"
require valid-user
Jaykappy
 
Posts: 14
Joined: 28. May 2013 19:50
Operating System: Win 8

Re: issue opening image from website

Postby Jaykappy » 05. July 2013 04:29

think i found it.....I had the below in the htaccess file in the folder that houses the images....where they were uploaded....I removed it and I was able to see and open the image....what is the below doing?

In the htaccess file...once removed it worked....

Option -Indexes
Jaykappy
 
Posts: 14
Joined: 28. May 2013 19:50
Operating System: Win 8

Re: issue opening image from website

Postby Jaykappy » 05. July 2013 04:39

This was not an issue in IIS.....seems to be only an apache issue....how to fix?
Jaykappy
 
Posts: 14
Joined: 28. May 2013 19:50
Operating System: Win 8

Re: issue opening image from website

Postby JJ_Tagy » 05. July 2013 11:23

That command is not a bug. Apache uses it to allow (or in this case deny) access to a folder by navigation alone. Your site must link a file from it.

http://wiki.apache.org/httpd/DirectoryListings

As for the XAMPP folder being locked, that has nothing to do with this unless you are referencing a file inside. We don't see your scripts or htaccess so we can only guess.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: issue opening image from website

Postby Altrea » 05. July 2013 12:50

An "HTTP Error 500" will be logged somewhere.
We can only guess what is going on without the information of your
  • \xampp\apache\logs\error.log
  • \xampp\php\logs\php_error_log
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests