XAMPP Apache Error 500

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Apache Error 500

Postby ThePie » 23. June 2013 01:18

I'm having trouble with XAMPP. I'm on Win 7 32 bit. In the MySQL admin button works fine in the xampp control panel but the Apache admin button brings me to the webpage below. I ran the test_php and the command prompt window is what I get. On my Other laptop I just plug in the flash drive and it works fine. (I have XAMPP 1.8.1 portable by the way). I was using both admin control buttons fine and now only the MySQL one works. Don't no why its saying I don't have the Microsoft Visual C++ 2008 not installed cause I reinstalled it like 5 times. Any suggestions?

CHANGING TITLE TO XAMPP APACHE ERROR 500, since that's what I'm getting when I try to access http://localhost/xampp/

Image
Image
Last edited by ThePie on 23. June 2013 19:53, edited 1 time in total.
ThePie
 
Posts: 7
Joined: 23. June 2013 00:23
XAMPP Version: 5.6.3
Operating System: Windows 7 32 bit

Re: XAMPP Apache Admin Control Not Working

Postby hackattack142 » 23. June 2013 03:03

Hello,

Are you saying that http://localhost/phpmyadmin works fine but http://localhost/xampp does not?

It looks like your Apache is running and you PHP works so it is not likely a C++ Runtimes issue.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 702
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP Apache Admin Control Not Working

Postby ThePie » 23. June 2013 03:09

hackattack142 wrote:Hello,

Are you saying that http://localhost/phpmyadmin works fine but http://localhost/xampp does not?

It looks like your Apache is running and you PHP works so it is not likely a C++ Runtimes issue.


Do you no what it could be cause php is good but xampp url is not.
ThePie
 
Posts: 7
Joined: 23. June 2013 00:23
XAMPP Version: 5.6.3
Operating System: Windows 7 32 bit

Re: XAMPP Apache Admin Control Not Working

Postby Altrea » 23. June 2013 07:09

Contents of your \xampp\php\logs\php_error_log?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP Apache Admin Control Not Working

Postby ThePie » 23. June 2013 19:42

Altrea wrote:Contents of your \xampp\php\logs\php_error_log?

Error log file is empty. (It has the contents from other PC) (Trying to get it to work on this one, so its not empty empty but has no info on this PC).
ThePie
 
Posts: 7
Joined: 23. June 2013 00:23
XAMPP Version: 5.6.3
Operating System: Windows 7 32 bit

Re: XAMPP Apache Error 500

Postby Altrea » 23. June 2013 20:08

okay...
then contents of your \xampp\apache\logs\error.log

somewhere the error has to be logged.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP Apache Error 500

Postby ThePie » 23. June 2013 21:24

Altrea wrote:okay...
then contents of your \xampp\apache\logs\error.log

somewhere the error has to be logged.


This is the contents of the log file from today. It's on my 8GB SanDisk flash drive that has 6GB of free space left on it. XAMPP portable 1.8.1 is installed on here btw. Not sure if I mentioned that or not.

Code: Select all
[Sun Jun 23 13:42:48.975286 2013] [core:warn] [pid 4372:tid 216] AH00098: pid file E:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Jun 23 13:42:49.583687 2013] [ssl:warn] [pid 4372:tid 216] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Jun 23 13:42:50.519689 2013] [mpm_winnt:notice] [pid 4372:tid 216] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Sun Jun 23 13:42:50.519689 2013] [mpm_winnt:notice] [pid 4372:tid 216] AH00456: Server built: Aug 18 2012 12:41:37
[Sun Jun 23 13:42:50.519689 2013] [core:notice] [pid 4372:tid 216] AH00094: Command line: 'e:\\website design\\xampp\\xampp v1.8.1\\xampp-portable\\apache\\bin\\httpd.exe -d E:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/apache'
[Sun Jun 23 13:42:50.535289 2013] [mpm_winnt:notice] [pid 4372:tid 216] AH00418: Parent: Created child process 5180
[Sun Jun 23 13:42:52.594492 2013] [ssl:warn] [pid 5180:tid 228] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Jun 23 13:42:52.750493 2013] [mpm_winnt:notice] [pid 5180:tid 228] AH00354: Child: Starting 150 worker threads.
[Sun Jun 23 13:42:58.257302 2013] [authn_file:error] [pid 5180:tid 1652] (OS 3)The system cannot find the path specified.  : [client ::1:1136] AH01620: Could not open password file: C:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/security/xampp.users
[Sun Jun 23 13:47:09.417544 2013] [authn_file:error] [pid 5180:tid 1648] (OS 3)The system cannot find the path specified.  : [client ::1:1183] AH01620: Could not open password file: C:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/security/xampp.users
[Sun Jun 23 13:47:13.239551 2013] [authn_file:error] [pid 5180:tid 1624] (OS 3)The system cannot find the path specified.  : [client ::1:1184] AH01620: Could not open password file: C:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/security/xampp.users
[Sun Jun 23 13:48:00.133233 2013] [core:warn] [pid 2628:tid 216] AH00098: pid file E:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Jun 23 13:48:00.710434 2013] [ssl:warn] [pid 2628:tid 216] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Jun 23 13:48:00.866434 2013] [mpm_winnt:notice] [pid 2628:tid 216] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Sun Jun 23 13:48:00.866434 2013] [mpm_winnt:notice] [pid 2628:tid 216] AH00456: Server built: Aug 18 2012 12:41:37
[Sun Jun 23 13:48:00.866434 2013] [core:notice] [pid 2628:tid 216] AH00094: Command line: 'e:\\website design\\xampp\\xampp v1.8.1\\xampp-portable\\apache\\bin\\httpd.exe -d E:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/apache'
[Sun Jun 23 13:48:00.991234 2013] [mpm_winnt:notice] [pid 2628:tid 216] AH00418: Parent: Created child process 4888
[Sun Jun 23 13:48:03.003638 2013] [ssl:warn] [pid 4888:tid 228] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Jun 23 13:48:03.159638 2013] [mpm_winnt:notice] [pid 4888:tid 228] AH00354: Child: Starting 150 worker threads.
[Sun Jun 23 13:52:41.154127 2013] [authn_file:error] [pid 4888:tid 1656] (OS 3)The system cannot find the path specified.  : [client 127.0.0.1:1213] AH01620: Could not open password file: C:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/security/xampp.users
[Sun Jun 23 13:52:49.078941 2013] [authn_file:error] [pid 4888:tid 1648] (OS 3)The system cannot find the path specified.  : [client 127.0.0.1:1212] AH01620: Could not open password file: C:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/security/xampp.users, referer: http://127.0.0.1/xampp/
[Sun Jun 23 13:54:07.391078 2013] [authn_file:error] [pid 4888:tid 1648] (OS 3)The system cannot find the path specified.  : [client ::1:1223] AH01620: Could not open password file: C:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/security/xampp.users
ThePie
 
Posts: 7
Joined: 23. June 2013 00:23
XAMPP Version: 5.6.3
Operating System: Windows 7 32 bit

Re: XAMPP Apache Error 500

Postby Altrea » 23. June 2013 21:27

[Sun Jun 23 13:54:07.391078 2013] [authn_file:error] [pid 4888:tid 1648] (OS 3)The system cannot find the path specified. : [client ::1:1223] AH01620: Could not open password file: C:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/security/xampp.users

There is your error. For any reason XAMPP is searching for a password file on your local harddisk.
My recommandation would be to disable the folder protection by deleting the .htaccess file in your \xampp\htdocs\xampp\ folder.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP Apache Error 500

Postby ThePie » 23. June 2013 21:52

Altrea wrote:
[Sun Jun 23 13:54:07.391078 2013] [authn_file:error] [pid 4888:tid 1648] (OS 3)The system cannot find the path specified. : [client ::1:1223] AH01620: Could not open password file: C:/Website Design/XAMPP/XAMPP v1.8.1/xampp-portable/security/xampp.users

There is your error. For any reason XAMPP is searching for a password file on your local harddisk.
My recommandation would be to disable the folder protection by deleting the .htaccess file in your \xampp\htdocs\xampp\ folder.


Ahh ok thank you for that. Now I noticed that when I go to http://localhost/security/lang.php?en by clicking the security tab in localhost/xampp it has the error 500 on that page instead of the security information.
ThePie
 
Posts: 7
Joined: 23. June 2013 00:23
XAMPP Version: 5.6.3
Operating System: Windows 7 32 bit

Re: XAMPP Apache Error 500

Postby Altrea » 23. June 2013 21:55

There is another .htaccess file in \xampp\security\htdocs\
Delete it too.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP Apache Error 500

Postby ThePie » 23. June 2013 22:06

Altrea wrote:There is another .htaccess file in \xampp\security\htdocs\
Delete it too.


Ok thanks for all your help. Will deleting either of those files have any effect on anything?
ThePie
 
Posts: 7
Joined: 23. June 2013 00:23
XAMPP Version: 5.6.3
Operating System: Windows 7 32 bit

Re: XAMPP Apache Error 500

Postby Altrea » 23. June 2013 22:07

They are just for the folder protection, which you normally would not need on development/test instances.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP Apache Error 500

Postby ThePie » 23. June 2013 22:14

Altrea wrote:They are just for the folder protection, which you normally would not need on development/test instances.


Oh ok. Thanks again for all your help with this stuff.
ThePie
 
Posts: 7
Joined: 23. June 2013 00:23
XAMPP Version: 5.6.3
Operating System: Windows 7 32 bit

Re: XAMPP Apache Error 500

Postby Altrea » 23. June 2013 22:46

You are welcome.
Have fun with XAMPP and all that stuff 8)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: Ecklory and 75 guests