htdocs

Problems with the Windows version of XAMPP, questions, comments, and anything related.

htdocs

Postby Sil » 17. May 2004 15:19

I don't want HTDOCS to be my public folder.. but my D partition... How can i do that?
User avatar
Sil
 
Posts: 1
Joined: 17. May 2004 15:17

Postby myhelipad » 18. May 2004 04:42

open file httpd.conf on x:\xampp\apache\conf directory, find
Code: Select all
DocumentRoot
it's looks like this
Code: Select all
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "/xampp/htdocs"


Change "x:/xampp/htdocs" to directory you want, eg: c:\www.

After finish editing then restart your xampp or your server... :lol:
User avatar
myhelipad
 
Posts: 13
Joined: 01. March 2004 04:48
Location: Malaysia

Postby Huxxx » 24. May 2004 10:50

dont think its that easy. Other things wont work anymore if you change this.
Huxxx
 
Posts: 3
Joined: 21. May 2004 15:34

Postby BlackbirdHakke » 24. May 2004 11:50

HI,

you have to change TWO entries in your httpd.conf:
#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "L:/XAMPP/minixampp/htdocs"

and
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "L:/XAMPP/minixampp/htdocs">


greets, Flo
~ich bin, denke ich~
Ishundia - das RPG
BlackbirdHakke
 
Posts: 89
Joined: 24. February 2004 08:51

Postby schamock » 24. May 2004 12:40

hi flo
i have the same problem. i changed both directorys into

Code: Select all
G:/ftp/bnb/wwwsite


but the server still shows the

Code: Select all
file://localhost/D:/Communication/XAMPP/xampp/install/start.html


when it starts.

if i want to go to localhost in my browser, it shows all my drives...

what am i doing wrong???

thx
schamock
 
Posts: 2
Joined: 24. May 2004 12:37

Postby schamock » 24. May 2004 12:49

sorry
my fault
-> clear cache -> it works
schamock
 
Posts: 2
Joined: 24. May 2004 12:37

Postby myhelipad » 25. May 2004 01:30

BlackbirdHakke wrote:HI,

you have to change TWO entries in your httpd.conf:
#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "L:/XAMPP/minixampp/htdocs"

and
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "L:/XAMPP/minixampp/htdocs">


greets, Flo


sorry its my fault forgot to inform about second one, thanks BlackbirdHakke
..::help me to help someone else::..
User avatar
myhelipad
 
Posts: 13
Joined: 01. March 2004 04:48
Location: Malaysia

Postby free69 » 03. June 2004 14:43

Gentlemen,
Don't you have any problem to change httpd.conf only?
I think install/start.html and htdocs/xampp/*.php must be changed too.

It is very differcult job.
free69
 
Posts: 35
Joined: 02. June 2004 05:52

Postby BlackbirdHakke » 04. June 2004 08:22

Hi,

what for?

greets, Flo
~ich bin, denke ich~
Ishundia - das RPG
BlackbirdHakke
 
Posts: 89
Joined: 24. February 2004 08:51

Postby MAGnUm » 08. June 2004 01:01

nope
~~:M A G n U m:~~
(Disclaimer: if any of this info is confusing or vague tough, its free!!)
User avatar
MAGnUm
 
Posts: 151
Joined: 16. October 2003 18:08
Location: USA

Postby free69 » 08. June 2004 01:09

Nope? - What is it?
free69
 
Posts: 35
Joined: 02. June 2004 05:52

Postby BlackbirdHakke » 08. June 2004 07:31

What for do you want to change:

Don't you have any problem to change httpd.conf only?
I think install/start.html and htdocs/xampp/*.php must be changed too.

?

For making any directory work as webfolder, just these two settings have to be made, because this is the the apaches main setting for webroot.

What for do you want to edit start.html? You can replace it with your own, but in fact everyone should know that.

Now you can tell us whats wrong with a better description, if theres still any problem with your XAMPP.

@schamock:

Did you restart apache, and/or did you really edit the httpd.conf (and not httpd.old.conf for example)

Nope means no.

greets, Flo
~ich bin, denke ich~
Ishundia - das RPG
BlackbirdHakke
 
Posts: 89
Joined: 24. February 2004 08:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests