need help xampp configuration

Problems with the Windows version of XAMPP, questions, comments, and anything related.

need help xampp configuration

Postby 12strings » 11. June 2013 02:40

Hi guys, my xampp has been useless for weeks & You have always led me
back on the path & I thank you in advance. I was determined to conquer
this own but all this trial error & reading hundreds of posts I haven't
quite made it.
I'm running windows7 64 & 32 bit. I can't access to phpmyadmin.
I used 1.7.3 for years w/no probs & just got a wild hair.
I have documentation. If you're willing to help Just tell
what to do.
========================================================
here is the message at the bottom of the control panel
before startup of the server:

8
:23:18 PM [main] Initializing Control Panel
8:23:18 PM [main] Windows Version: Windows 7 Ultimate SP1 64-bit
8:23:18 PM [main] XAMPP Version: 1.8.1
8:23:18 PM [main] Control Panel Version: 3.1.0 Beta 6 [ Compiled: September 20th 2012 ]
8:23:18 PM [main] Running with Administrator rights - good!
8:23:18 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:23:18 PM [main] Checking for prerequisites
8:23:19 PM [main] All prerequisites found
8:23:19 PM [main] Initializing Modules
8:23:19 PM [main] Starting Check-Timer
8:23:19 PM [main] Control Panel Ready

===================================================================
here is the error log:

Digest: generating secret for digest authentication ...
[Sat Apr 13 19:11:29 2013] [notice] Digest: done
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Child process is running
Sat Apr 13 19:11:30 2013] [notice] Child 5740: Acquired the start mutex.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting 150 worker threads.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting thread to listen on port 443.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting thread to listen on port 80.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting thread to listen on port 443.
[Sat Apr 13 19:11:30 2013] [notice] Child 5740: Starting thread to listen on port 80.
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

==================================================================
and this display when I click on the services. mysql stays on and apache
shuts off immediatey:

8:28:56 PM [main] Initializing Control Panel
8:28:56 PM [main] Windows Version: Windows 7 Ultimate SP1 64-bit
8:28:56 PM [main] XAMPP Version: 1.8.1
8:28:56 PM [main] Control Panel Version: 3.1.0 Beta 6 [ Compiled: September 20th 2012 ]
8:28:56 PM [main] Running with Administrator rights - good!
8:28:56 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:28:56 PM [main] Checking for prerequisites
8:28:56 PM [main] All prerequisites found
8:28:56 PM [main] Initializing Modules
8:28:56 PM [main] Starting Check-Timer
8:28:56 PM [main] Control Panel Ready
8:29:23 PM [Apache] Attempting to start Apache app...
8:29:24 PM [Apache] Status change detected: running
8:29:24 PM [mysql] Attempting to start MySQL app...
8:29:25 PM [mysql] Status change detected: running
8:29:27 PM [Apache] Status change detected: stopped
8:29:27 PM [Apache] Error: Apache shutdown unexpectedly.
8:29:27 PM [Apache] This may be due to a blocked port, missing dependencies,
8:29:27 PM [Apache] improper privileges, a crash, or a shutdown by another method.
8:29:27 PM [Apache] Check the "/xampp/apache/logs/error.log" file
8:29:27 PM [Apache] and the Windows Event Viewer for more clues

12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit

Re: need help xampp configuration

Postby hackattack142 » 11. June 2013 04:30

Hello,

That Apache error suggests that something is already listening on port 80 which is blocking Apache from listening on that port.

You have a couple options:
1. Hunt down which program is blocking and reconfigure/stop it (open a command prompt [Start -> Run -> cmd] and run "netstat -nabo" look for what is listening on port 80)
2. Reconfigure Apache to listen on a different port (you will also need to tell the XAMPP Control Panel about the new port as well)
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: need help xampp configuration

Postby 12strings » 13. June 2013 21:46

hackattack, thanks so much for your input.
In an attempt to bury myself
in this sea of misery, installed Xampp 1.7.3.
finally it seemed that I'd got it. I said
"127.0.0.1 "and phpmyadmin said "whatuwant" & we
created a new database "passdb"and he said
"create a table and I did "passtbl".
when I hit save or ok or go or
whateverthehell, he said "that table already
exists" & I looked over to the left and saw
"passdb(1) passtbl(0). Not to be defeated,
I let him lead me through all
this again (exactly). Third times a charm;
Repeated it all, this time just one record,
clicked "browse, sql, import. Now I've got
it. NOT!". syntax error". Let me stop rambling
here. I went to my databases & looked up the passtbl
sql. Well this sql is the only one in the list
that had the tag of FRM. Ok I changed it to "sql"
and headed back in. Only thing is, now it asked
for username & password via the message below:

Authentication Required
A username and password are being requested
by http://127.0.0.1. The site says
"xamp user"
username: xxxxx
password: ######

I tried repeatedly to get around that sucker.
Aint happenin'!. Looking at configs.......:
I left everything to default other than
Phpmyadmin/config.inc.php, code below:

Code: Select all
<?php$cfg['blowfish_secret'] = 'Imad@u4thi$';
$i = 0;$i++;
$cfg['Servers'][$i]['auth_type']            = 'config';
$cfg['Servers'][$i]['user']                 = 'root';
$cfg['Servers'][$i]['password']             = '';
$cfg['Servers'][$i]['AllowNoPassword']      = true;
$cfg['Servers'][$i]['host']             = 'localhost';
$cfg['Servers'][$i]['connect_type']     = 'tcp';
$cfg['Servers'][$i]['compress']         = false;
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';
$cfg['Servers'][$i]['pmadb']            = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable']    = 'pma_bookmark';
$cfg['Servers'][$i]['relation']         = 'pma_relation';
$cfg['Servers'][$i]['table_info']       = 'pma_table_info';
$cfg['Servers'][$i]['table_coords']     = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages']        = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info']      = 'pma_column_info';
$cfg['Servers'][$i]['history']          = 'pma_history';
$cfg['Servers'][$i]['designer_coords']  = 'pma_designer_coords';
$cfg['UploadDir']   = '';
$cfg['SaveDir']     = '';
$cfg['AllowAnywhereRecoding']       = true;
$cfg['DefaultCharset']              = 'utf-8';
$cfg['DefaultLang']                 = 'en-utf-8';
$cfg['DefaultConnectionCollation']  = 'utf8_general_ci';
$cfg['MySQLManualBase'] = 'http://dev.mysql.com/doc/refman/5.1/en';
$cfg['MySQLManualType'] = 'searchable';


All the rest I left to default. Please, help!
Oh, I need to add that I haven't found, with this version,the error logs
12strings
 
Posts: 23
Joined: 04. April 2013 17:56
XAMPP Version: 5.6.3
Operating System: win 7 64 bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests