404 trying to access localhost htdocs

Problems with the Windows version of XAMPP, questions, comments, and anything related.

404 trying to access localhost htdocs

Postby BruceChittenden » 10. June 2013 13:34

I just did an install of xampp 1.8.1 (all defaults), I started apache (works fine), but I cannot access htdocs/index.html. I get the 404 error. I have read all the forms and I have not seen anything related to this issue. Can someone please help me. Thanks in advance. Bruce
BruceChittenden
 
Posts: 3
Joined: 10. June 2013 13:09
XAMPP Version: 5.6.3
Operating System: Window 7

Re: 404 trying to access localhost htdocs

Postby Altrea » 10. June 2013 15:05

What is the contents of your browsers address by at the time you are getting this error?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6617
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: 404 trying to access localhost htdocs

Postby BruceChittenden » 10. June 2013 16:10

http://localhost/index.html/
BruceChittenden
 
Posts: 3
Joined: 10. June 2013 13:09
XAMPP Version: 5.6.3
Operating System: Window 7

Re: 404 trying to access localhost htdocs

Postby BruceChittenden » 10. June 2013 18:33

Some additional data. I can access this file with apache by using the address 127.0.0.1/index.html Does that help with the problem of localhost?
BruceChittenden
 
Posts: 3
Joined: 10. June 2013 13:09
XAMPP Version: 5.6.3
Operating System: Window 7

Re: 404 trying to access localhost htdocs

Postby CraftyMc » 19. June 2013 02:29

i'm pretty sure it's because you haven't forwarded ports 80 and 443. either this or you have changed Apache's default port and not forwarded it.
CraftyMc
 
Posts: 13
Joined: 18. June 2013 20:11
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: 404 trying to access localhost htdocs

Postby hackattack142 » 19. June 2013 02:43

Hello,

Ports do not need to be forwarded on localhost/127.0.0.1 as the connection never leaves your system.

If you can access via 127.0.0.1 and not localhost, there might be an issue with your HOSTS file (C:\Windows\System32\drivers\etc\hosts).

Make sure the following line exists in that file
Code: Select all
   127.0.0.1       localhost
and does not have a '#' in front of it.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests