dl() Not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

dl() Not working

Postby thilmca » 04. June 2013 06:39

Dear Friends,

I need to read a test.so file using dl() method. Its not working in latest version of xampp. am using xampp 1.8.0. Please help me to fix the issue.
thilmca
 
Posts: 1
Joined: 04. June 2013 06:30
Operating System: windows

Re: dl() Not working

Postby JJ_Tagy » 04. June 2013 07:38

This may be related as I believe we now run php 5.4
http://stackoverflow.com/questions/1222 ... nabling-dl
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: dl() Not working

Postby Altrea » 04. June 2013 12:36

Hi thilmca,

As JJ_Tagy already mentioned, dl() is only supported in specific Server APIs. PHP in XAMPP is running as Apache Module so it uses the SAPI apache2handler. This SAPI doesn't have any support for dl().

The other thing:
http://www.php.net/manual/en/function.dl.php wrote:Note:

dl() is not supported when PHP is built with ZTS support. Use the Extension Loading Directives instead.

ZTS stands for Zend Thread Safety. PHP in XAMPP is build as thread-safe (TS) so it is not supported. Sorry.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests