Apache won't start.Again!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start.Again!

Postby kirwood » 24. May 2013 13:16

Hi,
You will see from an earlier post that I had Apache running.
I then added a new entry to httpd-vhosts and hosts and the Apache server crashed.
Nothing in error log but in Event Viewer it said my version of Notepad and Notepad+++ were not compatible with Win 8 64 bit. I have now installed the latest version, deleted and reloaded both files.
Apache crashed again. This time all the error logs were clear, nothing.
This is what I added to the two files.
127.0.0.1 fhm
<VirtualHost *:80>
DocumentRoot "D:/FullHouseMarketing"
ServerName fhm
<Directory "D:/FullHouseMarketing">
Order allow,deny
Allow from all
Require all granted
</Directory>
</VirtualHost>

I am reluctant to uninstall Apache and start again because I am not sure how to go about it with a 64 bit windows version. The existing Apache was installed by the people who upgraded the pc to 64 bit.

Help appreciated
Kirwood
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache won't start.Again!

Postby Nobbie » 24. May 2013 21:21

kirwood wrote:This is what I added to the two files.


You really added ALL LINES to both "hosts" and "httpd-vhosts.conf"?
Nobbie
 
Posts: 6491
Joined: 09. March 2008 13:04

Re: Apache won't start.Again!

Postby kirwood » 27. May 2013 16:30

No.
I added 127.0.0.1 fhm to the hosts file
and
<VirtualHost *:80>
DocumentRoot "D:/FullHouseMarketing"
ServerName fhm
<Directory "D:/FullHouseMarketing">
Order allow,deny
Allow from all
Require all granted
</Directory>
</VirtualHost>
to httpd-vhosts.conf file.
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache won't start.Again!

Postby Altrea » 27. May 2013 17:39

Your configuration is working on my W7 Testmachine.
What happens if you execute your \xampp\apache_start.bat file in your Windows command line?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6482
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache won't start.Again!

Postby kirwood » 28. May 2013 11:26

Hi,
From command prompt I worked out there was a port conflict.
It was that pesky Skype again.
Uninstalled Skype and Apache is fine.

Problem is I do use Skype as well.
Tried changing Apache ports from 80 and 443 to 3939 and 444 but Apache would not start.
Any suggestions as to how I can run both? In the Windows 8 version of Skype you cannot change Skype ports.

kirwood
ps can a file be attached to a post in this forum?
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache won't start.Again!

Postby Altrea » 28. May 2013 11:43

In your Skype configuration there is a checkfield that Skype don't uses port 80 and 443.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6482
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests